kernel: remove useless AddDepends/hid abstraction
authorFelix Fietkau <nbd@openwrt.org>
Sun, 29 Mar 2015 08:12:31 +0000 (08:12 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 29 Mar 2015 08:12:31 +0000 (08:12 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 45134

package/kernel/linux/modules/001-depends.mk
package/kernel/linux/modules/input.mk
package/kernel/linux/modules/other.mk
package/kernel/linux/modules/usb.mk

index e845670ec8f6639e8a10278569f2acfea7a4c2a1..57fc9abf73f3c0b43645f60a865cc15145c985c1 100644 (file)
@@ -5,10 +5,6 @@
 # See /LICENSE for more information.
 #
 
-define AddDepends/hid
-  DEPENDS+= +kmod-hid $(1)
-endef
-
 define AddDepends/input
   DEPENDS+= +kmod-input-core $(1)
 endef
index 2320b051f9f366c6307062561636f26a247e6480..1e8b2f0257ea98a227dcb1681543afe482581218 100644 (file)
@@ -25,10 +25,10 @@ $(eval $(call KernelPackage,hid))
 define KernelPackage/hid-generic
   SUBMENU:=$(INPUT_MODULES_MENU)
   TITLE:=Generic HID device support
+  DEPENDS:=+kmod-hid
   KCONFIG:=CONFIG_HID_GENERIC
   FILES:=$(LINUX_DIR)/drivers/hid/hid-generic.ko
   AUTOLOAD:=$(call AutoProbe,hid-generic)
-  $(call AddDepends/hid)
 endef
 
 define KernelPackage/hid/description
index 1644f77ce44261c8232ccf439e596c0bd2a063cd..c27048193277bb9fe3e2650732aa03b310f27f2c 100644 (file)
@@ -29,7 +29,7 @@ $(eval $(call KernelPackage,6lowpan-iphc))
 define KernelPackage/bluetooth
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Bluetooth support
-  DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-crypto-hash +!LINUX_3_10:kmod-6lowpan-iphc +kmod-lib-crc16
+  DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-crypto-hash +!LINUX_3_10:kmod-6lowpan-iphc +kmod-lib-crc16 +kmod-hid
   KCONFIG:= \
        CONFIG_BLUEZ \
        CONFIG_BLUEZ_L2CAP \
@@ -50,7 +50,6 @@ define KernelPackage/bluetooth
        CONFIG_BT_HCIUART_H4 \
        CONFIG_BT_HIDP \
        CONFIG_HID_SUPPORT=y
-  $(call AddDepends/hid)
   $(call AddDepends/rfkill)
   FILES:= \
        $(LINUX_DIR)/net/bluetooth/bluetooth.ko \
index 74d9e6f1ec24169751826a9243b0048d7a982670..ef803f3eb35e58faf0217b294c00a24f92a227db 100644 (file)
@@ -1311,10 +1311,10 @@ $(eval $(call KernelPackage,usb-net-kalmia))
 define KernelPackage/usb-hid
   TITLE:=Support for USB Human Input Devices
   KCONFIG:=CONFIG_HID_SUPPORT=y CONFIG_USB_HID CONFIG_USB_HIDDEV=y
+  DEPENDS:=+kmod-hid +kmod-hid-generic
   FILES:=$(LINUX_DIR)/drivers/$(USBHID_DIR)/usbhid.ko
   AUTOLOAD:=$(call AutoProbe,usbhid)
   $(call AddDepends/usb)
-  $(call AddDepends/hid,+kmod-hid-generic)
   $(call AddDepends/input,+kmod-input-evdev)
 endef