upx: fix build error
authorNicolas Thill <nico@openwrt.org>
Fri, 21 Oct 2011 11:31:25 +0000 (11:31 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 21 Oct 2011 11:31:25 +0000 (11:31 +0000)
g++ -O2 -Wall -W -Wcast-align -Wcast-qual -Wpointer-arith -Wshadow -Wwrite-strings -Werror -o compress.o -c compress.cpp
cc1plus: warnings being treated as errors
compress.cpp:75: error: unused parameter 'src'
...

SVN-Revision: 28500

tools/upx/Makefile

index 0a805f0a4a09e8b5d11266bb317de88a19942f91..2f3313ca38939d7e2813e5866aee7eeaf47fd2ce 100644 (file)
@@ -20,7 +20,8 @@ include $(INCLUDE_DIR)/host-build.mk
 
 define Host/Compile
        rm -f $(HOST_BUILD_DIR)/src/.depend
-       $(MAKE) UPX_LZMADIR="$(BUILD_DIR_HOST)/lzma-4.65" -C $(HOST_BUILD_DIR)/src
+       $(MAKE) UPX_LZMADIR="$(BUILD_DIR_HOST)/lzma-4.65" -C $(HOST_BUILD_DIR)/src \
+               CXXFLAGS_WERROR=
 endef
 
 define Host/Install