implement target profiles in menuconfig
authorFelix Fietkau <nbd@openwrt.org>
Sun, 12 Nov 2006 05:06:56 +0000 (05:06 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 12 Nov 2006 05:06:56 +0000 (05:06 +0000)
SVN-Revision: 5512

26 files changed:
Makefile
include/kernel-build.mk
package/ar7-atm/Makefile
package/ar7-net/Makefile
package/base-files/Makefile
package/bridge/Makefile
package/broadcom-wl/Makefile
package/busybox/Makefile
package/dnsmasq/Makefile
package/dropbear/Makefile
package/iptables/Makefile
package/madwifi/Makefile
package/mtd/Makefile
package/nozomi/Makefile
package/nvram/Makefile
package/ppp/Makefile
package/switch/Makefile
package/wireless-tools/Makefile
package/wlcompat/Makefile
scripts/gen_package_config.pl
scripts/gen_target_config.pl
target/Config.in
target/linux/ar7-2.4/Makefile
target/linux/aruba-2.6/Makefile
target/linux/brcm-2.4/Makefile
target/linux/brcm-2.6/Makefile

index e5e1f6fd3110cd1c7eddde05af84b6da2b9be223..eed9335a5be66ba6f5d657f9d775d49f4f7bd6cf 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -39,11 +39,11 @@ else
 endif
 export OPENWRTVERSION
 
 endif
 export OPENWRTVERSION
 
-ifneq ($(shell ./scripts/timestamp.pl -p tmp/.pkginfo package scripts Makefile),tmp/.pkginfo)
+ifneq ($(shell ./scripts/timestamp.pl -p tmp/.pkginfo package scripts include),tmp/.pkginfo)
   tmp/.pkginfo: FORCE
 endif
 
   tmp/.pkginfo: FORCE
 endif
 
-ifneq ($(shell ./scripts/timestamp.pl -p tmp/.targetinfo target/linux scripts Makefile),tmp/.targetinfo)
+ifneq ($(shell ./scripts/timestamp.pl -p tmp/.targetinfo target/linux scripts include),tmp/.targetinfo)
   tmp/.targetinfo: FORCE
 endif
 
   tmp/.targetinfo: FORCE
 endif
 
index e491e489c1182c1afec6178ec9728499165495c2..35149d768614eda67148b661a6a9744cf6b95b33 100644 (file)
@@ -6,6 +6,9 @@
 #
 KERNEL_BUILD:=1
 
 #
 KERNEL_BUILD:=1
 
+# For target profile selection - the default set
+DEFAULT_PACKAGES:=base-files libgcc uclibc bridge busybox dnsmasq dropbear iptables mtd ppp ppp-mod-pppoe mtd
+
 ifeq ($(DUMP),1)
   all: dumpinfo
 else
 ifeq ($(DUMP),1)
   all: dumpinfo
 else
@@ -146,41 +149,59 @@ define BuildKernel
   mostlyclean: FORCE
        $(call Kernel/Clean)
 
   mostlyclean: FORCE
        $(call Kernel/Clean)
 
+  ifeq ($(DUMP),1)
+    dumpinfo:
+               @echo 'Target: $(BOARD)-$(KERNEL)'
+               @echo 'Target-Name: $(BOARDNAME) [$(KERNEL)]'
+               @echo 'Target-Path: $(subst $(TOPDIR)/,,$(PWD))'
+               @echo 'Target-Arch: $(ARCH)'
+               @echo 'Target-Features: $(FEATURES)'
+               @echo 'Linux-Version: $(LINUX_VERSION)'
+               @echo 'Linux-Release: $(LINUX_RELEASE)'
+               @echo 'Linux-Kernel-Arch: $(LINUX_KARCH)'
+               @echo 'Target-Description:'
+               @getvar $(call shvar,Target/Description)
+               @echo '@@'
+               @echo 'Default-Packages: $(DEFAULT_PACKAGES)'
+    ifneq ($(DUMPINFO),)
+               @$(DUMPINFO)
+    endif
+  endif
+
   define BuildKernel
   endef
 endef
 
   define BuildKernel
   endef
 endef
 
+define Profile/Default
+  NAME:=
+  PACKAGES:=
+endef
+
+define Profile
+  $(eval $(call Profile/Default))
+  $(eval $(call Profile/$(1)))
+  DUMPINFO += \
+       echo "Target-Profile: $(1)"; \
+       echo "Target-Profile-Name: $(NAME)"; \
+       echo "Target-Profile-Packages: $(PACKAGES)"; 
+endef
+
 $(eval $(call shexport,Target/Description))
 
 $(eval $(call shexport,Target/Description))
 
-ifeq ($(DUMP),1)
-  dumpinfo:
-       @echo 'Target: $(BOARD)-$(KERNEL)'
-       @echo 'Target-Name: $(BOARDNAME) [$(KERNEL)]'
-       @echo 'Target-Path: $(subst $(TOPDIR)/,,$(PWD))'
-       @echo 'Target-Arch: $(ARCH)'
-       @echo 'Target-Features: $(FEATURES)'
-       @echo 'Linux-Version: $(LINUX_VERSION)'
-       @echo 'Linux-Release: $(LINUX_RELEASE)'
-       @echo 'Linux-Kernel-Arch: $(LINUX_KARCH)'
-       @echo 'Target-Description:'
-       @echo "$$$(call shvar,Target/Description)"
-       @echo '@@'
-else
-  download: $(DL_DIR)/$(LINUX_SOURCE)
-  prepare: $(LINUX_DIR)/.configured $(TMP_DIR)/.kernel.mk
-  compile: $(LINUX_DIR)/.modules
-  install: $(LINUX_DIR)/.image
+download: $(DL_DIR)/$(LINUX_SOURCE)
+prepare: $(LINUX_DIR)/.configured $(TMP_DIR)/.kernel.mk
+compile: $(LINUX_DIR)/.modules
+install: $(LINUX_DIR)/.image
 
 
-  clean: FORCE
+clean: FORCE
        rm -f $(STAMP_DIR)/.linux-compile
        rm -rf $(KERNEL_BUILD_DIR)
 
        rm -f $(STAMP_DIR)/.linux-compile
        rm -rf $(KERNEL_BUILD_DIR)
 
-  rebuild: FORCE
+rebuild: FORCE
        @$(MAKE) mostlyclean
        @if [ -f $(LINUX_KERNEL) ]; then \
                $(MAKE) clean; \
        fi
        @$(MAKE) compile
        @$(MAKE) mostlyclean
        @if [ -f $(LINUX_KERNEL) ]; then \
                $(MAKE) clean; \
        fi
        @$(MAKE) compile
-endif
 
 
 
 
index 6ef3c2652bc56073ce8b3540232bc566c34c981f..25ef3728d428eeab6c1eb0626b5a32f8ef3a3dcf 100644 (file)
@@ -25,7 +25,6 @@ include $(INCLUDE_DIR)/package.mk
 define KernelPackage/sangam-atm-annex-a
   SUBMENU:=Network Devices
   DEPENDS:=@LINUX_2_4_AR7 +kmod-atm
 define KernelPackage/sangam-atm-annex-a
   SUBMENU:=Network Devices
   DEPENDS:=@LINUX_2_4_AR7 +kmod-atm
-  DEFAULT:=y
   TITLE:=AR7 ADSL driver (Annex A)
   DESCRIPTION:=The AR7 ADSL driver for Annex A
   VERSION:=$(PKG_VERSION)+$(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE)
   TITLE:=AR7 ADSL driver (Annex A)
   DESCRIPTION:=The AR7 ADSL driver for Annex A
   VERSION:=$(PKG_VERSION)+$(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE)
index a8423a3fddfbc68c4b7bb4d3a6a9f267b236e4cd..fbcdf64968d6db375b43b9499090b8640980e52d 100644 (file)
@@ -25,7 +25,6 @@ include $(INCLUDE_DIR)/package.mk
 define KernelPackage/avalanche-cpmac
   SUBMENU:=Network Devices
   DEPENDS:=@LINUX_2_4_AR7 +kmod-atm
 define KernelPackage/avalanche-cpmac
   SUBMENU:=Network Devices
   DEPENDS:=@LINUX_2_4_AR7 +kmod-atm
-  DEFAULT:=y
   TITLE:=AR7 Network driver (CPMAC)
   DESCRIPTION:=AR7 Network driver (CPMAC)
   VERSION:=$(PKG_VERSION)+$(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE)
   TITLE:=AR7 Network driver (CPMAC)
   DESCRIPTION:=AR7 Network driver (CPMAC)
   VERSION:=$(PKG_VERSION)+$(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE)
index ea4159d641278a543d7be135ded660cc63bfffb4..5af1414d4e37f483484f4ffb23ceeb3dd2b94b0d 100644 (file)
@@ -35,7 +35,6 @@ CONFIG_PACKAGE_base-files$(TARGET):=$(CONFIG_PACKAGE_base-files)
 define Package/base-files$(TARGET)
   SECTION:=base
   CATEGORY:=Base system
 define Package/base-files$(TARGET)
   SECTION:=base
   CATEGORY:=Base system
-  DEFAULT:=y
   TITLE:=Base filesystem for OpenWrt
   DESCRIPTION:=\
        This package contains a base filesystem and system scripts for OpenWrt.
   TITLE:=Base filesystem for OpenWrt
   DESCRIPTION:=\
        This package contains a base filesystem and system scripts for OpenWrt.
@@ -87,7 +86,6 @@ endef
 define Package/libgcc
   SECTION:=libs
   CATEGORY:=Base system
 define Package/libgcc
   SECTION:=libs
   CATEGORY:=Base system
-  DEFAULT:=y
   DEPENDS:=@!NATIVE_TOOLCHAIN
   TITLE:=GCC support library
   URL:=http://gcc.gnu.org/
   DEPENDS:=@!NATIVE_TOOLCHAIN
   TITLE:=GCC support library
   URL:=http://gcc.gnu.org/
@@ -106,7 +104,6 @@ endef
 define Package/uclibc
   SECTION:=libs
   CATEGORY:=Base system
 define Package/uclibc
   SECTION:=libs
   CATEGORY:=Base system
-  DEFAULT:=y
   DEPENDS:=@!NATIVE_TOOLCHAIN
   TITLE:=C library embedded systems
   URL:=http://uclibc.org/
   DEPENDS:=@!NATIVE_TOOLCHAIN
   TITLE:=C library embedded systems
   URL:=http://uclibc.org/
index c186c8e701c174452e9ecbd98fbcbd617dcbc9a6..07149fdee2e98a74874b4a8425255de719562906 100644 (file)
@@ -24,7 +24,6 @@ include $(INCLUDE_DIR)/package.mk
 define Package/bridge
   SECTION:=net
   CATEGORY:=Base system
 define Package/bridge
   SECTION:=net
   CATEGORY:=Base system
-  DEFAULT:=y
   TITLE:=Ethernet bridging configuration utility
   DESCRIPTION:=\
        Manage ethernet bridging: a way to connect networks together to \\\
   TITLE:=Ethernet bridging configuration utility
   DESCRIPTION:=\
        Manage ethernet bridging: a way to connect networks together to \\\
index 3ef4bcf0819a059bb9de81789b4c0104809b7d98..1b3964285490e65cba391ec78f0c90453050187e 100644 (file)
@@ -44,7 +44,6 @@ endef
 
 define Package/kmod-brcm-wl
   $(call Package/kmod-brcm-wl/Default)
 
 define Package/kmod-brcm-wl
   $(call Package/kmod-brcm-wl/Default)
-  DEFAULT:=y
   TITLE+= (normal version)
   DESCRIPTION+= (normal version).
 endef
   TITLE+= (normal version)
   DESCRIPTION+= (normal version).
 endef
@@ -57,8 +56,8 @@ endef
 
 define Package/wlc
   $(call Package/broadcom-wl/Default)
 
 define Package/wlc
   $(call Package/broadcom-wl/Default)
+  TITLE:=wl driver setup utility
   DEFAULT:=y
   DEFAULT:=y
-  TITLE:=Proprietary Broadcom wl driver setup utility
   DESCRIPTION:=\
        This package contains an utility for initializing the proprietary Broadcom \\\
        wl driver.
   DESCRIPTION:=\
        This package contains an utility for initializing the proprietary Broadcom \\\
        wl driver.
@@ -74,7 +73,8 @@ endef
 
 define Package/nas
   $(call Package/broadcom-wl/Default)
 
 define Package/nas
   $(call Package/broadcom-wl/Default)
-  DEPENDS+= +nvram
+  DEPENDS+=+nvram
+  DEFAULT:=y
   TITLE:=Proprietary Broadcom WPA/WPA2 authenticator
   DESCRIPTION:=\
        This package contains the proprietary WPA/WPA2 authenticator (nas) for the \\\
   TITLE:=Proprietary Broadcom WPA/WPA2 authenticator
   DESCRIPTION:=\
        This package contains the proprietary WPA/WPA2 authenticator (nas) for the \\\
index 05174a32bda0dd0b8bb2cfeb065de2bcabf6ed9d..cc347372643c09f00139c08e2f9e3cd4c1fe35dd 100644 (file)
@@ -24,7 +24,6 @@ include $(INCLUDE_DIR)/package.mk
 define Package/busybox
   SECTION:=base
   CATEGORY:=Base system
 define Package/busybox
   SECTION:=base
   CATEGORY:=Base system
-  DEFAULT:=y
   TITLE:=Core utilities for embedded Linux
   URL:=http://busybox.net/
   MENU:=1
   TITLE:=Core utilities for embedded Linux
   URL:=http://busybox.net/
   MENU:=1
index d7e5f18b610c69a184859971987cf1caed80ca85..d0beeb6f49b9a0b4886da13e41decd55b08db39e 100644 (file)
@@ -24,7 +24,6 @@ include $(INCLUDE_DIR)/package.mk
 define Package/dnsmasq
   SECTION:=net
   CATEGORY:=Base system
 define Package/dnsmasq
   SECTION:=net
   CATEGORY:=Base system
-  DEFAULT:=y
   TITLE:=A lightweight DNS and DHCP server
   DESCRIPTION:=\
        It is intended to provide coupled DNS and DHCP service to a LAN.
   TITLE:=A lightweight DNS and DHCP server
   DESCRIPTION:=\
        It is intended to provide coupled DNS and DHCP service to a LAN.
index 546facf9239839606b53b20594d52da18886d2cd..1f4e47d4e72035e462ec5e3f294b1e94e1b561e5 100644 (file)
@@ -29,7 +29,6 @@ define Package/dropbear
   $(call Package/dropbear/Default)
   SECTION:=net
   CATEGORY:=Base system
   $(call Package/dropbear/Default)
   SECTION:=net
   CATEGORY:=Base system
-  DEFAULT:=y
   TITLE:=Small SSH2 client/server
   DESCRIPTION:=\
        A small SSH2 server/client designed for small memory environments.
   TITLE:=Small SSH2 client/server
   DESCRIPTION:=\
        A small SSH2 server/client designed for small memory environments.
index ee0c0941b17ea3dea9e370659ab426eb37ff5be2..5fb069f6de61245ea03ddce953650bed9f7b417a 100644 (file)
@@ -38,7 +38,6 @@ endef
 
 define Package/iptables
   $(call Package/iptables/Default)
 
 define Package/iptables
   $(call Package/iptables/Default)
-  DEFAULT:=y
   TITLE:=IPv4 firewall administration tool
   MENU:=1
 endef
   TITLE:=IPv4 firewall administration tool
   MENU:=1
 endef
index 6fa682b0610f9e38034847e65349a4d971231475..2d952d1148658b012df89e462e390a371d7b77f8 100644 (file)
@@ -77,8 +77,8 @@ endif
 
 define KernelPackage/madwifi
   SUBMENU:=Wireless Drivers
 
 define KernelPackage/madwifi
   SUBMENU:=Wireless Drivers
-  DEFAULT:=y if LINUX_2_6_BRCM || LINUX_2_6_ARUBA || LINUX_2_4_AR531X || LINUX_2_6_XSCALE, m if ALL
   TITLE:=Driver for Atheros wireless chipsets
   TITLE:=Driver for Atheros wireless chipsets
+  DEPENDS:=+wireless-tools
   DESCRIPTION:=\
        This package contains a driver for Atheros 802.11a/b/g chipsets.
   URL:=http://madwifi.org/
   DESCRIPTION:=\
        This package contains a driver for Atheros 802.11a/b/g chipsets.
   URL:=http://madwifi.org/
index b3edb7b1b8931eba03a3ecc26ed76cb929d7f9fb..2a27f0f5c31650374d4f584b0205eea089fc3f12 100644 (file)
@@ -19,7 +19,6 @@ include $(INCLUDE_DIR)/package.mk
 define Package/mtd
   SECTION:=utils
   CATEGORY:=Base system
 define Package/mtd
   SECTION:=utils
   CATEGORY:=Base system
-  DEFAULT:=y
   TITLE:=Update utility for trx firmware images
   DESCRIPTION:=\
        This package contains an utility useful to upgrade from other firmware or \\\
   TITLE:=Update utility for trx firmware images
   DESCRIPTION:=\
        This package contains an utility useful to upgrade from other firmware or \\\
index 5b879de4b8a0b3eb41a5a48a3652fe55a02b6996..a6b9c008722193f46e2d23e5b604ad6e036bfb6b 100644 (file)
@@ -30,7 +30,6 @@ define KernelPackage/nozomi
   DESCRIPTION:=Option Globetrotter HSDPA driver
   URL:=http://www.pharscape.org/
   DEPENDS:=@LINUX_2_4
   DESCRIPTION:=Option Globetrotter HSDPA driver
   URL:=http://www.pharscape.org/
   DEPENDS:=@LINUX_2_4
-  DEFAULT:=m if ALL
   VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
   FILES:=$(PKG_BUILD_DIR)/noz.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,70,noz)
   VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
   FILES:=$(PKG_BUILD_DIR)/noz.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,70,noz)
index 1fd82cd71fa1bdb1a17833f980ca9a20fc4ba129..ab33c115144e963ecc3ae57e1114ac5704262f4a 100644 (file)
@@ -18,7 +18,6 @@ include $(INCLUDE_DIR)/package.mk
 define Package/nvram
   SECTION:=utils
   CATEGORY:=Utilities
 define Package/nvram
   SECTION:=utils
   CATEGORY:=Utilities
-  DEFAULT:=y
   DEPENDS:=@LINUX_2_4_BRCM
   TITLE:=Broadcom config utility
   DESCRIPTION:=\
   DEPENDS:=@LINUX_2_4_BRCM
   TITLE:=Broadcom config utility
   DESCRIPTION:=\
index 80c6f5afe8fdfbb83832d0c7381739a950bee945..7d05db09af7b3133d5e35e81631c29e34a9b3db6 100644 (file)
@@ -33,7 +33,6 @@ endef
 
 define Package/ppp
   $(call Package/ppp/Default)
 
 define Package/ppp
   $(call Package/ppp/Default)
-  DEFAULT:=y
   DEPENDS:=+kmod-ppp
   TITLE:=PPP daemon
   DESCRIPTION:=\
   DEPENDS:=+kmod-ppp
   TITLE:=PPP daemon
   DESCRIPTION:=\
@@ -44,7 +43,6 @@ endef
 define Package/ppp-mod-pppoa
   $(call Package/ppp/Default)
   DEPENDS:=ppp +linux-atm +kmod-pppoa
 define Package/ppp-mod-pppoa
   $(call Package/ppp/Default)
   DEPENDS:=ppp +linux-atm +kmod-pppoa
-  DEFAULT:=y if LINUX_2_4_AR7
   TITLE:=PPPoA plugin
   DESCRIPTION:=\
        This package contains a PPPoA (PPP over ATM) plugin for ppp.
   TITLE:=PPPoA plugin
   DESCRIPTION:=\
        This package contains a PPPoA (PPP over ATM) plugin for ppp.
@@ -52,7 +50,6 @@ endef
 
 define Package/ppp-mod-pppoe
   $(call Package/ppp/Default)
 
 define Package/ppp-mod-pppoe
   $(call Package/ppp/Default)
-  DEFAULT:=y
   DEPENDS:=ppp +kmod-pppoe
   TITLE:=PPPoE plugin
   DESCRIPTION:=\
   DEPENDS:=ppp +kmod-pppoe
   TITLE:=PPPoE plugin
   DESCRIPTION:=\
index 75f312940278908b6d54f6b96402d31dddef8fd2..07208bc30f7679de812ca7914d0417f0dc915b38 100644 (file)
@@ -20,7 +20,6 @@ define Package/kmod-switch
   SECTION:=kernel
   CATEGORY:=Kernel drivers
   DEPENDS:=@LINUX_2_6_BRCM||LINUX_2_4_BRCM
   SECTION:=kernel
   CATEGORY:=Kernel drivers
   DEPENDS:=@LINUX_2_6_BRCM||LINUX_2_4_BRCM
-  DEFAULT:=y
   TITLE:=Switch drivers
   DESCRIPTION:=\
        This package contains switch drivers for ADM6996L and BCM53XX RoboSwitch.
   TITLE:=Switch drivers
   DESCRIPTION:=\
        This package contains switch drivers for ADM6996L and BCM53XX RoboSwitch.
index def2a6cc851e1e6f9a058a21a34ec143311c8580..f78bef986a0c30456aa3a97f8ad6c9dad1037895 100644 (file)
@@ -26,7 +26,6 @@ include $(INCLUDE_DIR)/package.mk
 define Package/wireless-tools
   SECTION:=net
   CATEGORY:=Base system
 define Package/wireless-tools
   SECTION:=net
   CATEGORY:=Base system
-  DEFAULT:=y
   TITLE:=Tools for manipulating Linux Wireless Extensions
   DESCRIPTION:=\
        This package contains a collection of tools for configuring wireless \\\
   TITLE:=Tools for manipulating Linux Wireless Extensions
   DESCRIPTION:=\
        This package contains a collection of tools for configuring wireless \\\
index fc66c90f506304c8e49835a5085143e1cd66dda6..4a372946581cd7241f4874ef839cc3bbfae89ed1 100644 (file)
@@ -19,7 +19,8 @@ include $(INCLUDE_DIR)/package.mk
 define Package/kmod-wlcompat/Default
   SECTION:=kernel
   CATEGORY:=Kernel drivers
 define Package/kmod-wlcompat/Default
   SECTION:=kernel
   CATEGORY:=Kernel drivers
-  DEPENDS:=kmod-brcm-wl
+  DEPENDS:=@PACKAGE_kmod-brcm-wl||PACKAGE_kmod-brcm-wl-mimo +wireless-tools
+  DEFAULT:=y
   TITLE:=Broadcom wl wrapper module
   DESCRIPTION:=\
        This package contains a wrapper module, that provides Wireless Extension \\\
   TITLE:=Broadcom wl wrapper module
   DESCRIPTION:=\
        This package contains a wrapper module, that provides Wireless Extension \\\
@@ -29,7 +30,6 @@ endef
 
 define Package/kmod-wlcompat
   $(call Package/kmod-wlcompat/Default)
 
 define Package/kmod-wlcompat
   $(call Package/kmod-wlcompat/Default)
-  DEFAULT:=y
 endef
 
 define Package/kmod-wlcompat-debug
 endef
 
 define Package/kmod-wlcompat-debug
index 9c705af563b3113cf5692f46fc9b0efacb337d52..4ce117c06f516030ddc95a2a0c3ef5307994a60f 100755 (executable)
@@ -89,10 +89,13 @@ sub print_category($) {
                        if ($c > 0) {
                                $title .= ("." x $c). " ". $pkg->{title};
                        }
                        if ($c > 0) {
                                $title .= ("." x $c). " ". $pkg->{title};
                        }
+                       print "\tconfig DEFAULT_".$pkg->{name}."\n";
+                       print "\t\tbool\n\n";
                        print "\t";
                        $pkg->{menu} and print "menu";
                        print "config PACKAGE_".$pkg->{name}."\n";
                        print "\t\ttristate \"$title\"\n";
                        print "\t";
                        $pkg->{menu} and print "menu";
                        print "config PACKAGE_".$pkg->{name}."\n";
                        print "\t\ttristate \"$title\"\n";
+                       print "\t\tdefault y if DEFAULT_".$pkg->{name}."\n";
                        foreach my $default (split /\s*,\s*/, $pkg->{default}) {
                                print "\t\tdefault $default\n";
                        }
                        foreach my $default (split /\s*,\s*/, $pkg->{default}) {
                                print "\t\tdefault $default\n";
                        }
index c0b83963b64de44a2c10409f43570ef848eac932..4d0d6b13ef45e0f959a469ff40c2ef9b5391298d 100755 (executable)
@@ -10,6 +10,8 @@ use strict;
 
 my @target;
 my $target;
 
 my @target;
 my $target;
+my $profiles;
+my $profile;
 
 sub features(@) {
        my $ret;
 
 sub features(@) {
        my $ret;
@@ -30,8 +32,11 @@ sub features(@) {
 while (<>) {
        chomp;
        /^Target:\s*((.+)-(\d+\.\d+))\s*$/ and do {
 while (<>) {
        chomp;
        /^Target:\s*((.+)-(\d+\.\d+))\s*$/ and do {
+               my $conf = uc $3.'_'.$2;
+               $conf =~ tr/\.-/__/;
                $target = {
                        id => $1,
                $target = {
                        id => $1,
+                       conf => $conf,
                        board => $2,
                        kernel => $3
                };
                        board => $2,
                        kernel => $3
                };
@@ -56,6 +61,22 @@ while (<>) {
        /^Linux-Version:\s*(.+)\s*$/ and $target->{version} = $1;
        /^Linux-Release:\s*(.+)\s*$/ and $target->{release} = $1;
        /^Linux-Kernel-Arch:\s*(.+)\s*$/ and $target->{karch} = $1;
        /^Linux-Version:\s*(.+)\s*$/ and $target->{version} = $1;
        /^Linux-Release:\s*(.+)\s*$/ and $target->{release} = $1;
        /^Linux-Kernel-Arch:\s*(.+)\s*$/ and $target->{karch} = $1;
+       /^Default-Packages:\s*(.+)\s*$/ and do {
+               my @pkgs = split /\s+/, $1;
+               $target->{defaultpkgs} = \@pkgs;
+       };
+       /^Target-Profile:\s*(.+)\s*$/ and do {
+               $profiles = $target->{profiles} or $target->{profiles} = $profiles = [];
+               $profile = {
+                       id => $1
+               };
+               push @$profiles, $profile;
+       };
+       /^Target-Profile-Name:\s*(.+)\s*$/ and $profile->{name} = $1;
+       /^Target-Profile-Packages:\s*(.+)\s*$/ and do {
+               my @pkgs = split /\s+/, $1;
+               $profile->{pkgs} = \@pkgs;
+       };
 }
 
 @target = sort {
 }
 
 @target = sort {
@@ -63,13 +84,18 @@ while (<>) {
 } @target;
 
 
 } @target;
 
 
+print <<EOF;
+choice
+       prompt "Target System"
+       default LINUX_2_4_BRCM
+       
+EOF
+
 foreach $target (@target) {
 foreach $target (@target) {
-       my $conf = uc $target->{kernel}.'_'.$target->{board};
        my $features = features(@{$target->{features}});
        my $help = $target->{desc};
        chomp $features;
        $features .= "\n";
        my $features = features(@{$target->{features}});
        my $help = $target->{desc};
        chomp $features;
        $features .= "\n";
-       $conf =~ tr/\.-/__/;
        if ($help =~ /\w+/) {
                $help =~ s/^\s*/\t  /mg;
                $help = "\thelp\n$help";
        if ($help =~ /\w+/) {
                $help =~ s/^\s*/\t  /mg;
                $help = "\thelp\n$help";
@@ -78,7 +104,7 @@ foreach $target (@target) {
        }
 
        print <<EOF
        }
 
        print <<EOF
-config LINUX_$conf
+config LINUX_$target->{conf}
        bool "$target->{name}"
        select $target->{arch}
 $features$help
        bool "$target->{name}"
        select $target->{arch}
 $features$help
@@ -86,3 +112,87 @@ $features$help
 EOF
 }
 
 EOF
 }
 
+print <<EOF;
+if DEVEL
+
+config LINUX_2_6_ARM
+       bool "UNSUPPORTED little-endian arm platform"
+       depends BROKEN
+       select LINUX_2_6
+       select arm
+
+config LINUX_2_6_CRIS
+       bool "UNSUPPORTED cris platform"
+       depends BROKEN
+       select LINUX_2_6
+       select cris
+
+config LINUX_2_6_M68K
+       bool "UNSUPPORTED m68k platform"
+       depends BROKEN
+       select LINUX_2_6
+       select m68k
+
+config LINUX_2_6_SH3
+       bool "UNSUPPORTED little-endian sh3 platform"
+       depends BROKEN
+       select LINUX_2_6
+       select sh3
+
+config LINUX_2_6_SH3EB
+       bool "UNSUPPORTED big-endian sh3 platform"
+       depends BROKEN
+       select LINUX_2_6
+       select sh3eb
+
+config LINUX_2_6_SH4
+       bool "UNSUPPORTED little-endian sh4 platform"
+       depends BROKEN
+       select LINUX_2_6
+       select sh4
+
+config LINUX_2_6_SH4EB
+       bool "UNSUPPORTED big-endian sh4 platform"
+       depends BROKEN
+       select LINUX_2_6
+       select sh4eb
+
+config LINUX_2_6_SPARC
+       bool "UNSUPPORTED sparc platform"
+       depends BROKEN
+       select LINUX_2_6
+       select sparc
+
+endif
+
+endchoice
+
+choice
+       prompt "Target Profile"
+
+EOF
+
+foreach $target (@target) {
+       my $profiles;
+       
+       $profiles = $target->{profiles} or $profiles = [
+               {
+                       id => 'Default',
+                       name => 'Default',
+                       pkgs => []
+               }
+       ];
+       foreach my $profile (@$profiles) {
+               print <<EOF;
+config LINUX_$target->{conf}_$profile->{id}
+       bool "$profile->{name}"
+       depends LINUX_$target->{conf}
+EOF
+               foreach my $pkg (@{$target->{defaultpkgs}}, @{$profile->{pkgs}}) {
+                       print "\tselect DEFAULT_$pkg\n";
+               }
+               print "\n";
+       }
+}
+
+print "endchoice\n";
index 0ed1d0c587a611e35e736e065c7bd7e626571b3d..83e2e1a9000d3fb2347502e72ce1697b50d6d667 100644 (file)
@@ -1,64 +1,5 @@
-choice
-       prompt "Target System"
-       default LINUX_2_4_BRCM
-
 source "tmp/.config-target.in"
 
 source "tmp/.config-target.in"
 
-if DEVEL
-
-config LINUX_2_6_ARM
-       bool "UNSUPPORTED little-endian arm platform"
-       depends BROKEN
-       select LINUX_2_6
-       select arm
-
-config LINUX_2_6_CRIS
-       bool "UNSUPPORTED cris platform"
-       depends BROKEN
-       select LINUX_2_6
-       select cris
-
-config LINUX_2_6_M68K
-       bool "UNSUPPORTED m68k platform"
-       depends BROKEN
-       select LINUX_2_6
-       select m68k
-
-config LINUX_2_6_SH3
-       bool "UNSUPPORTED little-endian sh3 platform"
-       depends BROKEN
-       select LINUX_2_6
-       select sh3
-
-config LINUX_2_6_SH3EB
-       bool "UNSUPPORTED big-endian sh3 platform"
-       depends BROKEN
-       select LINUX_2_6
-       select sh3eb
-
-config LINUX_2_6_SH4
-       bool "UNSUPPORTED little-endian sh4 platform"
-       depends BROKEN
-       select LINUX_2_6
-       select sh4
-
-config LINUX_2_6_SH4EB
-       bool "UNSUPPORTED big-endian sh4 platform"
-       depends BROKEN
-       select LINUX_2_6
-       select sh4eb
-
-config LINUX_2_6_SPARC
-       bool "UNSUPPORTED sparc platform"
-       depends BROKEN
-       select LINUX_2_6
-       select sparc
-
-endif
-
-endchoice
-
-
 # Kernel/Hardware features
 
 config LINUX_2_4
 # Kernel/Hardware features
 
 config LINUX_2_4
index f3d55da1918542429a5fa62ffa36bc6cd23fa2e6..0ecfed61583d1f4e028459ed1fa17070b8c40844 100644 (file)
@@ -10,6 +10,7 @@ ARCH:=mipsel
 BOARD:=ar7
 BOARDNAME:=TI AR7
 FEATURES:=atm squashfs jffs2
 BOARD:=ar7
 BOARDNAME:=TI AR7
 FEATURES:=atm squashfs jffs2
+DEFAULT_PACKAGES += kmod-avalanche-cpmac
 
 define Target/Description
        Build firmware images for TI AR7 based routers (w.g. Linksys WAG54G v2)
 
 define Target/Description
        Build firmware images for TI AR7 based routers (w.g. Linksys WAG54G v2)
@@ -20,4 +21,23 @@ LINUX_RELEASE:=1
 LINUX_KERNEL_MD5SUM:=38f4d0830e95a20f4bfed17622d5557c
 
 include $(INCLUDE_DIR)/kernel-build.mk
 LINUX_KERNEL_MD5SUM:=38f4d0830e95a20f4bfed17622d5557c
 
 include $(INCLUDE_DIR)/kernel-build.mk
+
+define Profile/AnnexA
+  NAME:=ADSL Annex A (default)
+  PACKAGES:=kmod-sangam-atm-annex-a ppp-mod-pppoa
+endef
+$(eval $(call Profile,AnnexA))
+
+define Profile/AnnexB
+  NAME:=ADSL Annex B
+  PACKAGES:=kmod-sangam-atm-annex-b ppp-mod-pppoa
+endef
+$(eval $(call Profile,AnnexB))
+
+define Profile/None
+  NAME:=No ADSL
+  PACKAGES:=
+endef
+$(eval $(call Profile,None))
+
 $(eval $(call BuildKernel))
 $(eval $(call BuildKernel))
index c3946e2d10d8dd9979d86b3cc74ed9f1028b70cc..0a42148864c5f55cefca084739b5bcb7eba0473d 100644 (file)
@@ -10,6 +10,7 @@ ARCH:=mips
 BOARD:=aruba
 BOARDNAME:=Aruba
 FEATURES:=jffs2 pci usb
 BOARD:=aruba
 BOARDNAME:=Aruba
 FEATURES:=jffs2 pci usb
+DEFAULT_PACKAGES += kmod-madwifi
 
 define Target/Description
        Build firmware images for Aruba boards
 
 define Target/Description
        Build firmware images for Aruba boards
index 7319ccabd470b62240d6e62c643afdc983da3a35..2294a0546b08157f33527a6789c9e333f85679a6 100644 (file)
@@ -10,6 +10,7 @@ ARCH:=mipsel
 BOARD:=brcm
 BOARDNAME:=Broadcom BCM947xx/953xx
 FEATURES:=pci usb pcmcia squashfs jffs2
 BOARD:=brcm
 BOARDNAME:=Broadcom BCM947xx/953xx
 FEATURES:=pci usb pcmcia squashfs jffs2
+DEFAULT_PACKAGES += kmod-switch nvram
 
 define Target/Description
        Build firmware images for Broadcom based routers
 
 define Target/Description
        Build firmware images for Broadcom based routers
@@ -26,4 +27,59 @@ LINUX_KERNEL_MD5SUM:=38f4d0830e95a20f4bfed17622d5557c
 
 include $(INCLUDE_DIR)/kernel-build.mk
 
 
 include $(INCLUDE_DIR)/kernel-build.mk
 
+define Profile/Broadcom
+  NAME:=Generic, Broadcom WiFi (default)
+  PACKAGES:=kmod-brcm-wl
+endef
+$(eval $(call Profile,Broadcom))
+
+define Profile/BroadcomMimo
+  NAME:=Generic, Broadcom WiFi (MIMO)
+  PACKAGES:=kmod-brcm-wl-mimo
+endef
+$(eval $(call Profile,BroadcomMimo))
+
+define Profile/Atheros
+  NAME:=Generic, Atheros WiFi
+  PACKAGES:=kmod-madwifi
+endef
+$(eval $(call Profile,Atheros))
+
+define Profile/None
+  NAME:=Generic, No WiFi
+  PACKAGES:=
+endef
+$(eval $(call Profile,None))
+
+
+define Profile/WRT54G3G
+  NAME:=Linksys WRT54G3G
+  PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-pcmcia-core kmod-pcmcia-serial kmod-nozomi comgt
+endef
+$(eval $(call Profile,WRT54G3G))
+
+define Profile/WL500G
+  NAME:=ASUS WL-500g
+  PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-lp
+endef
+$(eval $(call Profile,WL500G))
+
+define Profile/WL500GD
+  NAME:=ASUS WL-500g Deluxe
+  PACKAGES:=kmod-usb-core kmod-usb-uhci kmod-usb2
+endef
+$(eval $(call Profile,WL500GD))
+
+define Profile/WL500GP
+  NAME:=ASUS WL-500g Premium
+  PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2
+endef
+$(eval $(call Profile,WL500GP))
+
+define Profile/WLHDD
+  NAME:=WL-HDD
+  PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-ide-core kmod-ide-pdc202xx
+endef
+$(eval $(call Profile,WLHDD))
+
 $(eval $(call BuildKernel))
 $(eval $(call BuildKernel))
index 599282803662065933165e0baf7d397f08b35107..0c3f5f79a707483585588fdebfecbae28842da52 100644 (file)
@@ -10,6 +10,7 @@ ARCH:=mipsel
 BOARD:=brcm
 BOARDNAME:=Broadcom BCM947xx/953xx
 FEATURES:=pci usb pcmcia squashfs jffs2
 BOARD:=brcm
 BOARDNAME:=Broadcom BCM947xx/953xx
 FEATURES:=pci usb pcmcia squashfs jffs2
+DEFAULT_PACKAGES += kmod-switch
 
 define Target/Description
        Build firmware images for Broadcom based routers
 
 define Target/Description
        Build firmware images for Broadcom based routers
@@ -26,4 +27,16 @@ LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
 
 include $(INCLUDE_DIR)/kernel-build.mk
 
 
 include $(INCLUDE_DIR)/kernel-build.mk
 
+define Profile/Atheros
+  NAME:=Atheros WiFi (default)
+  PACKAGES:=kmod-madwifi
+endef
+$(eval $(call Profile,Atheros))
+
+define Profile/None
+  NAME:=No WiFi
+  PACKAGES:=
+endef
+$(eval $(call Profile,None))
+
 $(eval $(call BuildKernel))
 $(eval $(call BuildKernel))