firewall: add DHCPv6 default rule (#10381)
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 9 Nov 2011 11:10:37 +0000 (11:10 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 9 Nov 2011 11:10:37 +0000 (11:10 +0000)
SVN-Revision: 28874

package/firewall/Makefile
package/firewall/files/firewall.config

index f95f73b4ad5eaf3370050692efc3f27e1d78fb9b..6106348156a7869d469230bcc41c34e5cb55f1bb 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=firewall
 
 PKG_VERSION:=2
-PKG_RELEASE:=41
+PKG_RELEASE:=42
 
 include $(INCLUDE_DIR)/package.mk
 
index 5a5dfd018672a04042826956e8d84cda577ee661..4ba165fcc628ff17e05eb73339fe832b85e3d798 100644 (file)
@@ -43,6 +43,18 @@ config rule
        option family           ipv4
        option target           ACCEPT
 
+# Allow DHCPv6 replies
+# see https://dev.openwrt.org/ticket/10381
+config rule
+       option src              wan
+       option proto            udp
+       option src_ip           fe80::/10
+       option src_port         547
+       option dest_ip          fe80::/10
+       option dest_port        546
+       option family           ipv6
+       option target           ACCEPT
+
 # Allow essential incoming IPv6 ICMP traffic
 config rule
        option src              wan