gcc: switch to 5.2.0 by default
authorFelix Fietkau <nbd@openwrt.org>
Tue, 17 Nov 2015 12:38:41 +0000 (12:38 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 17 Nov 2015 12:38:41 +0000 (12:38 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 47492

toolchain/gcc/Config.in
toolchain/gcc/Config.version

index 249a01b..a8c39d6 100644 (file)
@@ -2,9 +2,8 @@
 
 choice
        prompt "GCC compiler Version" if TOOLCHAINOPTS
-       default GCC_USE_VERSION_5 if TARGET_octeon
        default GCC_USE_VERSION_4_8_ARC if arc
-       default GCC_USE_VERSION_4_8_LINARO
+       default GCC_USE_VERSION_5
        help
          Select the version of gcc you wish to use.
 
index a7354f8..efd8dc0 100644 (file)
@@ -1,5 +1,4 @@
 config GCC_VERSION_4_8_LINARO
-       default y if (!TOOLCHAINOPTS && !(TARGET_octeon || arc))
        bool
 
 config GCC_VERSION_4_8_ARC
@@ -8,14 +7,14 @@ config GCC_VERSION_4_8_ARC
 
 config GCC_VERSION
        string
-       default "5.2.0"     if GCC_VERSION_5
        default "4.8-linaro"    if GCC_VERSION_4_8_LINARO
        default "arc-2015.06"   if GCC_VERSION_4_8_ARC
-       default "4.8-linaro"
+       default "5.2.0"
 
 config GCC_VERSION_4_8
        bool
        default y       if (GCC_VERSION_4_8_LINARO || GCC_VERSION_4_8_ARC)
 
 config GCC_VERSION_5
+       default y if (!TOOLCHAINOPTS && !arc)
        bool