firewall: move include sourcing into a subshell, this makes the firewall init immune...
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 2 Mar 2011 19:20:29 +0000 (19:20 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 2 Mar 2011 19:20:29 +0000 (19:20 +0000)
SVN-Revision: 25835

package/firewall/Makefile
package/firewall/files/lib/core_init.sh

index 3d61e098896261735417cd5df2ce7c4fccd77917..a8a62c287d033d153a0b20f2a11e3778a9599b69 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=firewall
 
 PKG_VERSION:=2
-PKG_RELEASE:=22
+PKG_RELEASE:=23
 
 include $(INCLUDE_DIR)/package.mk
 
index c7e41e7ff7dada3ad8015d741c8e894240e78376..42124b39bd47cbc85208d93349a8a7f30a9f49ee 100644 (file)
@@ -271,8 +271,10 @@ fw_load_notrack_zone() {
 fw_load_include() {
        local name="$1"
 
-       local path; config_get path ${name} path
-       [ -e $path ] && . $path
+       local path
+       config_get path ${name} path
+
+       [ -e $path ] && ( . $path )
 }