include: remove SDK specific target from toplevel.mk
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 8 Feb 2015 22:54:19 +0000 (22:54 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 8 Feb 2015 22:54:19 +0000 (22:54 +0000)
Instead introduce a generic "make prepare" target which is executed if
include/prepare.mk exists.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 44329

include/toplevel.mk

index 0b8a658c18423455310b3a4c6ee03b48fc850522..67357b033a857de35cd2e359125f4990455451eb 100644 (file)
@@ -136,13 +136,19 @@ kernel_menuconfig: prepare_kernel_conf
 kernel_nconfig: prepare_kernel_conf
        $(_SINGLE)$(NO_TRACE_MAKE) -C target/linux nconfig
 
-tmp/.prereq-build: $(if $(SDK),.git/config) include/prereq-build.mk
+tmp/.prereq-build: include/prereq-build.mk
        mkdir -p tmp
        rm -f tmp/.host.mk
        @$(_SINGLE)$(NO_TRACE_MAKE) -j1 -r -s -f $(TOPDIR)/include/prereq-build.mk prereq 2>/dev/null || { \
                echo "Prerequisite check failed. Use FORCE=1 to override."; \
                false; \
        }
+  ifneq ($(realpath $(TOPDIR)/include/prepare.mk),)
+       @$(_SINGLE)$(NO_TRACE_MAKE) -j1 -r -s -f $(TOPDIR)/include/prepare.mk prepare 2>/dev/null || { \
+               echo "Preparation failed."; \
+               false; \
+       }
+  endif
        touch $@
 
 printdb: FORCE