comgt: split directip support into its own package
authorJohn Crispin <john@openwrt.org>
Wed, 8 Oct 2014 08:00:55 +0000 (08:00 +0000)
committerJohn Crispin <john@openwrt.org>
Wed, 8 Oct 2014 08:00:55 +0000 (08:00 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 42836

package/network/utils/comgt/Makefile

index 254670693a2971a949a57328eeb12e4aead6200a..21dda8bd56608509b7b37e944ad066d9df1e2d9a 100644 (file)
@@ -22,14 +22,24 @@ PKG_CHECK_FORMAT_SECURITY:=0
 
 include $(INCLUDE_DIR)/package.mk
 
-define Package/comgt
+define Package/comgt/Default
   SECTION:=utils
   CATEGORY:=Utilities
+endef
+
+define Package/comgt
+$(call Package/comgt/Default)
   TITLE:=Option/Vodafone 3G/GPRS control tool
   DEPENDS:=+chat
   URL:=http://www.pharscape.org/comgt.html
 endef
 
+define Package/comgt-directip
+$(call Package/comgt/Default)
+  TITLE:=Sierra Wireless Direct-IP support
+  DEPENDS:=+comgt +kmod-usb-serial +kmod-usb-serial-sierrawireless +kmod-usb-net +kmod-usb-net-sierrawireless
+endef
+
 define Package/comgt/description
  comgt is a scripting language interpreter useful for establishing 
  communications on serial lines and through PCMCIA modems as well as GPRS 
@@ -59,13 +69,19 @@ define Package/comgt/install
        $(INSTALL_DATA) ./files/getcarrier.gcom $(1)/etc/gcom/getcarrier.gcom
        $(INSTALL_DATA) ./files/getcnum.gcom $(1)/etc/gcom/getcnum.gcom
        $(INSTALL_DATA) ./files/getimsi.gcom $(1)/etc/gcom/getimsi.gcom
-       $(INSTALL_DATA) ./files/directip.gcom $(1)/etc/gcom/directip.gcom
-       $(INSTALL_DATA) ./files/directip-stop.gcom $(1)/etc/gcom/directip-stop.gcom
        $(INSTALL_DIR) $(1)/etc/hotplug.d/tty
        $(INSTALL_DATA) ./files/3g.usb $(1)/etc/hotplug.d/tty/30-3g
        $(INSTALL_DIR) $(1)/lib/netifd/proto
        $(INSTALL_BIN) ./files/3g.sh $(1)/lib/netifd/proto/3g.sh
+endef
+
+define Package/comgt-directip/install
+       $(INSTALL_DIR) $(1)/etc/gcom
+       $(INSTALL_DATA) ./files/directip.gcom $(1)/etc/gcom/directip.gcom
+       $(INSTALL_DATA) ./files/directip-stop.gcom $(1)/etc/gcom/directip-stop.gcom
+       $(INSTALL_DIR) $(1)/lib/netifd/proto
        $(INSTALL_BIN) ./files/directip.sh $(1)/lib/netifd/proto/directip.sh
 endef
 
 $(eval $(call BuildPackage,comgt))
+$(eval $(call BuildPackage,comgt-directip))