unmask ip6tables on 2.6.27 and 2.6.28
authorTravis Kemen <thepeople@openwrt.org>
Sat, 10 Jan 2009 23:52:56 +0000 (23:52 +0000)
committerTravis Kemen <thepeople@openwrt.org>
Sat, 10 Jan 2009 23:52:56 +0000 (23:52 +0000)
SVN-Revision: 13965

package/kernel/modules/netfilter.mk

index e22707679318355a6fcadbe0ad8c7ce82655db85..f109b94da1c1afad02990a1383a3c57bf8f1fda0 100644 (file)
@@ -354,11 +354,10 @@ endef
 $(eval $(call KernelPackage,ipt-extra))
 
 
-# XXX: disabled on 2.6.27 due to broken IMQ
 define KernelPackage/ip6tables
   SUBMENU:=$(NF_MENU)
   TITLE:=IPv6 modules
-  DEPENDS:=+kmod-ipv6 @!LINUX_2_6_27 @!LINUX_2_6_28
+  DEPENDS:=+kmod-ipv6
   KCONFIG:=CONFIG_IP6_NF_IPTABLES
   FILES:=$(foreach mod,$(IPT_IPV6-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
   AUTOLOAD:=$(call AutoLoad,49,$(notdir $(IPT_IPV6-m)))