linux/netsupport: Add support for MPLS protocol
authorJohn Crispin <john@openwrt.org>
Fri, 12 Feb 2016 08:31:17 +0000 (08:31 +0000)
committerJohn Crispin <john@openwrt.org>
Fri, 12 Feb 2016 08:31:17 +0000 (08:31 +0000)
This adds support for MPLS protocol including usage of lightweight tunnels.
Kernel size of vmlinuz.bin grows by ~8k.

Signed-off-by: André Valentin <avalentin@marcant.net>
SVN-Revision: 48710

package/kernel/linux/modules/netsupport.mk

index 77bd67a7c3b8424c8df2444192b302e3a3597e1c..8a923ed66e5af495922f73e06b45b0e78b2fb339 100644 (file)
@@ -1001,3 +1001,25 @@ define KernelPackage/rxrpc/description
 endef
 
 $(eval $(call KernelPackage,rxrpc))
+
+define KernelPackage/mpls
+  SUBMENU:=$(NETWORK_SUPPORT_MENU)
+  TITLE:=MPLS support
+  KCONFIG:= \
+       CONFIG_MPLS=y \
+       CONFIG_LWTUNNEL=y \
+       CONFIG_NET_MPLS_GSO=m \
+       CONFIG_MPLS_ROUTING=m \
+       CONFIG_MPLS_IPTUNNEL=m
+  FILES:= \
+       $(LINUX_DIR)/net/mpls/mpls_gso.ko \
+       $(LINUX_DIR)/net/mpls/mpls_iptunnel.ko \
+       $(LINUX_DIR)/net/mpls/mpls_router.ko
+  AUTOLOAD:=$(call AutoLoad,30,mpls_router mpls_iptunnel mpls_gso)
+endef
+
+define KernelPackage/mpls/description
+  Kernel support for MPLS
+endef
+
+$(eval $(call KernelPackage,mpls))