brcm63xx: Add DT support for AR-5387un
authorJonas Gorski <jogo@openwrt.org>
Thu, 21 Aug 2014 11:28:28 +0000 (11:28 +0000)
committerJonas Gorski <jogo@openwrt.org>
Thu, 21 Aug 2014 11:28:28 +0000 (11:28 +0000)
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 42240

28 files changed:
target/linux/brcm63xx/dts/ar-5387un.dts [new file with mode: 0644]
target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/patches-3.14/531-board_AR-5387un.patch
target/linux/brcm63xx/patches-3.14/532-board_AR-5381u.patch
target/linux/brcm63xx/patches-3.14/533-board_rta770bw.patch
target/linux/brcm63xx/patches-3.14/534-board_hw556.patch
target/linux/brcm63xx/patches-3.14/535-board_rta770w.patch
target/linux/brcm63xx/patches-3.14/536-board_fast2704.patch
target/linux/brcm63xx/patches-3.14/537-board_fast2504n.patch
target/linux/brcm63xx/patches-3.14/550-alice_gate2_leds.patch
target/linux/brcm63xx/patches-3.14/551-96348gw_a_leds.patch
target/linux/brcm63xx/patches-3.14/552-board_96348gw-10_reset_button.patch
target/linux/brcm63xx/patches-3.14/553-boards_probe_switch.patch
target/linux/brcm63xx/patches-3.14/554-board_DWVS0_leds_buttons.patch
target/linux/brcm63xx/patches-3.14/555-board_96318ref.patch
target/linux/brcm63xx/patches-3.14/556-board_96318ref_p300.patch
target/linux/brcm63xx/patches-3.14/557-board_bcm963269bhr.patch
target/linux/brcm63xx/patches-3.14/558-board_AR1004G.patch
target/linux/brcm63xx/patches-3.14/559-board_vw6339gu.patch
target/linux/brcm63xx/patches-3.14/560-board_963268gu_p300.patch
target/linux/brcm63xx/patches-3.14/561-board_WAP-5813n.patch
target/linux/brcm63xx/patches-3.14/562-board_VR-3025u.patch
target/linux/brcm63xx/patches-3.14/563-board_VR-3025un.patch
target/linux/brcm63xx/patches-3.14/564-board_P870HW-51a_v2.patch
target/linux/brcm63xx/patches-3.14/565-board_hw520.patch
target/linux/brcm63xx/patches-3.14/566-board_A4001N.patch
target/linux/brcm63xx/patches-3.14/567-board_dsl-2751b_e1.patch
target/linux/brcm63xx/profiles/comtrend.mk

diff --git a/target/linux/brcm63xx/dts/ar-5387un.dts b/target/linux/brcm63xx/dts/ar-5387un.dts
new file mode 100644 (file)
index 0000000..d24a655
--- /dev/null
@@ -0,0 +1,8 @@
+/dts-v1/;
+
+/include/ "bcm6328.dtsi"
+
+/ {
+       model = "Comtrend AR-5387un";
+       compatible = "comtrend,ar-5387un", "brcm,bcm6328";
+};
index 3050d2c588212b311f523532b8b2041d4c08734f..a04709aa167a96277613f01472fde811f9885f82 100755 (executable)
@@ -271,8 +271,6 @@ define Image/Build
        # Sagem F@ST2504n
        $(call Image/Build/CFE,$(1),F@ST2504n,6362,F@ST2504n,OpenWRT-$(REVISION))
 
-       # Comtrend AR-5387un
-       $(call Image/Build/CFE,$(1),96328A-1441N1,6328,AR-5387un,,--pad 8)
        # Comtrend VR-3025u
        $(call Image/Build/CFE,$(1),96368M-1541N,6368,VR-3025u,,--pad 16)
        # Comtrend VR-3025un
@@ -357,6 +355,8 @@ $(eval $(call CfeImageDTB,96328avng,bcm96328avng,96328avng,6328,96328avng-16M-fl
 $(eval $(call CfeImageDTB,AR1004G,ar1004g,96348GW-10,6348,AR1004G))
 # Comtrend AR-5381u
 $(eval $(call CfeImageDTB,AR5381u,ar-5381u,96328A-1241N,6328,AR-5381u,,--pad 8))
+# Comtrend AR-5387un
+$(eval $(call CfeImageDTB,AR5387un,ar-5387un,96328A-1441N1,6328,AR-5387un,,--pad 8))
 # Comtrend 536, 5621
 $(eval $(call CfeImageDTB,CT536_CT5621,ct536plus,96348GW-11,6348,CT536_CT5621))
 # Comtrend CT-5365
index 378ead3d7343ee4b9b62cca309693b7e066ddfef..128354e476c82041baf4d922b10f0e146acda6a5 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -166,6 +166,115 @@ static struct board_info __initdata boar
+@@ -166,6 +166,116 @@ static struct board_info __initdata boar
        },
  };
  
@@ -33,6 +33,7 @@
 +
 +static struct board_info __initdata board_AR5387un = {
 +      .name                                   = "96328A-1441N1",
++      .of_board_id                            = "comtrend,ar-5387un",
 +      .expected_cpu_id                        = 0x6328,
 +
 +      .has_uart0                              = 1,
  static struct board_info __initdata board_963281TAN = {
        .name                           = "963281TAN",
        .expected_cpu_id                = 0x6328,
-@@ -2821,6 +2930,7 @@ static const struct board_info __initcon
+@@ -2821,6 +2931,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
index ada24fffb9127a7cff46440962aef7ed999868d9..f690bc5f91ce16552018d4f73686a54db92a4965 100644 (file)
@@ -93,7 +93,7 @@
  static struct sprom_fixup __initdata ar5387un_fixups[] = {
        { .offset = 2, .value = 0x05bb },
        { .offset = 65, .value = 0x1204 },
-@@ -2930,6 +3016,7 @@ static const struct board_info __initcon
+@@ -2931,6 +3017,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
index cc650d96d7deab06670773d9b3f3ac8e6a2229e7..1d1a45ca20213f1a1f4ca96b8fd211e6cb437019 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -839,6 +839,55 @@ static struct board_info __initdata boar
+@@ -840,6 +840,55 @@ static struct board_info __initdata boar
  
        .has_uart0                      = 1,
  };
@@ -56,7 +56,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6345 */
  
  /*
-@@ -3030,6 +3079,7 @@ static const struct board_info __initcon
+@@ -3031,6 +3080,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6345
        &board_96345gw2,
index d0f7ef99c293c06976a14fe5d378a7a7663cb5ad..f10f5d13a53a50feb30ac9193bef6168af4a9c09 100644 (file)
@@ -8,7 +8,7 @@
  #include <linux/platform_device.h>
  #include <linux/spi/spi.h>
  #include <linux/spi/spi_gpio.h>
-@@ -2677,6 +2678,405 @@ static struct board_info __initdata boar
+@@ -2678,6 +2679,405 @@ static struct board_info __initdata boar
        },
  };
  
   /* T-Home Speedport W 303V Typ B */
  static struct board_info __initdata board_spw303v = {
        .name                   = "96358-502V",
-@@ -3115,6 +3515,9 @@ static const struct board_info __initcon
+@@ -3116,6 +3516,9 @@ static const struct board_info __initcon
        &board_nb4_fxc_r1,
        &board_ct6373_1,
        &board_HW553,
index 01da5fbb1dfa9597d42c78c01997e65f3afe0a2a..efa039f9c644063e1911277bbd3b564a30a5f5dd 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -889,6 +889,60 @@ static struct board_info __initdata boar
+@@ -890,6 +890,60 @@ static struct board_info __initdata boar
                },
        },
  };
@@ -61,7 +61,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6345 */
  
  /*
-@@ -3480,6 +3534,7 @@ static const struct board_info __initcon
+@@ -3481,6 +3535,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6345
        &board_96345gw2,
        &board_rta770bw,
index 9ebeb06a423e9992af14967d94fd786c8fe13b25..00572a487747ff3a628e9bb5d0d7b6c6a993da82 100644 (file)
@@ -12,7 +12,7 @@ Signed-off-by: Marcin Jurkowski <marcin1j@gmail.com>
 ---
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -663,6 +663,122 @@ static struct board_info __initdata boar
+@@ -664,6 +664,122 @@ static struct board_info __initdata boar
                },
        },
  };
@@ -135,7 +135,7 @@ Signed-off-by: Marcin Jurkowski <marcin1j@gmail.com>
  #endif /* CONFIG_BCM63XX_CPU_6328 */
  
  /*
-@@ -3524,6 +3640,7 @@ static const struct board_info __initcon
+@@ -3525,6 +3641,7 @@ static const struct board_info __initcon
        &board_963281TAN,
        &board_A4001N1,
        &board_dsl_274xb_f1,
index 109868c233f356c50c6d6fe09a36df5b3c46d7f4..0298f7cdf4ff8360f138101e000fee320072c23b 100644 (file)
@@ -6,7 +6,7 @@ Signed-off-by: Max Staudt <openwrt.max@enpas.org>
 ---
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -3479,6 +3479,96 @@ static struct board_info __initdata boar
+@@ -3480,6 +3480,96 @@ static struct board_info __initdata boar
        .devs = nb6_devices,
        .num_devs = ARRAY_SIZE(nb6_devices),
  };
@@ -103,7 +103,7 @@ Signed-off-by: Max Staudt <openwrt.max@enpas.org>
  #endif /* CONFIG_BCM63XX_CPU_6362 */
  
  /*
-@@ -3696,6 +3786,7 @@ static const struct board_info __initcon
+@@ -3697,6 +3787,7 @@ static const struct board_info __initcon
  
  #ifdef CONFIG_BCM63XX_CPU_6362
        &board_nb6,
index 2cc1db357ffc68445adb899e4f4380919e082d21..2b6a7e7e80ee57dc7ebeee5f38ee7f939b7a4a97 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -2304,6 +2304,99 @@ static struct board_info __initdata boar
+@@ -2305,6 +2305,99 @@ static struct board_info __initdata boar
  
        .has_ohci0 = 1,
        .has_ehci0 = 1,
index 50017095f7e696c303eabbce612c359fd4760387..2465d1405457bb5613e6fd896a22c9718d320f3c 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -1775,6 +1775,19 @@ static struct board_info __initdata boar
+@@ -1776,6 +1776,19 @@ static struct board_info __initdata boar
        },
  
        .has_ohci0 = 1,
index b6ed7930e9a1489cc792ae0dc9a8203e23d24f27..6ed480208987425850adf5785bbac1481b040b7f 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -1171,6 +1171,17 @@ static struct board_info __initdata boar
+@@ -1172,6 +1172,17 @@ static struct board_info __initdata boar
                        .active_low     = 1,
                },
        },
index 7f735e05a642645f972e222de5f67de32f09819f..2744170ffd0d4cf9f90468c9da31f7d83d08a845 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -793,6 +793,8 @@ static struct board_info __initdata boar
+@@ -794,6 +794,8 @@ static struct board_info __initdata boar
        .has_uart0                      = 1,
        .has_enet0                      = 1,
        .enet0 = {
@@ -9,7 +9,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -837,6 +839,8 @@ static struct board_info __initdata boar
+@@ -838,6 +840,8 @@ static struct board_info __initdata boar
        .has_uart0                      = 1,
        .has_enet0                      = 1,
        .enet0 = {
@@ -18,7 +18,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -1127,6 +1131,8 @@ static struct board_info __initdata boar
+@@ -1128,6 +1132,8 @@ static struct board_info __initdata boar
                .use_internal_phy       = 1,
        },
        .enet1 = {
@@ -27,7 +27,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -1201,6 +1207,8 @@ static struct board_info __initdata boar
+@@ -1202,6 +1208,8 @@ static struct board_info __initdata boar
        },
  
        .enet1 = {
@@ -36,7 +36,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -1482,6 +1490,8 @@ static struct board_info __initdata boar
+@@ -1483,6 +1491,8 @@ static struct board_info __initdata boar
                .use_internal_phy       = 1,
        },
        .enet1 = {
@@ -45,7 +45,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -1661,6 +1671,8 @@ static struct board_info __initdata boar
+@@ -1662,6 +1672,8 @@ static struct board_info __initdata boar
        },
  
        .enet1 = {
@@ -54,7 +54,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -1737,6 +1749,8 @@ static struct board_info __initdata boar
+@@ -1738,6 +1750,8 @@ static struct board_info __initdata boar
                .use_internal_phy       = 1,
        },
        .enet1 = {
@@ -63,7 +63,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -1760,6 +1774,8 @@ static struct board_info __initdata boar
+@@ -1761,6 +1775,8 @@ static struct board_info __initdata boar
                .use_internal_phy       = 1,
        },
        .enet1 = {
@@ -72,7 +72,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -1781,6 +1797,8 @@ static struct board_info __initdata boar
+@@ -1782,6 +1798,8 @@ static struct board_info __initdata boar
                .use_internal_phy       = 1,
        },
        .enet1 = {
@@ -81,7 +81,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -2126,6 +2144,8 @@ static struct board_info __initdata boar
+@@ -2127,6 +2145,8 @@ static struct board_info __initdata boar
        },
  
        .enet1 = {
@@ -90,7 +90,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -2180,6 +2200,8 @@ static struct board_info __initdata boar
+@@ -2181,6 +2201,8 @@ static struct board_info __initdata boar
        },
  
        .enet1 = {
@@ -99,7 +99,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -2322,6 +2344,8 @@ static struct board_info __initdata boar
+@@ -2323,6 +2345,8 @@ static struct board_info __initdata boar
        },
  
        .enet1 = {
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -2441,6 +2465,8 @@ static struct board_info __initdata boar
+@@ -2442,6 +2466,8 @@ static struct board_info __initdata boar
        },
  
        .enet1 = {
index 56840a8d1cbea38b8fe3608e1c07c96b2efb1579..b254a0b8ab370a6c2510575c157b7380781116f4 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -2473,6 +2473,94 @@ static struct board_info __initdata boar
+@@ -2474,6 +2474,94 @@ static struct board_info __initdata boar
  
        .has_ohci0                      = 1,
        .has_ehci0                      = 1,
index 081a9bbc137c19f26c087e8bf50eca8b4dd47c2f..b465ef3ee943996294ea70a4e05708ea225d6d75 100644 (file)
@@ -94,7 +94,7 @@
   * known 6328 boards
   */
  #ifdef CONFIG_BCM63XX_CPU_6328
-@@ -3954,6 +4041,9 @@ static const struct board_info __initcon
+@@ -3955,6 +4042,9 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_3368
        &board_cvg834g,
  #endif
index 25cfde937c4b67c38aff7c210a5c6ae0dae33de8..81d6dd34e590a0efe77b9644436ab7c62b75ad39 100644 (file)
@@ -95,7 +95,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6318 */
  
  /*
-@@ -4043,6 +4131,7 @@ static const struct board_info __initcon
+@@ -4044,6 +4132,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6318
        &board_96318ref,
index 16f6283b1be1b9c98a476a3cb310f69c4d46d571..95ebdbd839daf7ccc8ac4cbb5ca20779949d1a8a 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4123,6 +4123,75 @@ static struct board_info __initdata boar
+@@ -4124,6 +4124,75 @@ static struct board_info __initdata boar
  #endif /* CONFIG_BCM63XX_CPU_6368 */
  
  /*
@@ -76,7 +76,7 @@
   * all boards
   */
  static const struct board_info __initconst *bcm963xx_boards[] = {
-@@ -4203,6 +4272,9 @@ static const struct board_info __initcon
+@@ -4204,6 +4273,9 @@ static const struct board_info __initcon
        &board_96368mvwg,
        &board_96368mvngr,
  #endif
index 1060e71d82a3109664a84c0858dac71f536f61d8..57858e3b26fb6cd2b41a706c509dcc7487ef96ad 100644 (file)
@@ -8,7 +8,7 @@ Signed-off-by: Adrian Feliks <mexit@o2.pl>
 ---
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -1433,6 +1433,52 @@ static struct board_info __initdata boar
+@@ -1434,6 +1434,52 @@ static struct board_info __initdata boar
        },
  };
  
@@ -61,7 +61,7 @@ Signed-off-by: Adrian Feliks <mexit@o2.pl>
  
  /* BT Voyager 2110 */
  static struct board_info __initdata board_V2110 = {
-@@ -4243,6 +4289,7 @@ static const struct board_info __initcon
+@@ -4244,6 +4290,7 @@ static const struct board_info __initcon
        &board_96348A_122,
        &board_CPVA502plus,
        &board_96348W3,
index 1c76d9f67d637e2b298ac5a5a7c835c715c24da0..2d698f4e711b4fd8a684805c1c428665269b1c3a 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4235,6 +4235,108 @@ static struct board_info __initdata boar
+@@ -4236,6 +4236,108 @@ static struct board_info __initdata boar
                },
        },
  };
  #endif /* CONFIG_BCM63XX_CPU_63268 */
  
  /*
-@@ -4321,6 +4423,7 @@ static const struct board_info __initcon
+@@ -4322,6 +4424,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
        &board_963269bhr,
index 023dc0bdc0448e45739368022a638ef58489b140..6cd4c326d772a877175eb1d186da6d6f39e56480 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4172,6 +4172,131 @@ static struct board_info __initdata boar
+@@ -4173,6 +4173,131 @@ static struct board_info __initdata boar
   * known 63268/63269 boards
   */
  #ifdef CONFIG_BCM63XX_CPU_63268
  static struct board_info __initdata board_963269bhr = {
        .name                           = "963269BHR",
        .expected_cpu_id                = 0x63268,
-@@ -4422,6 +4547,7 @@ static const struct board_info __initcon
+@@ -4423,6 +4548,7 @@ static const struct board_info __initcon
        &board_96368mvngr,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
index ffff144b6fc991d3fb0c9eb0d1e3c061cf0a553c..c8337cb163b175744cda9c1e00a5037b1e0f764f 100644 (file)
@@ -8,7 +8,7 @@
  #include <linux/platform_device.h>
  #include <linux/spi/spi.h>
  #include <linux/spi/spi_gpio.h>
-@@ -4166,6 +4167,117 @@ static struct board_info __initdata boar
+@@ -4167,6 +4168,117 @@ static struct board_info __initdata boar
        .has_ohci0 = 1,
        .has_ehci0 = 1,
  };
  #endif /* CONFIG_BCM63XX_CPU_6368 */
  
  /*
-@@ -4545,6 +4657,7 @@ static const struct board_info __initcon
+@@ -4546,6 +4658,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
index 65aef42deb89b7680c9ad715cb58b4308533fc84..9bf57b9afa56240512d518f43db07b68c5139a77 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4168,6 +4168,116 @@ static struct board_info __initdata boar
+@@ -4169,6 +4169,116 @@ static struct board_info __initdata boar
        .has_ehci0 = 1,
  };
  
  static struct b53_platform_data WAP5813n_b53_pdata = {
        .alias = "eth0",
  };
-@@ -4657,6 +4767,7 @@ static const struct board_info __initcon
+@@ -4658,6 +4768,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
index d97a5f9af53b3b2e888c86b4d1021c1171fd655d..bb7597a464fb8a2681c8a64076c3cddd03796ea2 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4278,6 +4278,116 @@ static struct board_info __initdata boar
+@@ -4279,6 +4279,116 @@ static struct board_info __initdata boar
        },
  };
  
  static struct b53_platform_data WAP5813n_b53_pdata = {
        .alias = "eth0",
  };
-@@ -4768,6 +4878,7 @@ static const struct board_info __initcon
+@@ -4769,6 +4879,7 @@ static const struct board_info __initcon
        &board_96368mvwg,
        &board_96368mvngr,
        &board_VR3025u,
index 2facb47bded08009b400e338510e07e115fb8f1f..4aefa3380c8478cf89f1e43a32ffe2830f30f881 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4177,6 +4177,96 @@ static struct sprom_fixup __initdata vr3
+@@ -4178,6 +4178,96 @@ static struct sprom_fixup __initdata vr3
        { .offset = 115, .value = 0xfad9 },
  };
  
@@ -97,7 +97,7 @@
  static struct board_info __initdata board_VR3025u = {
        .name                                   = "96368M-1541N",
        .expected_cpu_id                = 0x6368,
-@@ -4877,6 +4967,7 @@ static const struct board_info __initcon
+@@ -4878,6 +4968,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
index d2619d721f5b6c9da2253e7b2159789756d29281..7f9292f242b617882638b738a51811d4099db5a5 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -3224,6 +3224,56 @@ static struct board_info __initdata boar
+@@ -3225,6 +3225,56 @@ static struct board_info __initdata boar
        .num_spis = ARRAY_SIZE(ct6373_spi_devices),
  };
  
@@ -57,7 +57,7 @@
  static struct board_info __initdata board_HW553 = {
        .name                           = "HW553",
        .expected_cpu_id                = 0x6358,
-@@ -4951,6 +5001,7 @@ static const struct board_info __initcon
+@@ -4952,6 +5002,7 @@ static const struct board_info __initcon
        &board_nb4_ser_r0,
        &board_nb4_fxc_r1,
        &board_ct6373_1,
index 614bf3013d8c6e8e5eeed042b7f0591e4a9b8c54..6d0611a2b991b197fca1c423b5ae37ef760873ad 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -608,6 +608,95 @@ static struct board_info __initdata boar
+@@ -609,6 +609,95 @@ static struct board_info __initdata boar
        },
  };
  
@@ -96,7 +96,7 @@
  static struct board_info __initdata board_A4001N1 = {
        .name                                   = "963281T_TEF",
        .expected_cpu_id                        = 0x6328,
-@@ -4952,6 +5041,7 @@ static const struct board_info __initcon
+@@ -4953,6 +5042,7 @@ static const struct board_info __initcon
        &board_AR5381u,
        &board_AR5387un,
        &board_963281TAN,
index f4aa659e3aae6d90ccb945106e5293b828ca3486..bdf7690f4cf39b55ecbf78ddc42fe2392a4ccfd5 100644 (file)
  #endif /* CONFIG_BCM63XX_CPU_6318 */
  
  /*
-@@ -5035,6 +5170,7 @@ static const struct board_info __initcon
+@@ -5036,6 +5171,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6318
        &board_96318ref,
        &board_96318ref_p300,
index 80a57040cb2a53dee1fe53a58457a25ff5656f69..6118c271653961cb607e66f5eef550135c643c31 100644 (file)
@@ -15,6 +15,16 @@ define Profile/AR5381u/Description
 endef
 $(eval $(call Profile,AR5381u))
 
+define Profile/AR5387un
+  NAME:=Comtrend AR-5387un
+  PACKAGES:=kmod-b43 wpad-mini \
+       kmod-usb2 kmod-usb-ohci
+endef
+define Profile/AR5387un/Description
+  Package set optimized for AR-5387un.
+endef
+$(eval $(call Profile,AR5387un))
+
 define Profile/CT536_CT5621
   NAME:=Comtrend CT-536+/CT-5621
   PACKAGES:=kmod-b43 wpad-mini