introduce a menuconfig option to turn off static linking of host utilities
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 13 Aug 2012 00:26:34 +0000 (00:26 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 13 Aug 2012 00:26:34 +0000 (00:26 +0000)
SVN-Revision: 33154

Config.in
include/host-build.mk

index 0553712f7654aa2a5c7eed5c0f9f2681549bfe9e..e865777bee6b90fa1cb1df0fffbd99b08191ccf7 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -153,6 +153,13 @@ menu "Global build settings"
                  When this option is enabled, packages are built with the full versions of iconv and GNU gettext
                  instead of the default OpenWrt stubs. If uClibc is used, it is also built with locale support.
 
+       config BUILD_STATIC_TOOLS
+               default y
+               bool "Attempt to link host utilities statically"
+               help
+                 Linking host utilities like sed or firmware-utils statically increases the portability of the
+                 generated ImageBuilder and SDK tarballs, however it may fail on some Linux distributions.
+
        config SHADOW_PASSWORDS
                bool
                prompt "Enable shadow password support"
index a8bc79ea67de34648d444644e694539b8d95d219..40af5c87ccfa703d3030603f88a87b1d534744fd 100644 (file)
@@ -66,7 +66,9 @@ HOST_CONFIGURE_ARGS = \
 HOST_CONFIGURE_CMD = ./configure
 
 ifneq ($(HOST_OS),Darwin)
-  HOST_STATIC_LINKING = -static
+  ifeq ($(CONFIG_BUILD_STATIC_TOOLS),y)
+    HOST_STATIC_LINKING = -static
+  endif
 endif
 
 define Host/Configure/Default