build: add diffconfig target
authorJo-Philipp Wich <jo@mein.io>
Wed, 4 Jan 2017 08:03:50 +0000 (09:03 +0100)
committerJo-Philipp Wich <jo@mein.io>
Wed, 4 Jan 2017 10:03:53 +0000 (11:03 +0100)
Add a "diffconfig" build target which stores the output of
"scripts/diffconfig.sh" as "config.seed" in the image output directory and
invoke that target by default.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Makefile

index 51ed5a1132e358c2fade97b93f1ab38c1608e9de..3450f7e2973420ee202b112e7b9b8d4dbbb73123 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -87,9 +87,13 @@ prereq: $(target/stamp-prereq) tmp/.prereq_packages
 checksum: FORCE
        $(call sha256sums,$(BIN_DIR))
 
 checksum: FORCE
        $(call sha256sums,$(BIN_DIR))
 
+diffconfig: FORCE
+       $(SCRIPT_DIR)/diffconfig.sh > $(BIN_DIR)/config.seed
+
 prepare: .config $(tools/stamp-install) $(toolchain/stamp-install)
 world: prepare $(target/stamp-compile) $(package/stamp-compile) $(package/stamp-install) $(target/stamp-install) FORCE
        $(_SINGLE)$(SUBMAKE) -r package/index
 prepare: .config $(tools/stamp-install) $(toolchain/stamp-install)
 world: prepare $(target/stamp-compile) $(package/stamp-compile) $(package/stamp-install) $(target/stamp-install) FORCE
        $(_SINGLE)$(SUBMAKE) -r package/index
+       $(_SINGLE)$(SUBMAKE) -r diffconfig
        $(_SINGLE)$(SUBMAKE) -r checksum
 
 .PHONY: clean dirclean prereq prepare world package/symlinks package/symlinks-install package/symlinks-clean
        $(_SINGLE)$(SUBMAKE) -r checksum
 
 .PHONY: clean dirclean prereq prepare world package/symlinks package/symlinks-install package/symlinks-clean