kirkwood: add sheevaplug and derivatives
authorLuka Perkov <luka@openwrt.org>
Wed, 17 Dec 2014 08:33:55 +0000 (08:33 +0000)
committerLuka Perkov <luka@openwrt.org>
Wed, 17 Dec 2014 08:33:55 +0000 (08:33 +0000)
Add kirkwood FDT:
- SheevaPlug
- SheevaPlug with eSATA
- GuruplugServerPlus
- Topkick1281P2

Signed-off-by: GĂ©rald Kerma <drEagle@doukki.net>
SVN-Revision: 43735

target/linux/kirkwood/image/Makefile
target/linux/kirkwood/profiles/120-plug.mk [new file with mode: 0644]

index 5227ed26e7bc7d9014f3ec5519002e3c376bcf33..ede7cb30aa22a7c1ac85545dc25d98b0b9c9bad2 100644 (file)
@@ -138,6 +138,18 @@ Image/InstallKernel/Template/IOMEGA_IX2_200=$(call Image/InstallKernel/Template,
 Image/BuildKernel/Template/POGOE02=$(call Image/BuildKernel/Template,pogo_e02)
 Image/InstallKernel/Template/POGOE02=$(call Image/InstallKernel/Template,pogo_e02)
 
+Image/BuildKernel/Template/SHEEVAPLUG=$(call Image/BuildKernel/Template,sheevaplug)
+Image/InstallKernel/Template/SHEEVAPLUG=$(call Image/InstallKernel/Template,sheevaplug)
+
+Image/BuildKernel/Template/SHEEVAPLUGSATA=$(call Image/BuildKernel/Template,sheevaplug-esata)
+Image/InstallKernel/Template/SHEEVAPLUGSATA=$(call Image/InstallKernel/Template,sheevaplug-esata)
+
+Image/BuildKernel/Template/GuruplugServerPlus=$(call Image/BuildKernel/Template,guruplug-server-plus)
+Image/InstallKernel/Template/GuruplugServerPlus=$(call Image/InstallKernel/Template,guruplug-server-plus)
+
+Image/BuildKernel/Template/Topkick1281P2=$(call Image/BuildKernel/Template,topkick)
+Image/InstallKernel/Template/Topkick1281P2=$(call Image/InstallKernel/Template,topkick)
+
 define Image/BuildKernel
        $(call Image/BuildKernel/Template/$(PROFILE))
 endef
diff --git a/target/linux/kirkwood/profiles/120-plug.mk b/target/linux/kirkwood/profiles/120-plug.mk
new file mode 100644 (file)
index 0000000..cca703f
--- /dev/null
@@ -0,0 +1,78 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/SHEEVAPLUG
+  NAME:=Globalscale Technologies SheevaPlug
+  PACKAGES:= \
+       kmod-mmc kmod-mvsdio kmod-usb2 kmod-usb-storage \
+       kmod-of-i2c kmod-i2c-core kmod-i2c-mv64xxx \
+       kmod-ata-core uboot-envtools
+endef
+
+define Profile/SHEEVAPLUG/Description
+ Package set compatible with Globalscale Technologies SheevaPlug board.
+endef
+
+SHEEVAPLUG_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
+SHEEVAPLUG_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+
+$(eval $(call Profile,SHEEVAPLUG))
+
+define Profile/SHEEVAPLUGSATA
+  NAME:=Globalscale Technologies eSATA SheevaPlug
+  PACKAGES:= \
+       kmod-mmc kmod-mvsdio kmod-usb2 kmod-usb-storage \
+       kmod-of-i2c kmod-i2c-core kmod-i2c-mv64xxx \
+       kmod-ata-core kmod-ata-marvell-sata \
+       uboot-envtools
+endef
+
+define Profile/SHEEVAPLUGSATA/Description
+ Package set compatible with Globalscale Technologies eSATA SheevaPlug board.
+endef
+
+SHEEVAPLUGSATA_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
+SHEEVAPLUGSATA_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+
+$(eval $(call Profile,SHEEVAPLUGSATA))
+
+define Profile/GuruplugServerPlus
+  NAME:=Globalscale Technologies Guruplug Server Plus
+  PACKAGES:= \
+       kmod-mmc kmod-mvsdio kmod-usb2 kmod-usb-storage \
+       kmod-of-i2c kmod-i2c-core kmod-i2c-mv64xxx \
+       kmod-ata-core kmod-ata-marvell-sata \
+       kmod-btmrvl kmod-btmrvl-sdio kmod-libertas kmod-libertas-sdio \
+       uboot-envtools
+endef
+
+define Profile/GuruplugServerPlus/Description
+ Package set compatible with Globalscale Technologies Guruplug Server Plus board.
+endef
+
+GuruplugServerPlus_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
+GuruplugServerPlus_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+
+$(eval $(call Profile,GuruplugServerPlus))
+
+define Profile/Topkick1281P2
+  NAME:=Univeral Scientific Industrial Co. Topkick-1281P2
+  PACKAGES:= \
+       kmod-mmc kmod-mvsdio kmod-usb2 kmod-usb-storage \
+       kmod-of-i2c kmod-i2c-core kmod-i2c-mv64xxx \
+       kmod-ata-core kmod-ata-marvell-sata \
+       uboot-envtools
+endef
+
+define Profile/Topkick1281P2/Description
+ Package set compatible with Univeral Scientific Industrial Co. Topkick-1281P2 board.
+endef
+
+Topkick1281P2_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
+Topkick1281P2_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+
+$(eval $(call Profile,Topkick1281P2))