include: rework git prereq test to not require 'man'
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 6 Feb 2015 11:50:08 +0000 (11:50 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 6 Feb 2015 11:50:08 +0000 (11:50 +0000)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 44292

include/prereq-build.mk

index 1c8de0638ee322f0989203bbc592c97825d77adf..7945f053251b3ce5f5c76e1c3faadd245ff0e711 100644 (file)
@@ -143,7 +143,7 @@ $(eval $(call SetupHostCommand,svn,Please install the Subversion client, \
        svn --version | grep Subversion))
 
 $(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.6.5, \
-       git clone --help | grep -- --recursive))
+       git clone 2>&1 | grep -- --recursive))
 
 $(eval $(call SetupHostCommand,file,Please install the 'file' package, \
        file --version | grep file))