octeon: fix image build
authorJo-Philipp Wich <jo@mein.io>
Thu, 28 Jul 2016 17:21:44 +0000 (19:21 +0200)
committerJo-Philipp Wich <jo@mein.io>
Thu, 28 Jul 2016 17:44:19 +0000 (19:44 +0200)
After b47f438 "build: remove image prefix from kernel files in KDIR", the
kernel image in $(KDIR) has a different name and could not be found by the
tar-file build step anymore, leading to the following error on the build
servers:

  cp: cannot stat `.../linux-octeon/lede-octeon-generic-kernel.bin': No such file or directory
  make[4]: *** [.../linux-octeon/tmp/lede-octeon-generic-ext4-sysupgrade.tar] Error 1

Adjust the path to the source kernel image in order to fix the problem.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
target/linux/octeon/image/Makefile

index 89cbba592c79294b90c5261b76a18e286e0cd2a2..e2d6539ad352a15c320c81d2f3d0692e025f4491 100644 (file)
@@ -22,7 +22,7 @@ endef
 define Build/tar-file
        mkdir -p $(KDIR)/sysupgrade-$(DEVICE_NAME)/
        echo "BOARD=$(BOARD)" > $(KDIR)/sysupgrade-$(DEVICE_NAME)/CONTROL
-       $(CP) $(KDIR)/$(KERNEL_IMAGE) $(KDIR)/sysupgrade-$(DEVICE_NAME)/kernel
+       $(CP) $(KDIR_KERNEL_IMAGE) $(KDIR)/sysupgrade-$(DEVICE_NAME)/kernel
        $(CP) $(KDIR)/root.$(1) $(KDIR)/sysupgrade-$(DEVICE_NAME)/root
        (cd $(KDIR); $(TAR) cvf \
                $@ sysupgrade-$(DEVICE_NAME))