kernel: update kernel 4.4 to version 4.4.31
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Sat, 12 Nov 2016 13:52:47 +0000 (14:52 +0100)
committerJohn Crispin <john@phrozen.org>
Wed, 16 Nov 2016 09:54:33 +0000 (10:54 +0100)
+ Refresh patches
compile/run-tested on cns3xxx & imx6.

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/patches-4.4/051-0002-ovl-override-creds-with-the-ones-from-the-superblock.patch
target/linux/generic/patches-4.4/052-01-ubifs-Implement-O_TMPFILE.patch
target/linux/generic/patches-4.4/052-02-ubifs-Implement-RENAME_WHITEOUT.patch
target/linux/generic/patches-4.4/052-03-ubifs-Implement-RENAME_EXCHANGE.patch
target/linux/generic/patches-4.4/077-0005-bgmac-stop-clearing-DMA-receive-control-register-rig.patch
target/linux/generic/patches-4.4/201-extra_optimization.patch

index f4067193c76e0a361dc49e76da63b74d2b014293..13d39fb8fe4abc09491aaecbdb75c82d73e2860a 100644 (file)
@@ -4,11 +4,11 @@ LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .43
 LINUX_VERSION-4.1 = .34
-LINUX_VERSION-4.4 = .30
+LINUX_VERSION-4.4 = .31
 
 LINUX_KERNEL_MD5SUM-3.18.43 = b1faeb4a2e1e70ffe061bdbb3452840a
 LINUX_KERNEL_MD5SUM-4.1.34 = fba99f0f4765ebf01033e69518740a3c
-LINUX_KERNEL_MD5SUM-4.4.30 = 9d249133bd12dde04f434bb4a5a4a23dd42ead721803c0ba4b5742efd239995c
+LINUX_KERNEL_MD5SUM-4.4.31 = 29d9b0b1aa4dec3eb1a9edf1b84e79c5
 
 ifdef KERNEL_PATCHVER
   LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
index eed7bb2bcdca84afc11a111ec54612144e068e46..208bc61ec529cd1419783399e0e218942286a6d3 100644 (file)
@@ -58,7 +58,7 @@ Signed-off-by: Miklos Szeredi <mszeredi@redhat.com>
 
 --- a/fs/overlayfs/copy_up.c
 +++ b/fs/overlayfs/copy_up.c
-@@ -315,7 +315,6 @@ int ovl_copy_up_one(struct dentry *paren
+@@ -317,7 +317,6 @@ int ovl_copy_up_one(struct dentry *paren
        struct dentry *upperdir;
        struct dentry *upperdentry;
        const struct cred *old_cred;
@@ -66,7 +66,7 @@ Signed-off-by: Miklos Szeredi <mszeredi@redhat.com>
        char *link = NULL;
  
        if (WARN_ON(!workdir))
-@@ -334,28 +333,7 @@ int ovl_copy_up_one(struct dentry *paren
+@@ -336,28 +335,7 @@ int ovl_copy_up_one(struct dentry *paren
                        return PTR_ERR(link);
        }
  
@@ -96,7 +96,7 @@ Signed-off-by: Miklos Szeredi <mszeredi@redhat.com>
  
        err = -EIO;
        if (lock_rename(workdir, upperdir) != NULL) {
-@@ -378,9 +356,7 @@ int ovl_copy_up_one(struct dentry *paren
+@@ -380,9 +358,7 @@ int ovl_copy_up_one(struct dentry *paren
  out_unlock:
        unlock_rename(workdir, upperdir);
        revert_creds(old_cred);
index 957935c6af036a38472a8d10f7e4daa54254a6a3..1c55a89acf02f03c0875fc076ffa96955c43f312 100644 (file)
@@ -89,7 +89,7 @@ Signed-off-by: Richard Weinberger <richard@nod.at>
  /**
   * vfs_dent_type - get VFS directory entry type.
   * @type: UBIFS directory entry type
-@@ -1189,6 +1259,7 @@ const struct inode_operations ubifs_dir_
+@@ -1195,6 +1265,7 @@ const struct inode_operations ubifs_dir_
  #ifdef CONFIG_UBIFS_ATIME_SUPPORT
        .update_time = ubifs_update_time,
  #endif
index dd75ef4f47485a160eb1dcaa4f03743416f7cc78..c2ec904939872a55d875bcfc41c1252d8991f902 100644 (file)
@@ -65,7 +65,7 @@ Signed-off-by: Richard Weinberger <richard@nod.at>
  /**
   * vfs_dent_type - get VFS directory entry type.
   * @type: UBIFS directory entry type
-@@ -997,37 +1016,43 @@ out_budg:
+@@ -1003,37 +1022,43 @@ out_budg:
  }
  
  /**
@@ -116,7 +116,7 @@ Signed-off-by: Richard Weinberger <richard@nod.at>
        if (inode3)
                mutex_unlock(&ubifs_inode(inode3)->ui_mutex);
        if (inode1 != inode2)
-@@ -1036,12 +1061,15 @@ static void unlock_3_inodes(struct inode
+@@ -1042,12 +1067,15 @@ static void unlock_3_inodes(struct inode
  }
  
  static int ubifs_rename(struct inode *old_dir, struct dentry *old_dentry,
@@ -133,7 +133,7 @@ Signed-off-by: Richard Weinberger <richard@nod.at>
        int err, release, sync = 0, move = (new_dir != old_dir);
        int is_dir = S_ISDIR(old_inode->i_mode);
        int unlink = !!new_inode;
-@@ -1063,9 +1091,13 @@ static int ubifs_rename(struct inode *ol
+@@ -1069,9 +1097,13 @@ static int ubifs_rename(struct inode *ol
         * separately.
         */
  
@@ -149,7 +149,7 @@ Signed-off-by: Richard Weinberger <richard@nod.at>
        ubifs_assert(mutex_is_locked(&old_dir->i_mutex));
        ubifs_assert(mutex_is_locked(&new_dir->i_mutex));
        if (unlink)
-@@ -1087,7 +1119,32 @@ static int ubifs_rename(struct inode *ol
+@@ -1093,7 +1125,32 @@ static int ubifs_rename(struct inode *ol
                return err;
        }
  
@@ -183,7 +183,7 @@ Signed-off-by: Richard Weinberger <richard@nod.at>
  
        /*
         * Like most other Unix systems, set the @i_ctime for inodes on a
-@@ -1157,12 +1214,34 @@ static int ubifs_rename(struct inode *ol
+@@ -1163,12 +1220,34 @@ static int ubifs_rename(struct inode *ol
                if (unlink && IS_SYNC(new_inode))
                        sync = 1;
        }
@@ -220,7 +220,7 @@ Signed-off-by: Richard Weinberger <richard@nod.at>
        ubifs_release_budget(c, &req);
  
        mutex_lock(&old_inode_ui->ui_mutex);
-@@ -1195,7 +1274,11 @@ out_cancel:
+@@ -1201,7 +1280,11 @@ out_cancel:
                                inc_nlink(old_dir);
                }
        }
@@ -233,7 +233,7 @@ Signed-off-by: Richard Weinberger <richard@nod.at>
        ubifs_release_budget(c, &ino_req);
        ubifs_release_budget(c, &req);
        return err;
-@@ -1249,7 +1332,7 @@ const struct inode_operations ubifs_dir_
+@@ -1255,7 +1338,7 @@ const struct inode_operations ubifs_dir_
        .mkdir       = ubifs_mkdir,
        .rmdir       = ubifs_rmdir,
        .mknod       = ubifs_mknod,
index 20856c347d4c2d37a1b0eaba13cc1d414e897017..1830cd0eebecbe85a3c9af2a3e7ddad8cf0bc92b 100644 (file)
@@ -16,7 +16,7 @@ Signed-off-by: Richard Weinberger <richard@nod.at>
 
 --- a/fs/ubifs/dir.c
 +++ b/fs/ubifs/dir.c
-@@ -1095,11 +1095,6 @@ static int ubifs_rename(struct inode *ol
+@@ -1101,11 +1101,6 @@ static int ubifs_rename(struct inode *ol
                old_dentry, old_inode->i_ino, old_dir->i_ino,
                new_dentry, new_dir->i_ino, flags);
  
@@ -28,7 +28,7 @@ Signed-off-by: Richard Weinberger <richard@nod.at>
        if (unlink)
                ubifs_assert(mutex_is_locked(&new_inode->i_mutex));
  
-@@ -1284,6 +1279,64 @@ out_cancel:
+@@ -1290,6 +1285,64 @@ out_cancel:
        return err;
  }
  
@@ -93,7 +93,7 @@ Signed-off-by: Richard Weinberger <richard@nod.at>
  int ubifs_getattr(struct vfsmount *mnt, struct dentry *dentry,
                  struct kstat *stat)
  {
-@@ -1332,7 +1385,7 @@ const struct inode_operations ubifs_dir_
+@@ -1338,7 +1391,7 @@ const struct inode_operations ubifs_dir_
        .mkdir       = ubifs_mkdir,
        .rmdir       = ubifs_rmdir,
        .mknod       = ubifs_mknod,
index 0c4767895bfc7adac9ee1ffc1430aa08f1743280..e09524b0fa3c84dec042f78ca9e9f50f02484a49 100644 (file)
@@ -31,11 +31,9 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  drivers/net/ethernet/broadcom/bgmac.c | 5 ++++-
  1 file changed, 4 insertions(+), 1 deletion(-)
 
-diff --git a/drivers/net/ethernet/broadcom/bgmac.c b/drivers/net/ethernet/broadcom/bgmac.c
-index 31ca204..91cbf92 100644
 --- a/drivers/net/ethernet/broadcom/bgmac.c
 +++ b/drivers/net/ethernet/broadcom/bgmac.c
-@@ -307,6 +307,10 @@ static void bgmac_dma_rx_enable(struct bgmac *bgmac,
+@@ -307,6 +307,10 @@ static void bgmac_dma_rx_enable(struct b
        u32 ctl;
  
        ctl = bgmac_read(bgmac, ring->mmio_base + BGMAC_DMA_RX_CTL);
@@ -46,7 +44,7 @@ index 31ca204..91cbf92 100644
        if (bgmac->feature_flags & BGMAC_FEAT_RX_MASK_SETUP) {
                ctl &= ~BGMAC_DMA_RX_BL_MASK;
                ctl |= BGMAC_DMA_RX_BL_128 << BGMAC_DMA_RX_BL_SHIFT;
-@@ -317,7 +321,6 @@ static void bgmac_dma_rx_enable(struct bgmac *bgmac,
+@@ -317,7 +321,6 @@ static void bgmac_dma_rx_enable(struct b
                ctl &= ~BGMAC_DMA_RX_PT_MASK;
                ctl |= BGMAC_DMA_RX_PT_1 << BGMAC_DMA_RX_PT_SHIFT;
        }
@@ -54,6 +52,3 @@ index 31ca204..91cbf92 100644
        ctl |= BGMAC_DMA_RX_ENABLE;
        ctl |= BGMAC_DMA_RX_PARITY_DISABLE;
        ctl |= BGMAC_DMA_RX_OVERFLOW_CONT;
--- 
-2.10.1
-
index 508627a7e4e9f6b4f78c2d7610c45c6ab68aa9a5..d2f6642226f793ac8479ffe845ae7b5a387e2f37 100644 (file)
@@ -1,7 +1,7 @@
 --- a/Makefile
 +++ b/Makefile
-@@ -619,12 +619,12 @@ KBUILD_CFLAGS    += $(call cc-option,-fno-d
- KBUILD_CFLAGS += $(call cc-disable-warning,maybe-uninitialized,)
+@@ -620,12 +620,12 @@ KBUILD_CFLAGS    += $(call cc-disable-warni
+ KBUILD_CFLAGS += $(call cc-disable-warning,frame-address,)
  
  ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
 -KBUILD_CFLAGS += -Os