host.mk: introduce PATCH which refers to either gpatch or patch
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 7 Oct 2010 11:33:12 +0000 (11:33 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 7 Oct 2010 11:33:12 +0000 (11:33 +0000)
SVN-Revision: 23287

include/host.mk

index f3e47c8723c452218968c7b8d2b7843a97e89acc..9b8a32b672d3579c5cbe1deed2f7625dec912e0a 100644 (file)
@@ -59,6 +59,9 @@ $(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
                else \
                        echo 'XARGS:=xargs' >> $@; \
                fi; \
+               PATCH=`which gpatch 2>/dev/null`; \
+               [ -n "$$PATCH" -a -x "$$PATCH" ] || PATCH=`which patch 2>/dev/null`; \
+               echo "PATCH:=$$PATCH" >> $@; \
        )
 
 endif