opkg: work around unconditional libopenssl build dependency
authorFelix Fietkau <nbd@openwrt.org>
Fri, 11 Sep 2015 16:31:01 +0000 (16:31 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 11 Sep 2015 16:31:01 +0000 (16:31 +0000)
As the OpenWrt build system only resolves build dependencies per directory,
all opkg variants were causing libopenssl to be downloaded and built,
not only opkg-smime. Fix this by applying the same workaround as in
ustream-ssl.

Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
SVN-Revision: 46850

package/system/opkg/Makefile

index 32bcf2bdf1d5c61b2b1bb0987c578f0c8bf4bf1a..4da4d468370dbea69957fae0eaf6f784c192e5fc 100644 (file)
@@ -72,7 +72,7 @@ endef
 define Package/opkg-smime
   $(call Package/opkg/Default)
   TITLE+= (with S/MIME signature support)
-  DEPENDS+=+libopenssl
+  DEPENDS+=+PACKAGE_opkg-smime:libopenssl
   VARIANT:=smime
 endef