image: add support for k unit suffix to append-ubi
authorMathias Kresin <dev@kresin.me>
Sun, 4 Sep 2016 06:51:58 +0000 (08:51 +0200)
committerMathias Kresin <dev@kresin.me>
Sun, 4 Sep 2016 06:51:58 +0000 (08:51 +0200)
Allows to use the same unit for all definitions of the blocksize to be
consistent regardless of the used filesystem.

Signed-off-by: Mathias Kresin <dev@kresin.me>
include/image-commands.mk

index 3b9ea3ccba887fe7cc32ed657ec2543c25feec7f..6cb5bff4ab79008b5f5a7f547ea2fd0246fc7d45 100644 (file)
@@ -117,7 +117,7 @@ define Build/append-ubi
                $(foreach part,$(UBINIZE_PARTS),--part $(part)) \
                $(IMAGE_ROOTFS) \
                $@.tmp \
-               -p $(BLOCKSIZE) -m $(PAGESIZE) \
+               -p $(BLOCKSIZE:%k=%KiB) -m $(PAGESIZE) \
                $(if $(SUBPAGESIZE),-s $(SUBPAGESIZE)) \
                $(if $(VID_HDR_OFFSET),-O $(VID_HDR_OFFSET)) \
                $(UBINIZE_OPTS)