update to kernel 2.6.36.4
authorFlorian Fainelli <florian@openwrt.org>
Sat, 19 Feb 2011 12:44:07 +0000 (12:44 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 19 Feb 2011 12:44:07 +0000 (12:44 +0000)
SVN-Revision: 25580

15 files changed:
include/kernel-version.mk
target/linux/adm8668/Makefile
target/linux/avr32/Makefile
target/linux/brcm47xx/Makefile
target/linux/cns21xx/Makefile
target/linux/ep93xx/Makefile
target/linux/generic/patches-2.6.36/040-arm-update-mach-types.patch
target/linux/generic/patches-2.6.36/240-packet_socket_type.patch
target/linux/generic/patches-2.6.36/801-usb_serial_endpoint_size.patch
target/linux/generic/patches-2.6.36/980-vm_exports.patch
target/linux/leon/Makefile
target/linux/mpc83xx/Makefile
target/linux/mpc85xx/Makefile
target/linux/ramips/Makefile
target/linux/sparc/Makefile

index 31ac5d0630a2ab22b4bba2dd69aebe9254d94cb5..7e0eee1350c5d440fa6d5f04946ff54d9e0dfb16 100644 (file)
@@ -17,8 +17,8 @@ endif
 ifeq ($(LINUX_VERSION),2.6.35.9)
   LINUX_KERNEL_MD5SUM:=18d339e9229560e73c4249dffdc3fd90
 endif
-ifeq ($(LINUX_VERSION),2.6.36.2)
-  LINUX_KERNEL_MD5SUM:=d465f8ba05bf1b7530c596f1cca658e7
+ifeq ($(LINUX_VERSION),2.6.36.4)
+  LINUX_KERNEL_MD5SUM:=c05dd941d0e249695e9f72568888e1bf
 endif
 ifeq ($(LINUX_VERSION),2.6.37.1)
   LINUX_KERNEL_MD5SUM:=07d3b1868a67c1a7ddcf1d54444cb5d1
index 5980d9ef38f5a6fd2546ca9777ebf315641bd738..a60bb509b7949fa523a21198432bd2af13548292 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=adm8668
 BOARDNAME:=Infineon WildPass ADM8668
 FEATURES:=squashfs
 
-LINUX_VERSION:=2.6.36.2
+LINUX_VERSION:=2.6.36.4
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-rt61-pci
index 058b1a159e8b1c4babd105370bf7f355566eb023..139053aba278d70d72941810107a33f216b4e285 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Atmel AVR32
 FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.36.2
+LINUX_VERSION:=2.6.36.4
 
 include $(INCLUDE_DIR)/target.mk
 
index 14e25ffbc9208c31bdba15534d07d92509216678..2ff0bcab57028242355bbfa32508487a440d62e4 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=brcm47xx
 BOARDNAME:=Broadcom BCM947xx/953xx
 FEATURES:=squashfs usb pcmcia
 
-LINUX_VERSION:=2.6.36.2
+LINUX_VERSION:=2.6.36.4
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-switch kmod-diag nvram
index db098e7861ed711a7dee77bfa29e78c5fc8225a0..e0205f74abd7ba323a646f77e94443a8953445c8 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks CNS21xx
 FEATURES:=squashfs broken
 CFLAGS:=-Os -pipe -march=armv4 -mtune=arm9tdmi -funit-at-a-time
 
-LINUX_VERSION:=2.6.36.2
+LINUX_VERSION:=2.6.36.4
 
 include $(INCLUDE_DIR)/target.mk
 
index 90e71d27127c3cfb33117f1bf44cbf1c471a852b..d7662441a92044532425ae2ea82c19c2bc4113ce 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Cirrus Logic EP93xx
 FEATURES:=squashfs jffs2 ext4 targz usb
 CFLAGS:=-Os -pipe -march=armv4t -funit-at-a-time
 
-LINUX_VERSION:=2.6.36.2
+LINUX_VERSION:=2.6.36.4
 
 include $(INCLUDE_DIR)/target.mk
 
index 9c90fc7d8872b3e32930f792942a86bfd0034e68..faea9a4fbfc075aa132e5a57b7bd49624cdc55e7 100644 (file)
@@ -81,7 +81,7 @@
  htc_excalibur_s620    MACH_HTC_EXCALIBUR_S620 HTC_EXCALIBUR_S620      2391
  htc_opal              MACH_HTC_OPAL           HTC_OPAL                2392
  touchbook             MACH_TOUCHBOOK          TOUCHBOOK               2393
-@@ -2446,7 +2446,7 @@ siogentoo1               MACH_SIOGENTOO1         SIOGENTOO1      
+@@ -2446,7 +2446,7 @@ siogentoo1               MACH_SIOGENTOO1         SIOGENTOO1
  siogentoo2            MACH_SIOGENTOO2         SIOGENTOO2              2459
  sm3k                  MACH_SM3K               SM3K                    2460
  acer_tempo_f900               MACH_ACER_TEMPO_F900    ACER_TEMPO_F900         2461
index 204512ff11e800f2e1c6e6421bf24492a8252865..f5cb465e939ca4d5b9a0c170394dfed898cd2ed9 100644 (file)
@@ -99,7 +99,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
  
        if (sock->type == SOCK_PACKET)
                po->prot_hook.func = packet_rcv_spkt;
-@@ -2054,6 +2058,16 @@ packet_setsockopt(struct socket *sock, i
+@@ -2057,6 +2061,16 @@ packet_setsockopt(struct socket *sock, i
                po->tp_tstamp = val;
                return 0;
        }
@@ -116,7 +116,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
        default:
                return -ENOPROTOOPT;
        }
-@@ -2111,6 +2125,13 @@ static int packet_getsockopt(struct sock
+@@ -2114,6 +2128,13 @@ static int packet_getsockopt(struct sock
  
                data = &val;
                break;
index dba6aaf43460314d3bd389a35da1de0cce290b1f..361bf3dd07f0507c78e848f45b915e8046614bc2 100644 (file)
@@ -17,7 +17,7 @@
                port->bulk_in_size = buffer_size;
                port->bulk_in_endpointAddress = endpoint->bEndpointAddress;
                port->bulk_in_buffer = kmalloc(buffer_size, GFP_KERNEL);
-@@ -1376,3 +1377,5 @@ MODULE_LICENSE("GPL");
+@@ -1380,3 +1381,5 @@ MODULE_LICENSE("GPL");
  
  module_param(debug, bool, S_IRUGO | S_IWUSR);
  MODULE_PARM_DESC(debug, "Debug enabled or not");
index d748b9b3f062f3d35d40a03a511f39b8902a866c..0ac0999f291df8453c496e953953cf9233f38dfd 100644 (file)
@@ -48,7 +48,7 @@
  {
 --- a/kernel/exit.c
 +++ b/kernel/exit.c
-@@ -506,6 +506,7 @@ struct files_struct *get_files_struct(st
+@@ -514,6 +514,7 @@ struct files_struct *get_files_struct(st
  
        return files;
  }
@@ -56,7 +56,7 @@
  
  void put_files_struct(struct files_struct *files)
  {
-@@ -527,6 +528,7 @@ void put_files_struct(struct files_struc
+@@ -535,6 +536,7 @@ void put_files_struct(struct files_struc
                rcu_read_unlock();
        }
  }
@@ -76,7 +76,7 @@
   * macro override instead of weak attribute alias, to workaround
 --- a/kernel/sched.c
 +++ b/kernel/sched.c
-@@ -4439,6 +4439,7 @@ int can_nice(const struct task_struct *p
+@@ -4567,6 +4567,7 @@ int can_nice(const struct task_struct *p
        return (nice_rlim <= task_rlimit(p, RLIMIT_NICE) ||
                capable(CAP_SYS_NICE));
  }
index eb3b83fcfe9c8b296f1e7c12f2a833020e47a20c..34e206c286b47cde236f36307056f702af232e76 100644 (file)
@@ -14,7 +14,7 @@ FEATURES+=fpu tgz
 CFLAGS:=-Os -pipe -mcpu=v8 -funit-at-a-time
 KERNELNAME:="uImage"
 
-LINUX_VERSION:=2.6.36.2
+LINUX_VERSION:=2.6.36.4
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
 include $(INCLUDE_DIR)/target.mk
index 976a7be690c017f1bea26f6fdb909634711134ca..d0ba52cce343da115535118534daa98dbc2dd140 100644 (file)
@@ -13,7 +13,7 @@ CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=603e
 FEATURES:=squashfs targz broken
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.36.2
+LINUX_VERSION:=2.6.36.4
 
 include $(INCLUDE_DIR)/target.mk
 
index 5488adc59156f5b533ec5f3caa6f558700e41228..ef67446f937dd70ced53d61cf8fe5a67773eea88 100644 (file)
@@ -13,7 +13,7 @@ CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=8540
 FEATURES:=spe_fpu ramdisk broken
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.36.2
+LINUX_VERSION:=2.6.36.4
 
 include $(INCLUDE_DIR)/target.mk
 
index 4bd25160496caea810d975bb272bf3427ac1a587..f629170ecd4e9abda4ec9c9ad361c767b8a5f696 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
 FEATURES:=squashfs
 
-LINUX_VERSION:=2.6.36.2
+LINUX_VERSION:=2.6.36.4
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES+=kmod-leds-gpio wpad-mini
index a444c339891c315442abc08e32c04a5ec73b253b..fe859ff2c8ce1cc5c7b557f554db2c9737b29077 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=sparc
 BOARDNAME:=Sun UltraSPARC
 FEATURES+=fpu tgz
 
-LINUX_VERSION:=2.6.36.2
+LINUX_VERSION:=2.6.36.4
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
 include $(INCLUDE_DIR)/target.mk