kernel: fix Promise PDC202xx IDE driver location
authorNicolas Thill <nico@openwrt.org>
Mon, 5 Oct 2009 17:08:44 +0000 (17:08 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 5 Oct 2009 17:08:44 +0000 (17:08 +0000)
SVN-Revision: 17909

package/kernel/modules/block.mk

index 908b9d6159b5ca9693c74a42e4fac096a77236c6..dfeb4012e1de7a8c6c69e6f18b74845d8d39c65f 100644 (file)
@@ -256,7 +256,11 @@ define KernelPackage/ide-pdc202xx
   TITLE:=Promise PDC202xx IDE driver
   DEPENDS:=+kmod-ide-core
   KCONFIG:=CONFIG_BLK_DEV_PDC202XX_OLD
+ ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.28)),1)
   FILES:=$(LINUX_DIR)/drivers/ide/pdc202xx_old.$(LINUX_KMOD_SUFFIX)
+ else
+  FILES:=$(LINUX_DIR)/drivers/ide/pci/pdc202xx_old.$(LINUX_KMOD_SUFFIX)
+ endif
   AUTOLOAD:=$(call AutoLoad,30,pdc202xx_old)
 endef