sdk: bundle required firmware files
authorJo-Philipp Wich <jo@mein.io>
Thu, 21 Apr 2016 14:34:39 +0000 (16:34 +0200)
committerJo-Philipp Wich <jo@mein.io>
Thu, 21 Apr 2016 14:34:39 +0000 (16:34 +0200)
Bundle all firmware files which have been built along with the kernel to fix
packaging of kmods in the SDK environment that rely on in-tree firmwares,
specifically kmod-e100.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
target/sdk/Makefile

index 7f277f9affd8d4f6c55967c7d19219ddfe46ec30..f32b02b536543e2f36e694fcfce67ebf36b2dc08 100644 (file)
@@ -70,6 +70,8 @@ $(BIN_DIR)/$(SDK_NAME).tar.bz2: clean
        $(CP) $(INCLUDE_DIR) $(SCRIPT_DIR) $(TOPDIR)/docs $(SDK_BUILD_DIR)/
        $(TAR) -cf - -C $(TOPDIR) \
                `cd $(TOPDIR); find $(KDIR_BASE) -name \*.ko` \
+               `cd $(TOPDIR); find $(KDIR_BASE)/firmware/ -newer $(KDIR_BASE)/firmware/Makefile \
+                       -type f -name '*.bin' -or -name '*.cis' -or -name '*.csp' -or -name '*.dsp' -or -name '*.fw'` \
                $(foreach exclude,$(EXCLUDE_DIRS),--exclude="$(exclude)") \
                $(SDK_DIRS) $(KERNEL_FILES) | \
                $(TAR) -xf - -C $(SDK_BUILD_DIR)