apm821xx: fix IB image building
authorJo-Philipp Wich <jo@mein.io>
Sat, 30 Jul 2016 13:43:35 +0000 (15:43 +0200)
committerJo-Philipp Wich <jo@mein.io>
Mon, 1 Aug 2016 15:59:16 +0000 (17:59 +0200)
Change the image build code to generate the DTB files as part of the kernel
build phase in order to fix the image build in the ImageBuilder environment.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
target/linux/apm821xx/image/Makefile

index 25ee67b673aa9aad4afb5dbce62586f53557033a..100db560d4d831a6c02ae672e9385e11f52ce1c7 100644 (file)
@@ -85,7 +85,7 @@ define Build/create-uImage-dtb
        -$(STAGING_DIR_HOST)/bin/mkimage -A $(LINUX_KARCH) \
                -O linux -T kernel -C none \
                -n '$(call toupper,$(LINUX_KARCH)) LEDE Linux-$(LINUX_VERSION)' \
-               -d $@.dtb $@.new
+               -d $(IMAGE_KERNEL).dtb $@.new
        @mv $@.new $@
 endef
 
@@ -152,9 +152,9 @@ define Device/WNDR4700
   IMAGE_SIZE:=25559040
   IMAGES := factory.img sysupgrade.tar
   KERNEL_SIZE := 1920k
-  KERNEL := kernel-bin | lzma | uImage lzma | pad-offset $$(BLOCKSIZE) 64 | append-fakerootfs
+  KERNEL := dtb | kernel-bin | lzma | uImage lzma | pad-offset $$(BLOCKSIZE) 64 | append-fakerootfs
   KERNEL_INITRAMFS := kernel-bin | gzip | dtb | wndr4700-specialImage gzip
-  IMAGE/factory.img := dtb | create-uImage-dtb | append-kernel | pad-to 2M | append-ubi | \
+  IMAGE/factory.img := create-uImage-dtb | append-kernel | pad-to 2M | append-ubi | \
                       netgear-dni | check-size $$$$(IMAGE_SIZE)
   IMAGE/sysupgrade.tar := sysupgrade-tar
   NETGEAR_BOARD_ID := WNDR4700
@@ -178,7 +178,7 @@ define Build/boot-img
        mkdir -p $@.bootdir/boot
 
        $(CP) $@.scr $@.bootdir/boot/boot.scr
-       $(CP) $@.dtb $@.bootdir/boot/$(DEVICE_DTB)
+       $(CP) $(IMAGE_KERNEL).dtb $@.bootdir/boot/$(DEVICE_DTB)
        $(CP) $(IMAGE_KERNEL) $@.bootdir/boot/uImage
 
        genext2fs --block-size $(BLOCKSIZE) --size-in-blocks $$((1024 * $(BOOT_SIZE))) --root $@.bootdir $@.boot
@@ -211,6 +211,10 @@ define Build/recovery-tar
                $@
 endef
 
+define Build/export-dtb
+       cp $(IMAGE_KERNEL).dtb $@
+endef
+
 define Device/MyBookLiveDefault
   IMAGE_SIZE := 48m
   BLOCKSIZE := 1024
@@ -220,8 +224,8 @@ define Device/MyBookLiveDefault
   IMAGES := rootfs.img recovery.tar kernel.dtb
   DEVICE_DTB := apollo3g.dtb
   FILESYSTEMS := ext4
-  IMAGE/kernel.dtb := append-dtb
-  IMAGE/rootfs.img := boot-script | dtb | boot-img | hdd-img
+  IMAGE/kernel.dtb := export-dtb
+  IMAGE/rootfs.img := boot-script | boot-img | hdd-img
   IMAGE/recovery.tar := append-rootfs | gzip | uRamdisk | recovery-tar
 endef