cleanup toolchain version handling
authorImre Kaloz <kaloz@openwrt.org>
Thu, 27 Jan 2011 13:55:00 +0000 (13:55 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Thu, 27 Jan 2011 13:55:00 +0000 (13:55 +0000)
SVN-Revision: 25148

toolchain/eglibc/Config.in
toolchain/gcc/Config.in
toolchain/gcc/Config.version
toolchain/gcc/common.mk
tools/Makefile

index 2ae8da3e85c46edfe41b0ae5789a5163aa08743c..62ed24da9199b032f20994ae495971613f80e7a5 100644 (file)
@@ -22,11 +22,11 @@ choice
 
        config EGLIBC_VERSION_2_11
                bool "eglibc 2.11"
-               depends GCC_VERSION_4_3 || GCC_VERSION_4_4 || GCC_VERSION_4_5
+               depends !GCC_VERSION_LLVM
 
        config EGLIBC_VERSION_2_12
                bool "eglibc 2.12"
-               depends GCC_VERSION_4_3 || GCC_VERSION_4_4 || GCC_VERSION_4_5
+               depends !GCC_VERSION_LLVM
 
        config EGLIBC_VERSION_TRUNK
                bool "eglibc trunk"
index cd4f3e25e91f3ab6a22e8fcbbdd01996c9c3e245..019cd164b766f68ebdd0c842d6c2de0eb1493601 100644 (file)
@@ -78,7 +78,7 @@ config INSTALL_LIBSTDCPP
 
 config INSTALL_LIBGCJ
        bool
-       depends on !GCC_VERSION_4_2
+       depends on !GCC_VERSION_LLVM
        prompt "Build/install java compiler and GNU classpath ?" if TOOLCHAINOPTS
        default n
        help
index a39c0e88a9a4c5a8e21449de47fa78d8f37dc1de..fe1a7570ab4f44a5e20bee7f34536b9d458cb778 100644 (file)
@@ -9,17 +9,6 @@ config GCC_VERSION
        default "llvm"      if GCC_VERSION_LLVM
        default "4.5.1+l"
 
-config GCC_VERSION_4
-       bool
-       default y       if GCC_VERSION_4_2
-       default y       if GCC_VERSION_4_3
-       default y       if GCC_VERSION_4_4
-       default y       if GCC_VERSION_4_5
-
-config GCC_VERSION_4_2
-       bool
-       default y       if GCC_VERSION_LLVM
-
 config GCC_VERSION_4_3
        bool
        default y       if GCC_VERSION_4_3_3_CS
index 4d0cafa409f42e2fa66cc48d151a8b7fde00622d..977a104d006f4edab62d982a22619caa53e0d406 100644 (file)
@@ -48,12 +48,6 @@ else
   PKG_SOURCE_URL:=@GNU/gcc/gcc-$(PKG_VERSION)
   PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 
-  ifeq ($(PKG_VERSION),4.1.2)
-    PKG_MD5SUM:=a4a3eb15c96030906d8494959eeda23c
-  endif
-  ifeq ($(PKG_VERSION),4.2.4)
-    PKG_MD5SUM:=d79f553e7916ea21c556329eacfeaa16
-  endif
   ifeq ($(PKG_VERSION),4.3.3)
     PKG_MD5SUM:=cc3c5565fdb9ab87a05ddb106ba0bd1f
   endif
@@ -126,7 +120,7 @@ ifneq ($(CONFIG_GCC_VERSION_4_4)$(CONFIG_GCC_VERSION_4_5),)
   endif
 endif
 
-ifneq ($(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4)$(CONFIG_GCC_VERSION_4_5),)
+ifeq ($(CONFIG_GCC_LLVM),)
   GCC_BUILD_TARGET_LIBGCC:=y
   GCC_CONFIGURE+= \
                --with-gmp=$(TOPDIR)/staging_dir/host \
index 701393992e767ab600301a115c3ebab9d585295a..d8e7bfd8ee85e5fac428456fc56d9b1000540bea 100644 (file)
@@ -10,8 +10,8 @@ curdir:=tools
 
 # subdirectories to descend into
 tools-y :=
-ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
-tools-$(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4)$(CONFIG_GCC_VERSION_4_5) += gmp mpfr
+ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN)$(CONFIG_GCC_LLVM),)
+tools-y += gmp mpfr
 tools-$(CONFIG_GCC_VERSION_4_5) += mpc libelf
 endif
 tools-y += m4 libtool autoconf automake flex bison pkg-config sed mklibs
@@ -107,5 +107,5 @@ $(curdir)//compile = $(STAGING_DIR)/.prepared $(STAGING_DIR_HOST)/.prepared $($(
 $(curdir)/ := .config prereq
 $(curdir)//install = $(1)/compile
 
-$(eval $(call stampfile,$(curdir),tools,install,,CONFIG_CCACHE CONFIG_powerpc CONFIG_GCC_VERSION_4_3 CONFIG_GCC_USE_GRAPHITE CONFIG_TARGET_orion_generic))
+$(eval $(call stampfile,$(curdir),tools,install,,CONFIG_CCACHE CONFIG_powerpc CONFIG_GCC_VERSION_4_5 CONFIG_GCC_USE_GRAPHITE CONFIG_TARGET_orion_generic))
 $(eval $(call subdir,$(curdir)))