swconfig: support providing the switch device name in an option instead of the sectio...
authorFelix Fietkau <nbd@openwrt.org>
Mon, 18 Jan 2010 00:38:04 +0000 (00:38 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 18 Jan 2010 00:38:04 +0000 (00:38 +0000)
SVN-Revision: 19208

package/swconfig/Makefile
package/swconfig/files/switch.sh
package/swconfig/src/uci.c

index a7bed73174d768f50bf25cfb158fcedb96d9a5cd..72af8c735f2b80d4f304312fec1fb181009ccad5 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=swconfig
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/kernel.mk
index 7078b2e823e3bf2e575b0ca85b7974a593606a31..18d5fbd2c3d58f356e6f9ceec86ebc2caf38b757 100644 (file)
@@ -2,8 +2,10 @@
 # Copyright (C) 2009 OpenWrt.org
 
 setup_switch_dev() {
-       ifconfig "$1" 0.0.0.0
-       swconfig dev "$1" load network
+       config_get name "$1" name
+       name="${name:-$1}"
+       [ -d "/sys/class/net/$name" ] && ifconfig "$name" up
+       swconfig dev "$name" load network
 }
 
 setup_switch() {
index 2df837d2787865b01ae5ff2d58f439a99d67e852..e597acebfb7bd59b90bf51cbd1bb980888d20417 100644 (file)
@@ -107,6 +107,7 @@ int swlib_apply_from_uci(struct switch_dev *dev, struct uci_package *p)
        struct uci_element *e;
        struct uci_section *s;
        struct uci_option *o;
+       struct uci_ptr ptr;
        struct switch_val val;
        int i;
 
@@ -114,11 +115,28 @@ int swlib_apply_from_uci(struct switch_dev *dev, struct uci_package *p)
        head = &settings;
 
        uci_foreach_element(&p->sections, e) {
+               struct uci_element *n;
+
                s = uci_to_section(e);
 
                if (strcmp(s->type, "switch") != 0)
                        continue;
 
+               uci_foreach_element(&s->options, n) {
+                       struct uci_option *o = uci_to_option(n);
+
+                       if (strcmp(n->name, "name") != 0)
+                               continue;
+
+                       if (o->type != UCI_TYPE_STRING)
+                               continue;
+
+                       if (!strcmp(o->v.string, dev->dev_name))
+                               goto found;
+
+                       break;
+               }
+
                if (strcmp(e->name, dev->dev_name) != 0)
                        continue;