mac80211: add CONFIG_ATH5K_PCI only when not on aterhos target
authorHauke Mehrtens <hauke@hauke-m.de>
Wed, 22 Dec 2010 17:39:05 +0000 (17:39 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Wed, 22 Dec 2010 17:39:05 +0000 (17:39 +0000)
SVN-Revision: 24801

package/mac80211/Makefile
package/mac80211/patches/019-remove_ath5k_pci_option.patch [new file with mode: 0644]

index 56c8336cc09e831920647a3cd9103525c1250139..69fe1c16e0a7fa45b8e7e3e37518bff692eeb845 100644 (file)
@@ -881,6 +881,7 @@ BUILDFLAGS:= \
        $(if $(CONFIG_PACKAGE_kmod-rt2x00-pci),-DCONFIG_RT2X00_LIB_PCI) \
        $(if $(CONFIG_PACKAGE_kmod-rt2x00-usb),-DCONFIG_RT2X00_LIB_USB) \
        $(if $(CONFIG_PACKAGE_kmod-rt2x00-soc),-DCONFIG_RT2X00_LIB_SOC) \
+       $(if $(CONFIG_TARGET_atheros),-DCONFIG_ATH5K_AHB,-DCONFIG_ATH5K_PCI) \
        -DCONFIG_P54_SPI_DEFAULT_EEPROM
 
 MAKE_OPTS:= \
diff --git a/package/mac80211/patches/019-remove_ath5k_pci_option.patch b/package/mac80211/patches/019-remove_ath5k_pci_option.patch
new file mode 100644 (file)
index 0000000..792ecb5
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/config.mk
++++ b/config.mk
+@@ -189,7 +189,7 @@ CONFIG_MAC80211_HWSIM=m
+ ifdef CONFIG_PCI
+ CONFIG_ATH5K=m
+-CONFIG_ATH5K_PCI=y
++# CONFIG_ATH5K_PCI=y
+ # CONFIG_ATH5K_DEBUG=y
+ # CONFIG_ATH5K_AHB=y
+ CONFIG_ATH9K_HW=m