fix liblua symlink installation
authorFelix Fietkau <nbd@openwrt.org>
Fri, 23 May 2008 07:09:29 +0000 (07:09 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 23 May 2008 07:09:29 +0000 (07:09 +0000)
SVN-Revision: 11245

package/lua/Makefile
package/lua/patches/020-shared_liblua.patch

index 206740b0a19c2aafd24bd6a8154402f3c9d86868..e5ac938c0ef08b6ce10445966f7fedadf8d46c64 100644 (file)
@@ -113,14 +113,13 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/usr/include/lauxlib.h $(1)/usr/include/
        $(CP) $(PKG_INSTALL_DIR)/usr/include/lnum_config.h $(1)/usr/include/
        mkdir -p $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/liblua.{a,so.*} $(1)/usr/lib/
-       ln -sf liblua.so.$(PKG_VERSION) $(1)/usr/lib/liblua.so
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/liblua.* $(1)/usr/lib/
        ln -sf liblua.so.$(PKG_VERSION) $(1)/usr/lib/liblualib.so
 endef
 
 define Package/liblua/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/liblua.so.* $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/liblua.so* $(1)/usr/lib/
 endef
 
 define Package/lua/install
index a2f7ebff05e285ab1054f42758acd9a8adfd3338..402b8a5fc90113e8e3d49e6d578787c62d2fc89f 100644 (file)
@@ -1,7 +1,7 @@
 Index: lua-5.1.3/Makefile
 ===================================================================
---- lua-5.1.3.orig/Makefile    2008-05-22 15:57:52.000000000 +0200
-+++ lua-5.1.3/Makefile 2008-05-22 16:02:53.000000000 +0200
+--- lua-5.1.3.orig/Makefile    2008-05-23 09:03:23.000000000 +0200
++++ lua-5.1.3/Makefile 2008-05-23 09:05:51.000000000 +0200
 @@ -37,8 +37,8 @@
  
  # What to install.
@@ -9,14 +9,22 @@ Index: lua-5.1.3/Makefile
 -TO_INC= lua.h luaconf.h lualib.h lauxlib.h ../etc/lua.hpp
 -TO_LIB= liblua.a
 +TO_INC= lua.h luaconf.h lualib.h lauxlib.h ../etc/lua.hpp lnum_config.h
-+TO_LIB= liblua.a liblua.so liblua.so.$R
++TO_LIB= liblua.a liblua.so.$R
  TO_MAN= lua.1 luac.1
  
  # Lua version and release.
+@@ -58,6 +58,7 @@
+       cd src && $(INSTALL_EXEC) $(TO_BIN) $(INSTALL_BIN)
+       cd src && $(INSTALL_DATA) $(TO_INC) $(INSTALL_INC)
+       cd src && $(INSTALL_DATA) $(TO_LIB) $(INSTALL_LIB)
++      ln -s liblua.so.$R $(INSTALL_LIB)/liblua.so
+       cd doc && $(INSTALL_DATA) $(TO_MAN) $(INSTALL_MAN)
+ local:
 Index: lua-5.1.3/src/ldo.h
 ===================================================================
---- lua-5.1.3.orig/src/ldo.h   2008-05-22 15:57:52.000000000 +0200
-+++ lua-5.1.3/src/ldo.h        2008-05-22 16:02:53.000000000 +0200
+--- lua-5.1.3.orig/src/ldo.h   2008-05-23 09:03:23.000000000 +0200
++++ lua-5.1.3/src/ldo.h        2008-05-23 09:03:32.000000000 +0200
 @@ -46,7 +46,7 @@
  LUAI_FUNC int luaD_poscall (lua_State *L, StkId firstResult);
  LUAI_FUNC void luaD_reallocCI (lua_State *L, int newsize);
@@ -28,8 +36,8 @@ Index: lua-5.1.3/src/ldo.h
  LUAI_FUNC int luaD_rawrunprotected (lua_State *L, Pfunc f, void *ud);
 Index: lua-5.1.3/src/lfunc.h
 ===================================================================
---- lua-5.1.3.orig/src/lfunc.h 2008-05-22 15:57:52.000000000 +0200
-+++ lua-5.1.3/src/lfunc.h      2008-05-22 16:02:53.000000000 +0200
+--- lua-5.1.3.orig/src/lfunc.h 2008-05-23 09:03:23.000000000 +0200
++++ lua-5.1.3/src/lfunc.h      2008-05-23 09:03:32.000000000 +0200
 @@ -18,7 +18,7 @@
                           cast(int, sizeof(TValue *)*((n)-1)))
  
@@ -41,8 +49,8 @@ Index: lua-5.1.3/src/lfunc.h
  LUAI_FUNC UpVal *luaF_newupval (lua_State *L);
 Index: lua-5.1.3/src/lmem.h
 ===================================================================
---- lua-5.1.3.orig/src/lmem.h  2008-05-22 15:57:52.000000000 +0200
-+++ lua-5.1.3/src/lmem.h       2008-05-22 16:02:53.000000000 +0200
+--- lua-5.1.3.orig/src/lmem.h  2008-05-23 09:03:23.000000000 +0200
++++ lua-5.1.3/src/lmem.h       2008-05-23 09:03:32.000000000 +0200
 @@ -38,9 +38,9 @@
     ((v)=cast(t *, luaM_reallocv(L, v, oldn, n, sizeof(t))))
  
@@ -57,8 +65,8 @@ Index: lua-5.1.3/src/lmem.h
                                 const char *errormsg);
 Index: lua-5.1.3/src/lstring.h
 ===================================================================
---- lua-5.1.3.orig/src/lstring.h       2008-05-22 15:57:52.000000000 +0200
-+++ lua-5.1.3/src/lstring.h    2008-05-22 16:02:53.000000000 +0200
+--- lua-5.1.3.orig/src/lstring.h       2008-05-23 09:03:23.000000000 +0200
++++ lua-5.1.3/src/lstring.h    2008-05-23 09:03:32.000000000 +0200
 @@ -25,7 +25,7 @@
  
  LUAI_FUNC void luaS_resize (lua_State *L, int newsize);
@@ -70,8 +78,8 @@ Index: lua-5.1.3/src/lstring.h
  #endif
 Index: lua-5.1.3/src/lundump.h
 ===================================================================
---- lua-5.1.3.orig/src/lundump.h       2008-05-22 15:57:52.000000000 +0200
-+++ lua-5.1.3/src/lundump.h    2008-05-22 16:02:53.000000000 +0200
+--- lua-5.1.3.orig/src/lundump.h       2008-05-23 09:03:23.000000000 +0200
++++ lua-5.1.3/src/lundump.h    2008-05-23 09:03:32.000000000 +0200
 @@ -17,7 +17,7 @@
  LUAI_FUNC void luaU_header (char* h);
  
@@ -83,8 +91,8 @@ Index: lua-5.1.3/src/lundump.h
  /* print one chunk; from print.c */
 Index: lua-5.1.3/src/Makefile
 ===================================================================
---- lua-5.1.3.orig/src/Makefile        2008-05-22 16:02:53.000000000 +0200
-+++ lua-5.1.3/src/Makefile     2008-05-22 16:18:03.000000000 +0200
+--- lua-5.1.3.orig/src/Makefile        2008-05-23 09:03:32.000000000 +0200
++++ lua-5.1.3/src/Makefile     2008-05-23 09:03:36.000000000 +0200
 @@ -23,6 +23,7 @@
  PLATS= aix ansi bsd freebsd generic linux macosx mingw posix solaris