strip .gnu.attributes and .reginfo from kernel modules
authorFelix Fietkau <nbd@openwrt.org>
Sat, 26 Mar 2011 15:22:14 +0000 (15:22 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 26 Mar 2011 15:22:14 +0000 (15:22 +0000)
SVN-Revision: 26304

rules.mk

index ca76ef45b62d0eceff7f255474fcbbda0502b940..cddfdf5d308d9040c5d364fc6140ca5709759565 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -211,7 +211,7 @@ else
   RSTRIP:= \
     NM="$(TARGET_CROSS)nm" \
     STRIP="$(STRIP)" \
-    STRIP_KMOD="$(TARGET_CROSS)strip --strip-unneeded --remove-section=.comment --remove-section=.pdr --remove-section=.mdebug.abi32 --remove-section=.note.gnu.build-id" \
+    STRIP_KMOD="$(TARGET_CROSS)strip --strip-unneeded -R .comment -R .pdr -R .mdebug.abi32 -R .note.gnu.build-id -R .gnu.attributes -R .reginfo" \
     $(SCRIPT_DIR)/rstrip.sh
 endif