include/kernel.mk: add KernelPackage/conffiles macro
authorNicolas Thill <nico@openwrt.org>
Thu, 2 Apr 2015 14:53:34 +0000 (14:53 +0000)
committerNicolas Thill <nico@openwrt.org>
Thu, 2 Apr 2015 14:53:34 +0000 (14:53 +0000)
Signed-off-by: Nicolas Thill <nico@openwrt.org>
SVN-Revision: 45245

include/kernel.mk

index e3ad69787bb36e3327c2ba34e8c88bf0c838e451..700736fe9a77e66890945955d1689749603701bb 100644 (file)
@@ -157,6 +157,12 @@ define KernelPackage
     $(call KernelPackage/$(1)/$(BOARD))
   endef
 
+  ifdef KernelPackage/$(1)/conffiles
+    define Package/kmod-$(1)/conffiles
+$(call KernelPackage/$(1)/conffiles)
+    endef
+  endif
+
   ifdef KernelPackage/$(1)/description
     define Package/kmod-$(1)/description
 $(call KernelPackage/$(1)/description)