mtd-utils: fix compile on mac os x
authorFelix Fietkau <nbd@openwrt.org>
Sat, 16 Jan 2010 00:11:43 +0000 (00:11 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 16 Jan 2010 00:11:43 +0000 (00:11 +0000)
SVN-Revision: 19158

tools/mtd-utils/Makefile
tools/mtd-utils/include/fls.h [new file with mode: 0644]
tools/mtd-utils/include/linux/types.h [new file with mode: 0644]
tools/mtd-utils/patches/110-portability.patch

index 8938614e76b535187baa96ca798233f600ce76b7..45a61ab3c36c97d1739a4c99620ed08af20d7ab9 100644 (file)
@@ -23,7 +23,7 @@ include $(INCLUDE_DIR)/host-build.mk
 
 CFLAGS := $(HOST_CFLAGS) -I$(HOST_BUILD_DIR)/include -L$(HOST_BUILD_DIR) -L$(STAGING_DIR_HOST)/lib
 ifneq ($(HOST_OS),Linux)
-CFLAGS += -Dloff_t=off_t -D__BYTE_ORDER=BYTE_ORDER -include getline.h -include endian.h
+CFLAGS += -Dloff_t=off_t -D__BYTE_ORDER=BYTE_ORDER -include getline.h -include endian.h -I$(CURDIR)/include -include fls.h
 endif
 
 MTD_MAKEOPTS = \
diff --git a/tools/mtd-utils/include/fls.h b/tools/mtd-utils/include/fls.h
new file mode 100644 (file)
index 0000000..7514253
--- /dev/null
@@ -0,0 +1,2 @@
+#include <string.h>
+#define fls local_fls
diff --git a/tools/mtd-utils/include/linux/types.h b/tools/mtd-utils/include/linux/types.h
new file mode 100644 (file)
index 0000000..559fac7
--- /dev/null
@@ -0,0 +1,18 @@
+#ifndef _LINUX_TYPES_H
+#define _LINUX_TYPES_H
+
+#include <mtd/ubi-media.h>
+
+typedef uint16_t __u16;
+typedef uint32_t __u32;
+typedef uint64_t __u64;
+
+typedef __u16 __le16;
+typedef __u32 __le32;
+typedef __u64 __le64;
+typedef __u64 off64_t;
+
+typedef __u16  __sum16;
+typedef __u32  __wsum;
+
+#endif /* _LINUX_TYPES_H */
index 4ef27d1f7e82cc89d5e982c16909d0d52c936f21..3d0037c90a6dfd6d8397e38e61a9228ccc33d255 100644 (file)
  
  /* The version of UBI images supported by this implementation */
  #define UBI_VERSION 1
+--- a/mkfs.ubifs/mkfs.ubifs.h
++++ b/mkfs.ubifs/mkfs.ubifs.h
+@@ -34,7 +34,14 @@
+ #include <endian.h>
+ #include <byteswap.h>
+ #include <linux/types.h>
++#ifdef __linux__
+ #include <linux/fs.h>
++#else
++# ifndef O_LARGEFILE
++#  define O_LARGEFILE 0
++# endif
++# define llseek lseek
++#endif
+ #include <getopt.h>
+ #include <sys/types.h>
+--- a/mkfs.ubifs/mkfs.ubifs.c
++++ b/mkfs.ubifs/mkfs.ubifs.c
+@@ -773,8 +773,8 @@ int write_leb(int lnum, int len, void *b
+               if (ubi_leb_change_start(ubi, out_fd, lnum, c->leb_size, dtype))
+                       return sys_err_msg("ubi_leb_change_start failed");
+-      if (lseek64(out_fd, pos, SEEK_SET) != pos)
+-              return sys_err_msg("lseek64 failed seeking %lld",
++      if (llseek(out_fd, pos, SEEK_SET) != pos)
++              return sys_err_msg("llseek failed seeking %lld",
+                                  (long long)pos);
+       if (write(out_fd, buf, c->leb_size) != c->leb_size)
+@@ -1029,6 +1029,7 @@ static int add_inode_with_data(struct st
+       if (c->default_compr != UBIFS_COMPR_NONE)
+               use_flags |= UBIFS_COMPR_FL;
++#ifdef __linux__
+       if (flags & FS_COMPR_FL)
+               use_flags |= UBIFS_COMPR_FL;
+       if (flags & FS_SYNC_FL)
+@@ -1039,6 +1040,7 @@ static int add_inode_with_data(struct st
+               use_flags |= UBIFS_APPEND_FL;
+       if (flags & FS_DIRSYNC_FL && S_ISDIR(st->st_mode))
+               use_flags |= UBIFS_DIRSYNC_FL;
++#endif
+       memset(ino, 0, UBIFS_INO_NODE_SZ);
+@@ -1108,7 +1110,9 @@ static int add_dir_inode(DIR *dir, ino_t
+               fd = dirfd(dir);
+               if (fd == -1)
+                       return sys_err_msg("dirfd failed");
++#ifdef __linux__
+               if (ioctl(fd, FS_IOC_GETFLAGS, &flags) == -1)
++#endif
+                       flags = 0;
+       }
+@@ -1293,10 +1297,12 @@ static int add_file(const char *path_nam
+               key_write(&key, &dn->key);
+               dn->size = cpu_to_le32(bytes_read);
+               out_len = NODE_BUFFER_SIZE - UBIFS_DATA_NODE_SZ;
++#ifdef __linux__
+               if (c->default_compr == UBIFS_COMPR_NONE &&
+                   (flags & FS_COMPR_FL))
+                       use_compr = UBIFS_COMPR_LZO;
+               else
++#endif
+                       use_compr = c->default_compr;
+               compr_type = compress_data(buf, bytes_read, &dn->data,
+                                          &out_len, use_compr);
+@@ -1338,7 +1344,9 @@ static int add_non_dir(const char *path_
+               if (fd == -1)
+                       return sys_err_msg("failed to open file '%s'",
+                                          path_name);
++#ifdef __linux__
+               if (ioctl(fd, FS_IOC_GETFLAGS, &flags) == -1)
++#endif
+                       flags = 0;
+               if (close(fd) == -1)
+                       return sys_err_msg("failed to close file '%s'",
+--- a/mkfs.ubifs/devtable.c
++++ b/mkfs.ubifs/devtable.c
+@@ -134,6 +134,7 @@ static int interpret_table_entry(const c
+       unsigned int mode = 0755, uid = 0, gid = 0, major = 0, minor = 0;
+       unsigned int start = 0, increment = 0, count = 0;
++      buf[1023] = 0;
+       if (sscanf(line, "%1023s %c %o %u %u %u %u %u %u %u",
+                  buf, &type, &mode, &uid, &gid, &major, &minor,
+                  &start, &increment, &count) < 0)
+@@ -144,8 +145,8 @@ static int interpret_table_entry(const c
+               buf, type, mode, uid, gid, major, minor, start,
+               increment, count);
+-      len = strnlen(buf, 1024);
+-      if (len == 1024)
++      len = strlen(buf);
++      if (len == 1023)
+               return err_msg("too long path");
+       if (!strcmp(buf, "/"))