fix menuconfig checks
authorMike Baker <mbm@openwrt.org>
Sat, 7 Apr 2007 10:31:46 +0000 (10:31 +0000)
committerMike Baker <mbm@openwrt.org>
Sat, 7 Apr 2007 10:31:46 +0000 (10:31 +0000)
SVN-Revision: 6879

Makefile

index 43ed005b8ade32dafec91c54d1693c839a7fbfe3..fffc3bf5dab101e2cee4ed0d8d98d5daeda5164d 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -90,8 +90,9 @@ oldconfig: scripts/config/conf tmp/.config-target.in tmp/.config-package.in FORC
        $< -o Config.in
 
 menuconfig: scripts/config/mconf tmp/.config-target.in tmp/.config-package.in FORCE
-       @[ -f .config ] || \
-               [ -e $(HOME)/.openwrt/defconfig ] && cp $(HOME)/.openwrt/defconfig .config
+       @[ -f .config ] || { \
+               [ -e $(HOME)/.openwrt/defconfig ] && cp $(HOME)/.openwrt/defconfig .config; \
+       }
        $< Config.in
 
 kernel_menuconfig: .config FORCE