ar71xx: create profile and build image for the OpenMesh A60 board
authorSven Eckelmann <sven.eckelmann@open-mesh.com>
Tue, 9 Aug 2016 14:10:16 +0000 (16:10 +0200)
committerJohn Crispin <john@phrozen.org>
Tue, 14 Feb 2017 11:18:05 +0000 (12:18 +0100)
Signed-off-by: Sven Eckelmann <sven.eckelmann@open-mesh.com>
target/linux/ar71xx/image/legacy-devices.mk
target/linux/ar71xx/image/legacy.mk

index 528b2b41c658dfed6ad9a57462f0b40f1288533b..a1b4e894252267f7b4366fd404f312819cf627ef 100644 (file)
@@ -1,3 +1,10 @@
+define LegacyDevice/A60
+   DEVICE_TITLE := OpenMesh A60
+   DEVICE_PACKAGES := om-watchdog kmod-ath10k ath10k-firmware-qca988x \
+       mod-usb-core kmod-usb2
+endef
+LEGACY_DEVICES += A60
+
 define LegacyDevice/ALFANX
   DEVICE_TITLE := ALFA Network N2/N5 board
 endef
index d2f05e993eab55e461ef6cb7a8f465ccd08a4cb0..3dd3426c9574e23050b2b5f22caf75305d7c1fa6 100644 (file)
@@ -984,6 +984,7 @@ $(eval $(call SingleProfile,Netgear,64kraw,REALWNR1000V2,wnr1000v2,WNR1000V2,tty
 $(eval $(call SingleProfile,Netgear,64kraw,WNR1000V2_VC,wnr1000v2-vc,WNR1000V2,ttyS0,115200,$$(wnr2000v3_mtdlayout),0x31303030,WNR1000V2-VC,"",))
 $(eval $(call SingleProfile,Netgear,64kraw,WPN824N,wpn824n,WPN824N,ttyS0,115200,$$(wnr2000v3_mtdlayout),0x31313030,WPN824N,"" NA,))
 
+$(eval $(call SingleProfile,OpenMesh,squashfs-only,A60,a60,,,,A60))
 $(eval $(call SingleProfile,OpenMesh,squashfs-only,OM2P,om2p,,,,OM2P))
 $(eval $(call SingleProfile,OpenMesh,squashfs-only,OM5P,om5p,,,,OM5P))
 $(eval $(call SingleProfile,OpenMesh,squashfs-only,OM5PAC,om5pac,,,,OM5PAC))