imx6: make the default config bootable on ventana
authorJohn Crispin <john@openwrt.org>
Mon, 24 Nov 2014 19:12:19 +0000 (19:12 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 24 Nov 2014 19:12:19 +0000 (19:12 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 43369

target/linux/imx6/image/Makefile

index 391db7847484d18f09181cec5871b191cfdbb21a..3381473c7fa9b6fb0273754ae8e4781c4680d3a4 100644 (file)
@@ -44,9 +44,9 @@ endef
 
 define Image/InstallKernel/Template
 
- ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_KERNEL),)
+ ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_KERNEL)$(CONFIG_TARGET_imx6_VENTANA),)
        $(INSTALL_DIR) $(TARGET_DIR)/boot
-   ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_UIMAGE),)
+   ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_UIMAGE)$(CONFIG_TARGET_imx6_VENTANA),)
        $(CP) $(BIN_DIR)/$(IMG_PREFIX)-uImage $(TARGET_DIR)/boot/
        ln -sf $(IMG_PREFIX)-uImage $(TARGET_DIR)/boot/uImage
    endif
@@ -61,7 +61,7 @@ define Image/InstallKernel/Template
    endif
  endif
 
- ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_DTB),)
+ ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_DTB)$(CONFIG_TARGET_imx6_VENTANA),)
        $(INSTALL_DIR) $(TARGET_DIR)/boot
        $(foreach dts,$(shell echo $(1)), \
                $(CP) $(BIN_DIR)/$(IMG_PREFIX)-$(dts).dtb $(TARGET_DIR)/boot/ ; \