busybox: remove BUSYBOX_USE_LIBRPC
authorFelix Fietkau <nbd@openwrt.org>
Sun, 10 Jun 2012 22:24:24 +0000 (22:24 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 10 Jun 2012 22:24:24 +0000 (22:24 +0000)
SVN-Revision: 32175

package/busybox/Config.in
package/busybox/Makefile

index a954a25c8ae34734690a874743a9ba52de216042..88d1aa213ab5c1cc68be3e7c90fafd90e84b10f2 100644 (file)
@@ -19,10 +19,6 @@ config BUSYBOX_CONFIG_HUSH
        default y if NOMMU
        default n if !NOMMU
 
-config BUSYBOX_USE_LIBRPC
-       bool
-       default y if BUSYBOX_CONFIG_FEATURE_HAVE_RPC
-
 source "package/busybox/config/Config.in"
 
 endif
index 1d2d7b4fac1605bc16063db8991909936ba1dd85..ef7f51877b68ec87cc68d46ac8f222345b70e4d1 100644 (file)
@@ -17,7 +17,7 @@ PKG_SOURCE_URL:=http://www.busybox.net/downloads \
                http://distfiles.gentoo.org/distfiles/
 PKG_MD5SUM:=9c0cae5a0379228e7b55e5b29528df8e
 
-PKG_BUILD_DEPENDS:=BUSYBOX_USE_LIBRPC:librpc
+PKG_BUILD_DEPENDS:=BUSYBOX_CONFIG_FEATURE_HAVE_RPC:librpc
 PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
@@ -37,7 +37,7 @@ define Package/busybox
   MAINTAINER:=Nicolas Thill <nico@openwrt.org>
   TITLE:=Core utilities for embedded Linux
   URL:=http://busybox.net/
-  DEPENDS:=+BUSYBOX_USE_LIBRPC:librpc
+  DEPENDS:=+BUSYBOX_CONFIG_FEATURE_HAVE_RPC:librpc
   MENU:=1
 endef
 
@@ -66,7 +66,7 @@ ifdef CONFIG_GCC_VERSION_LLVM
 endif
 
 LDLIBS:=m crypt
-ifdef CONFIG_BUSYBOX_USE_LIBRPC
+ifdef CONFIG_BUSYBOX_CONFIG_FEATURE_HAVE_RPC
   TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
   export LDFLAGS=$(TARGET_LDFLAGS)
   LDLIBS += rpc