jsonfilter: improve error reporting
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 19 Jun 2014 07:56:24 +0000 (07:56 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 19 Jun 2014 07:56:24 +0000 (07:56 +0000)
The CLI now describes expression errors more precisely, e.g.:

  Syntax error: Invalid escape sequence
  In expression @["foo\x"]
  Near here ----------^

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 41266

package/utils/jsonfilter/Makefile

index 1ddb22f3f1d413e460203ec66fef87c968481ca7..c8d6b21ff909b2171eb7137320edff0894241e09 100644 (file)
@@ -1,13 +1,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=jsonfilter
-PKG_VERSION:=2014-06-18
+PKG_VERSION:=2014-06-19
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=http://git.openwrt.org/project/jsonpath.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=c0e1d4495a8afe51cc1900269d6a6fcf0b51a761
+PKG_SOURCE_VERSION:=afa3a10096e6d3ad50dc9d8250f40d8f23a9ad42
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 CMAKE_INSTALL:=1