ar71xx: fix WNDR3700 image generation
authorNicolas Thill <nico@openwrt.org>
Sat, 19 Dec 2009 14:45:43 +0000 (14:45 +0000)
committerNicolas Thill <nico@openwrt.org>
Sat, 19 Dec 2009 14:45:43 +0000 (14:45 +0000)
SVN-Revision: 18849

target/linux/ar71xx/image/Makefile

index 051f0a3f29540ddc79601f056e7d06b34974d74a..92f698a35c9224ef08f7b284a9cee55ab384f7c6 100644 (file)
@@ -237,14 +237,13 @@ wndr3700_mtdlayout=mtdparts=spi0.0:320k(u-boot)ro,128k(u-boot-env)ro,1024k(kerne
 define Image/Build/WNDR3700
        $(call PatchKernelLzma,$(2),$(3) $(wndr3700_mtdlayout))
        $(call MkImageLzma,$(KDIR)/vmlinux-$(2).bin.lzma,$(KDIR)/vmlinux-$(2).uImage)
-       mkdir $(KDIR)/wndr3700
-       mkdir $(KDIR)/wndr3700/image
+       mkdir -p $(KDIR)/wndr3700/image
        $(STAGING_DIR_HOST)/bin/wndr3700 \
                $(KDIR)/vmlinux-$(2).uImage \
                $(KDIR)/wndr3700/image/uImage
-       $(STAGING_DIR_HOST)/bin/mksquashfs-lzma \
+       $(MKSQUASHFS_CMD) \
                $(KDIR)/wndr3700 $(KDIR)/vmlinux-$(2).uImage.squashfs.tmp \
-               -nopad -noappend -root-owned -be
+               -nopad -noappend -root-owned $(SQUASHFS_OPTS)
        -rm -rf $(KDIR)/wndr3700
        mkimage -A mips -O linux -T filesystem -C none \
                -a 0xbf070000 -e 0xbf070000 \