kernel: update kernel to 3.10.15
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 13 Oct 2013 19:28:29 +0000 (19:28 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 13 Oct 2013 19:28:29 +0000 (19:28 +0000)
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
SVN-Revision: 38384

24 files changed:
include/kernel-version.mk
target/linux/ar7/Makefile
target/linux/ar71xx/Makefile
target/linux/avr32/Makefile
target/linux/bcm53xx/Makefile
target/linux/brcm2708/Makefile
target/linux/brcm47xx/Makefile
target/linux/brcm63xx/Makefile
target/linux/cns21xx/Makefile
target/linux/generic/patches-3.10/770-bgmac-backport.patch
target/linux/imx23/Makefile
target/linux/imx6/Makefile
target/linux/ixp4xx/Makefile
target/linux/lantiq/Makefile
target/linux/malta/Makefile
target/linux/mpc85xx/Makefile
target/linux/mvebu/Makefile
target/linux/octeon/Makefile
target/linux/ppc40x/Makefile
target/linux/ppc44x/Makefile
target/linux/ramips/Makefile
target/linux/rb532/Makefile
target/linux/realview/Makefile
target/linux/xburst/Makefile

index d63ab650a0601fcb9d0e9a0dbb1ba2c13457fde2..d0d4d32ed95f088e64be2322121f952af54f105e 100644 (file)
@@ -17,8 +17,8 @@ endif
 ifeq ($(LINUX_VERSION),3.9.11)
   LINUX_KERNEL_MD5SUM:=edbf88eb7f7d34dbd5d3887726790755
 endif
-ifeq ($(LINUX_VERSION),3.10.13)
-  LINUX_KERNEL_MD5SUM:=64ffe74249442fd7452d12348955ccfd
+ifeq ($(LINUX_VERSION),3.10.15)
+  LINUX_KERNEL_MD5SUM:=3fe22263308674d92c6d106f633eca52
 endif
 
 # disable the md5sum check for unknown kernel versions
index fc383f8c796dacc42d8d5c338ddb6142084c5a56..8601dd0219569a0572b221e37594137eab418f3d 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs atm
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 SUBTARGETS:=generic ac49x
 
-LINUX_VERSION:=3.10.13
+LINUX_VERSION:=3.10.15
 
 include $(INCLUDE_DIR)/target.mk
 
index cabcf04641ca39533432fd2fb556fec94c7ce8f8..0c99c08ba1349cb56a8d5c78e33c5a68f296bf81 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs targz mips16
 CPU_TYPE=34kc
 SUBTARGETS:=generic nand
 
-LINUX_VERSION:=3.10.13
+LINUX_VERSION:=3.10.15
 
 include $(INCLUDE_DIR)/target.mk
 
index a7387e3fd0ab32185ca0454efe3313d42484095b..8992c4356c7d4caa3f5eb1efbcca4e5746715771 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Atmel AVR32
 FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.10.13
+LINUX_VERSION:=3.10.15
 
 include $(INCLUDE_DIR)/target.mk
 
index c39c0205e5c1113edd97f16fcabc0b2d323ca3d1..4ebacd06c1e21f98e783823d2f84522877a52c9b 100644 (file)
@@ -14,7 +14,7 @@ MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
 CPU_TYPE:=cortex-a9
 CPU_SUBTYPE:=vfp
 
-LINUX_VERSION:=3.10.13
+LINUX_VERSION:=3.10.15
 
 include $(INCLUDE_DIR)/target.mk
 
index 0bd3f2fb43f8bf503de9cb1b768dc0ec039791b9..d652184756957cf1b21e67e629b65f37ad2d8c3a 100644 (file)
@@ -15,7 +15,7 @@ MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 CPU_TYPE:=arm1176jzf-s
 CPU_SUBTYPE:=vfp
 
-LINUX_VERSION:=3.10.13
+LINUX_VERSION:=3.10.15
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += brcm2708-gpu-fw kmod-usb-hid kmod-sound-core kmod-sound-arm-bcm2835
index 3ad04fe9a59dc6bb1883688d688a0413fea8b284..f95562274e795ce6e91ef8ffc459aaea3ae22f74 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Broadcom BCM947xx/953xx
 FEATURES:=squashfs usb pcmcia
 MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
 
-LINUX_VERSION:=3.10.13
+LINUX_VERSION:=3.10.15
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += swconfig kmod-diag wpad-mini nvram
index f4aa477b317936c086bd52a14bd47cc5b2cc2dc7..1fb2edf29749f2fb54f9eff3c652fa45ece8c9fa 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
 SUBTARGETS:=generic smp
 FEATURES:=squashfs usb atm pci pcmcia
-LINUX_VERSION:=3.10.13
+LINUX_VERSION:=3.10.15
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 include $(INCLUDE_DIR)/target.mk
index 8568323c90b54a5669c136886fa4a0a75fc59984..f010d5a3d7984cb2d01a734b65e52af1443f9fda 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Econa CNS21xx
 FEATURES:=squashfs
 CPU_TYPE:=fa526
 
-LINUX_VERSION:=3.10.13
+LINUX_VERSION:=3.10.15
 
 include $(INCLUDE_DIR)/target.mk
 
index 3651be70cdd20c78453497ec5b5b3b54e8a88b0a..99415a6d754d6686de389b6163462acf6b21f2ec 100644 (file)
@@ -163,13 +163,11 @@ patches for bgmac backported from net-next/master
                            ring->num_slots * sizeof(struct bgmac_dma_desc));
  
                ring->start = 0;
-@@ -908,10 +934,10 @@ static void bgmac_chip_reset(struct bgma
-               struct bcma_drv_cc *cc = &bgmac->core->bus->drv_cc;
+@@ -909,9 +935,9 @@ static void bgmac_chip_reset(struct bgma
                u8 et_swtype = 0;
                u8 sw_type = BGMAC_CHIPCTL_1_SW_TYPE_EPHY |
--                           BGMAC_CHIPCTL_1_IF_TYPE_RMII;
+                            BGMAC_CHIPCTL_1_IF_TYPE_MII;
 -              char buf[2];
-+                           BGMAC_CHIPCTL_1_IF_TYPE_MII;
 +              char buf[4];
  
 -              if (bcm47xx_nvram_getenv("et_swtype", buf, 1) > 0) {
@@ -188,15 +186,6 @@ patches for bgmac backported from net-next/master
  
 --- a/drivers/net/ethernet/broadcom/bgmac.h
 +++ b/drivers/net/ethernet/broadcom/bgmac.h
-@@ -333,7 +333,7 @@
- #define BGMAC_CHIPCTL_1_IF_TYPE_MASK          0x00000030
- #define BGMAC_CHIPCTL_1_IF_TYPE_RMII          0x00000000
--#define BGMAC_CHIPCTL_1_IF_TYPE_MI            0x00000010
-+#define BGMAC_CHIPCTL_1_IF_TYPE_MII           0x00000010
- #define BGMAC_CHIPCTL_1_IF_TYPE_RGMII         0x00000020
- #define BGMAC_CHIPCTL_1_SW_TYPE_MASK          0x000000C0
- #define BGMAC_CHIPCTL_1_SW_TYPE_EPHY          0x00000000
 @@ -384,6 +384,8 @@ struct bgmac_dma_ring {
        u16 mmio_base;
        struct bgmac_dma_desc *cpu_base;
index fd4ffb24b94e5c2bb20b442a67760bc33cfb47d8..9195c2c95d57b57bdd9d7f8ec30648b3271d6d17 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=ext4 rtc usb gpio
 CPU_TYPE:=arm926ej-s
 
 MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
-LINUX_VERSION:=3.10.13
+LINUX_VERSION:=3.10.15
 KERNELNAME:="zImage dtbs"
 
 define Target/Description
index 3af424e64c3b95c8c805122d1af637518e5b66b0..4a9bc8cb3cf1f8263a9bf29309c6e1d0aa92a179 100644 (file)
@@ -14,7 +14,7 @@ CPU_TYPE:=cortex-a9
 CPU_SUBTYPE:=vfpv3
 MAINTAINER:=Luka Perkov <luka@openwrt.org>
 
-LINUX_VERSION:=3.10.13
+LINUX_VERSION:=3.10.15
 
 include $(INCLUDE_DIR)/target.mk
 
index 86acd347a8035fedfc6fb00dcefa07011eaa849f..470f46f37b5a39f8a19b954915fca3d83e0d1aa7 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 SUBTARGETS=generic harddisk
 
-LINUX_VERSION:=3.10.13
+LINUX_VERSION:=3.10.15
 
 include $(INCLUDE_DIR)/target.mk
 
index 9ac2a13b3e85b3825932ab557ed2148966673b6a..714c1a00aed63aa0cc8942c1a3b8230dfe6e5481 100644 (file)
@@ -11,7 +11,7 @@ BOARDNAME:=Lantiq GPON/XWAY/SVIP
 FEATURES:=squashfs
 SUBTARGETS=xway xrx200 ase falcon
 
-LINUX_VERSION:=3.10.13
+LINUX_VERSION:=3.10.15
 
 CPU_TYPE:=mips32r2
 
index 853013a41e3ef8a31cb5a04d8f03c9e8f2bc0ae7..362069bbc2a8297f6c6a7bc2e42df67afccf2e06 100644 (file)
@@ -12,7 +12,7 @@ SUBTARGETS:=le be le64 be64
 INITRAMFS_EXTRA_FILES:=
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.10.13
+LINUX_VERSION:=3.10.15
 
 DEVICE_TYPE:=developerboard
 
index bbb9c01a6aadded6eeee8ad2443a926f86815597..c6d971d2d3fb3e72c898452c441d01b1673899a5 100644 (file)
@@ -14,7 +14,7 @@ FEATURES:=spe_fpu squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 SUBTARGETS=generic p1020
 
-LINUX_VERSION:=3.10.13
+LINUX_VERSION:=3.10.15
 
 include $(INCLUDE_DIR)/target.mk
 
index 611cafbb5127425a4eae5e8c25216c7e58ae2049..6794f5c8079dfa947c5a60610ea57d2c1424c074 100644 (file)
@@ -14,7 +14,7 @@ CPU_TYPE:=cortex-a9
 CPU_SUBTYPE:=vfpv3
 MAINTAINER:=Luka Perkov <luka@openwrt.org>
 
-LINUX_VERSION:=3.10.13
+LINUX_VERSION:=3.10.15
 
 include $(INCLUDE_DIR)/target.mk
 
index a861ca23b49340c5b1388dda36c81107c9e55191..2b03cd36cc24350c332935c5a597649abee8e7fb 100644 (file)
@@ -14,7 +14,7 @@ CPU_TYPE:=octeon
 CPU_CFLAGS_octeon:=-march=octeon
 MAINTAINER:=John Crispin <blogic@openwrt.org>
 
-LINUX_VERSION:=3.10.13
+LINUX_VERSION:=3.10.15
 
 include $(INCLUDE_DIR)/target.mk
 
index cac70d8959a0dbabedf1e1b79827e97ca62af7ad..560e7123c36ab37e7026e2d5fe56907e5d6e258b 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 CPU_TYPE:=405
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.10.13
+LINUX_VERSION:=3.10.15
 
 include $(INCLUDE_DIR)/target.mk
 
index 78e840e765f3b4d5a904be22f2cae3c5bc90f448..fef3408c29fd93bc65479b00c1887298bce09097 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs broken
 CPU_TYPE:=440
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.10.13
+LINUX_VERSION:=3.10.15
 
 include $(INCLUDE_DIR)/target.mk
 
index fec7ddbc9319ec2a3c3c2e1d2e13a002bbc0e2c9..a1d209f90ae2ca0b5a2f9bc647d66eba1968163f 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Ralink RT288x/RT3xxx
 SUBTARGETS:=rt305x rt3883 mt7620a rt288x
 FEATURES:=squashfs gpio
 
-LINUX_VERSION:=3.10.13
+LINUX_VERSION:=3.10.15
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES+=\
index c37123ad47a127446bee70e8cdc2f6cda1a2cc13..24b3d4c79199627adf6bd2d6b994a9f49b89e2bb 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=rb532
 BOARDNAME:=Mikrotik RouterBoard 532
 FEATURES:=pci targz broken
 
-LINUX_VERSION:=3.10.13
+LINUX_VERSION:=3.10.15
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532
index ee5dfc51b84d5c146554262aeb3ad98b3306485f..a7ca205ee46f409d06559df5b7d27663b5a149a3 100644 (file)
@@ -14,7 +14,7 @@ CPU_TYPE:=mpcore
 CPU_SUBTYPE:=vfp
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.10.13
+LINUX_VERSION:=3.10.15
 
 DEVICE_TYPE:=developerboard
 
index 0de518b45b7b59654202244eddcf87b7c98589a5..ea655142cdabe9be88becfad1f21c10c1c26d0a8 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Ingenic XBurst
 FEATURES:=targz ubifs audio
 SUBTARGETS:=qi_lb60 n516 n526 id800wt
 
-LINUX_VERSION:=3.10.13
+LINUX_VERSION:=3.10.15
 
 DEVICE_TYPE=other