fix ar7 image installation (patch by sw, fixes #2197)
authorFelix Fietkau <nbd@openwrt.org>
Fri, 10 Aug 2007 22:37:28 +0000 (22:37 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 10 Aug 2007 22:37:28 +0000 (22:37 +0000)
SVN-Revision: 8393

target/linux/ar7-2.6/image/Makefile

index 33324cd365ab87388f04ffe529344192bfd9023a..27af16553397282338b2a5a1973f69754bb3dd33 100644 (file)
@@ -64,7 +64,7 @@ endef
 
 define Image/Build
        dd if=$(KDIR)/loader.bin $(call align/$(1)) > $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).bin
-       cat $(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)/root.$(1) >> $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).bin
+       cat $(KDIR)/root.$(1) >> $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).bin
        $(call prepare_generic_squashfs,$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).bin)
        $(call Image/Build/CyberTAN,$(1),AG1B,AG1B,$(1))
        $(call Image/Build/CyberTAN,$(1),WA21,WA21,$(1))