kernel: add a module for the isl1208 rtc
authorFelix Fietkau <nbd@openwrt.org>
Sun, 6 Jan 2013 15:09:43 +0000 (15:09 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 6 Jan 2013 15:09:43 +0000 (15:09 +0000)
SVN-Revision: 35022

package/kernel/modules/other.mk

index 1c8a3dcfef61bbb9ba247490037e7e06f75c1ca6..ddaef8d9015c75b0d4ad1092e746595bad51b9a9 100644 (file)
@@ -539,6 +539,23 @@ endef
 $(eval $(call KernelPackage,pwm-gpio))
 
 
 $(eval $(call KernelPackage,pwm-gpio))
 
 
+define KernelPackage/rtc-isl1208
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Intersil ISL1208 RTC support
+  $(call AddDepends/rtc)
+  DEPENDS+=+kmod-i2c-core
+  KCONFIG:=CONFIG_RTC_DRV_ISL1208
+  FILES:=$(LINUX_DIR)/drivers/rtc/rtc-isl1208.ko
+  AUTOLOAD:=$(call AutoLoad,60,rtc-isl1208)
+endef
+
+define KernelPackage/rtc-isl1208/description
+ Kernel module for Intersil ISL1208 RTC.
+endef
+
+$(eval $(call KernelPackage,rtc-isl1208))
+
+
 define KernelPackage/rtc-marvell
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Marvell SoC built-in RTC support
 define KernelPackage/rtc-marvell
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Marvell SoC built-in RTC support