add documentation for /etc/config/wireless and improve formatting
authorFelix Fietkau <nbd@openwrt.org>
Mon, 16 Oct 2006 02:38:08 +0000 (02:38 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 16 Oct 2006 02:38:08 +0000 (02:38 +0000)
SVN-Revision: 5149

docs/Makefile
docs/config.tex
docs/openwrt.tex
docs/wireless.tex [new file with mode: 0644]

index 0a4128754bf5ba769449c0e897fca12f21332d03..8ee46807988b35c7800488aeb0210bd51fe15f1c 100644 (file)
@@ -1,4 +1,4 @@
-openwrt.pdf: Makefile openwrt.tex config.tex network.tex network-scripts.tex
+openwrt.pdf: Makefile openwrt.tex config.tex network.tex network-scripts.tex network-scripts.tex wireless.tex
        $(MAKE) cleanup
        pdflatex openwrt.tex
        pdflatex openwrt.tex
index 44b6689b538034b6482026b5d8acc95d29a40ca2..acb4bdf857742ae6490bd71e3970e36b28634e3a 100644 (file)
@@ -9,8 +9,8 @@ it was written under.
 Syntax:
 
 \begin{Verbatim}
-config    <type> [<name>]           # Section
-  option  <name>  <value>      # Option
+config      <type> [<name>]         # Section
+    option  <name>  <value>      # Option
 \end{Verbatim}
 
 Every parameter needs to be a single string and is formatted exactly
index ff58169f3f32331e6ce1ffbf2a7eaf13b073a467..f1269e296a9e4661957756b58f40505f79ce3b51 100644 (file)
 \tableofcontents
 
 \chapter{The Router}
-\section{Getting started}
-\subsection{Installation}
-\subsection{Initial configuration}
-\subsection{Failsafe mode}
-\section{Configuring OpenWrt}
-\subsection{Network}
-\include{network}
-
-\subsection{Wireless}
-
-\section{Advanced configuration}
-\include{config}
-
-\subsection{Hotplug}
-\subsection{Init scripts}
-\include{init-scripts}
-\subsection{Network scripts}
-\include{network-scripts}
-
+  \section{Getting started}
+    \subsection{Installation}
+    \subsection{Initial configuration}
+    \subsection{Failsafe mode}
+  \section{Configuring OpenWrt}
+    \subsection{Network}
+      \input{network}
+    \subsection{Wireless}
+      \input{wireless}
+  \section{Advanced configuration}
+    \input{config}
+    \subsection{Hotplug}
+    \subsection{Init scripts}
+      \input{init-scripts}
+    \subsection{Network scripts}
+      \input{network-scripts}
 \chapter{Development issues}
-\section{The build system}
-\subsection{Building an image}
-\subsection{Integrating packages}
-\subsection{Creating packages}
-
-\section{Extra tools}
-\subsection{Image Builder}
-\subsection{SDK}
-
-\section{Adding platform support}
-\section{Debugging and debricking}
-\subsection{Adding a serial port}
-\subsection{JTAG}
-
+  \section{The build system}
+    \subsection{Building an image}
+    \subsection{Integrating packages}
+    \subsection{Creating packages}
+  \section{Extra tools}
+    \subsection{Image Builder}
+    \subsection{SDK}
+  \section{Adding platform support}
+  \section{Debugging and debricking}
+    \subsection{Adding a serial port}
+    \subsection{JTAG}
 
 \end{document}
diff --git a/docs/wireless.tex b/docs/wireless.tex
new file mode 100644 (file)
index 0000000..279ee55
--- /dev/null
@@ -0,0 +1,103 @@
+The WiFi settings are configured in the file \texttt{/etc/config/wireless}
+(currently supported on Broadcom only). When booting the router for the first time
+it should detect your card and create a sample configuration that looks like this:
+
+\begin{Verbatim}
+config wifi-device  wl0
+    option type     broadcom
+    option channel  5
+
+config wifi-iface
+    option device   wl0
+    option mode     ap
+    option ssid     OpenWrt
+    option hidden   0
+    option encryption none
+\end{Verbatim}
+
+There are two types of config sections in this file. The '\texttt{wifi-device}' refers to
+the physical wifi interface and '\texttt{wifi-iface}' configures a virtual interface on top
+of that (if supported by the driver).
+
+\paragraph{Options for the \texttt{wifi-device}:}
+
+\begin{itemize}
+       \item \texttt{type} \\
+               The driver to use for this interface.
+       
+       \item \texttt{country} \\
+               The country code used to determine the regulatory settings.
+       
+       \item \texttt{channel} \\
+               The wifi channel (1-14, depending on your country setting).
+
+       \item \texttt{maxassoc} \\
+               Maximum number of associated clients
+
+\end{itemize}
+
+\paragraph{Options for the \texttt{wifi-iface}:}
+
+\begin{itemize}
+       \item \texttt{mode} \\
+               Operating mode:
+               
+               \begin{itemize}
+                       \item \texttt{ap} \\
+                               Access point mode
+
+                       \item \texttt{sta} \\
+                               Client mode
+
+                       \item \texttt{adhoc} \\
+                               Ad-Hoc mode
+
+                       \item \texttt{wds} \\
+                               WDS point-to-point link
+                               
+               \end{itemize}
+       \item \texttt{network} \\
+               Selects the interface section from \texttt{/etc/config/network} to be
+               used with this interface
+
+       \item \texttt{encryption} \\
+               Encryption setting. Accepts the following values:
+               
+               \begin{itemize}
+                       \item \texttt{psk}, \texttt{psk2} \\
+                               WPA(2) Pre-shared Key
+                               
+                       \item \texttt{wpa}, \texttt{wpa2} \\
+                               WPA(2) RADIUS
+                               
+               \end{itemize}
+               
+       \item \texttt{key} (wpa and psk) \\
+               Either the WPA key (PSK mode) or the RADIUS shared secret (WPA RADIUS mode)
+
+       \item \texttt{server} (wpa) \\
+               The RADIUS server address
+
+       \item \texttt{port} (wpa) \\
+               The RADIUS server port
+
+\end{itemize}
+
+\paragraph{Limitations:}
+
+\begin{itemize}
+       \item \textbf{Broadcom}: \\
+               Only the following mode combinations are supported:
+               
+               \begin{itemize}
+                       \item 1x \texttt{sta}, 0-3x \texttt{ap}
+                       \item 1-4x \texttt{ap}
+                       \item 1x \texttt{adhoc}
+               \end{itemize}
+
+               WDS links can only be used in pure AP mode and can't use WEP (except when sharing the
+               settings with the master interface, which is done automatically).
+
+\end{itemize}
+
+