kernel: adjust orion/kirkwood packages to also build for mvebu target
authorFlorian Fainelli <florian@openwrt.org>
Tue, 8 Jan 2013 22:20:21 +0000 (22:20 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 8 Jan 2013 22:20:21 +0000 (22:20 +0000)
Armada XP/370 boards share these hardware blocks with Orion and Kirkwood
SoCs.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 35059

package/kernel/modules/crypto.mk
package/kernel/modules/i2c.mk
package/kernel/modules/other.mk

index 02e3f68b0cca361ca07ce14e3435a5b9491a8a78..221b5a0e4ebd3ac68ac09eb2827bce91e947d0dc 100644 (file)
@@ -486,7 +486,7 @@ $(eval $(call KernelPackage,crypto-xts))
 
 define KernelPackage/crypto-mv-cesa
   TITLE:=Marvell crypto engine
 
 define KernelPackage/crypto-mv-cesa
   TITLE:=Marvell crypto engine
-  DEPENDS:=+kmod-crypto-manager +kmod-crypto-aes @TARGET_kirkwood||TARGET_orion
+  DEPENDS:=+kmod-crypto-manager +kmod-crypto-aes @TARGET_kirkwood||TARGET_orion||TARGET_mvebu
   KCONFIG:=CONFIG_CRYPTO_DEV_MV_CESA
   FILES:=$(LINUX_DIR)/drivers/crypto/mv_cesa.ko
   AUTOLOAD:=$(call AutoLoad,09,mv_cesa)
   KCONFIG:=CONFIG_CRYPTO_DEV_MV_CESA
   FILES:=$(LINUX_DIR)/drivers/crypto/mv_cesa.ko
   AUTOLOAD:=$(call AutoLoad,09,mv_cesa)
index 0a4982010c89bd7101c791c8c43383e8f96d7edf..2ee73bfca9dcc13391eafc324e138f69dde2fbef 100644 (file)
@@ -154,11 +154,11 @@ I2C_MV64XXX_MODULES:=\
 define KernelPackage/i2c-mv64xxx
   $(call i2c_defaults,$(I2C_MV64XXX_MODULES),59)
   TITLE:=Orion Platform I2C interface support
 define KernelPackage/i2c-mv64xxx
   $(call i2c_defaults,$(I2C_MV64XXX_MODULES),59)
   TITLE:=Orion Platform I2C interface support
-  DEPENDS:=@TARGET_kirkwood||TARGET_orion +kmod-i2c-core
+  DEPENDS:=@TARGET_kirkwood||TARGET_orion||TARGET_mvebu +kmod-i2c-core
 endef
 
 define KernelPackage/i2c-mv64xxx/description
 endef
 
 define KernelPackage/i2c-mv64xxx/description
- Kernel module for I2C interface on the Kirkwood and Orion
+ Kernel module for I2C interface on the Kirkwood, Orion and Armada XP/370
  family processors.
 endef
 
  family processors.
 endef
 
index 5d3e00a87f26cf6af09fd9619c92b15117ad58a6..d4983a324335cb6f089c0429fb89444641fa34c9 100644 (file)
@@ -479,14 +479,14 @@ $(eval $(call KernelPackage,wdt-omap))
 define KernelPackage/wdt-orion
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Marvell Orion Watchdog timer
 define KernelPackage/wdt-orion
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Marvell Orion Watchdog timer
-  DEPENDS:=@TARGET_orion||@TARGET_kirkwood
+  DEPENDS:=@TARGET_orion||TARGET_kirkwood||TARGET_mvebu
   KCONFIG:=CONFIG_ORION_WATCHDOG
   FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/orion_wdt.ko
   AUTOLOAD:=$(call AutoLoad,50,orion_wdt)
 endef
 
 define KernelPackage/wdt-orion/description
   KCONFIG:=CONFIG_ORION_WATCHDOG
   FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/orion_wdt.ko
   AUTOLOAD:=$(call AutoLoad,50,orion_wdt)
 endef
 
 define KernelPackage/wdt-orion/description
-  Kernel module for Marvell orion watchdog timer.
+  Kernel module for Marvell Orion, Kirkwood and Armada XP/370 watchdog timer.
 endef
 
 $(eval $(call KernelPackage,wdt-orion))
 endef
 
 $(eval $(call KernelPackage,wdt-orion))