don't overwrite .config if it's a symlink (fixes scripts/env problems)
authorFelix Fietkau <nbd@openwrt.org>
Sat, 18 Oct 2008 19:37:34 +0000 (19:37 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 18 Oct 2008 19:37:34 +0000 (19:37 +0000)
SVN-Revision: 13005

include/toplevel.mk

index 9d0eb2593356c80d1cd45a455fef2cb96bda4325..ab4448ae1047411414aeca5fcf748c94d447ce5c 100644 (file)
@@ -48,7 +48,7 @@ prepare-tmpinfo: FORCE
        touch $(TOPDIR)/tmp/.build
 
 .config: ./scripts/config/conf prepare-tmpinfo $(if $(CONFIG_HAVE_DOT_CONFIG),,FORCE)
-       @+if [ \! -f .config ] || ! grep CONFIG_HAVE_DOT_CONFIG .config >/dev/null; then \
+       @+if [ \! -e .config ] || ! grep CONFIG_HAVE_DOT_CONFIG .config >/dev/null; then \
                [ -e $(HOME)/.openwrt/defconfig ] && cp $(HOME)/.openwrt/defconfig .config; \
                $(_SINGLE)$(NO_TRACE_MAKE) menuconfig $(PREP_MK); \
        fi