sdk: clean scripts/config before packing tarball (FS#504)
authorFelix Fietkau <nbd@nbd.name>
Mon, 13 Feb 2017 10:45:43 +0000 (11:45 +0100)
committerFelix Fietkau <nbd@nbd.name>
Mon, 13 Feb 2017 10:46:14 +0000 (11:46 +0100)
Avoids shipping potentially incompatible object files and also reduces
the tarball size

Signed-off-by: Felix Fietkau <nbd@nbd.name>
target/sdk/Makefile

index 719b659d2518e4caadfcd295ee0f7bbac43c85cd..ecaa0155950ee32f33cc2712ec0afec3256f3a57 100644 (file)
@@ -137,6 +137,7 @@ $(BIN_DIR)/$(SDK_NAME).tar.xz: clean
        find $(SDK_BUILD_DIR) -name .git | $(XARGS) rm -rf
        find $(SDK_BUILD_DIR) -name .svn | $(XARGS) rm -rf
        find $(SDK_BUILD_DIR) -name CVS | $(XARGS) rm -rf
+       -make -C $(SDK_BUILD_DIR)/scripts/config clean
        (cd $(BUILD_DIR); \
                tar -I 'xz -7e' -cf $@ $(SDK_NAME); \
        )