avr32: optimize image generation
authorGabor Juhos <juhosg@openwrt.org>
Wed, 25 Sep 2013 19:32:34 +0000 (19:32 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Wed, 25 Sep 2013 19:32:34 +0000 (19:32 +0000)
 - remove the kernel+rootfs partitions from the MTD partition map,
 - use a temporary directory for intermediate image files,
 - append the root squashfs directly to the kernel,
 - don't hardcode uImage size in the jffs2 images,

Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 38194

target/linux/avr32/image/Makefile
target/linux/avr32/patches-3.10/110-openwrt_flashmap.patch

index ad53572dba8ecf683e869974f18951796057737f..99761c6da56616e0222d5057470a5995e9a7d973 100644 (file)
@@ -7,6 +7,8 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
+KDIR_TMP:=$(KDIR)/tmp
+
 ifneq ($(CONFIG_AVR32_UBOOT),)
   define Build/Clean
        $(MAKE) -C u-boot clean
@@ -18,6 +20,7 @@ ifneq ($(CONFIG_AVR32_UBOOT),)
 endif
 
 define Image/BuildKernel
+       -mkdir -p $(KDIR_TMP)
        cp $(KDIR)/uImage $(BIN_DIR)/$(IMG_PREFIX)-uImage
 
        $(STAGING_DIR_HOST)/bin/lzma e $(LINUX_DIR)/arch/avr32/boot/images/vmlinux.bin $(KDIR)/vmlinux.lzma
@@ -34,16 +37,17 @@ define Image/Build
 endef
 
 define Image/Build/squashfs
-       $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
        ( \
-               dd if=$(KDIR)/uImage-lzma bs=1024k conv=sync; \
-               dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
-       ) > $(BIN_DIR)/$(IMG_PREFIX)-$(1).img
+               cat $(KDIR)/uImage-lzma; \
+               cat $(KDIR)/root.squashfs; \
+       ) > $(KDIR_TMP)/avr32-squahsfs.img
+       padjffs2 $(KDIR_TMP)/avr32-squahsfs.img 64
+       dd if=$(KDIR_TMP)/avr32-squahsfs.img of=$(BIN_DIR)/$(IMG_PREFIX)-$(1).img bs=64k conv=sync
 endef
 
 define Image/Build/jffs2-64k
        ( \
-               dd if=$(KDIR)/uImage-lzma bs=1024k conv=sync; \
+               dd if=$(KDIR)/uImage-lzma bs=64k conv=sync; \
                dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
        ) > $(BIN_DIR)/$(IMG_PREFIX)-$(1).img
 endef
index 3f87699b04bd13f3d5d3aa4174245ae54dc7466e..876eb71c4949304556cdd94f95a61cf0111a84cf 100644 (file)
@@ -1,31 +1,11 @@
 --- a/arch/avr32/boards/atngw100/flash.c
 +++ b/arch/avr32/boards/atngw100/flash.c
-@@ -45,9 +45,14 @@ static struct mtd_partition flash_parts[
+@@ -45,7 +45,7 @@ static struct mtd_partition flash_parts[
                .mask_flags     = MTD_WRITEABLE,
        },
        {
 -              .name           = "root",
-+              .name           = "kernel",
++              .name           = "firmware",
                .offset         = 0x00020000,
--              .size           = 0x007d0000,
-+              .size           = 0x00100000,
-+      },
-+      {
-+              .name           = "rootfs",
-+              .offset         = 0x00120000,
-+              .size           = 0x006d0000,
+               .size           = 0x007d0000,
        },
-       {
-               .name           = "env",
-@@ -55,6 +60,11 @@ static struct mtd_partition flash_parts[
-               .size           = 0x00010000,
-               .mask_flags     = MTD_WRITEABLE,
-       },
-+      {
-+              .name           = "firmware",
-+              .offset         = 0x00020000,
-+              .size           = 0x007d0000,
-+      },
- };
- static struct physmap_flash_data flash_data = {