fixup linux-atm package after the broken patch earlier
authorTravis Kemen <thepeople@openwrt.org>
Mon, 15 Mar 2010 03:59:14 +0000 (03:59 +0000)
committerTravis Kemen <thepeople@openwrt.org>
Mon, 15 Mar 2010 03:59:14 +0000 (03:59 +0000)
SVN-Revision: 20225

package/linux-atm/Makefile
package/linux-atm/patches/200-no_libfl.patch [deleted file]

index 3321425ed5199b1d6aad46114972955511553196..0e469c7a7fc625e4c429de2a43303d8c47cd9601 100644 (file)
@@ -46,7 +46,10 @@ define Build/Prepare
 endef
 
 define Build/Configure
-       $(call Build/Configure/Default)
+       (cd $(PKG_BUILD_DIR); \
+               ./configure \
+       )
+       #$(call Build/Configure/Default)
        # prevent autoheader invocation
        touch $(PKG_BUILD_DIR)/stamp-h.in
 endef
@@ -60,22 +63,22 @@ endef
 ifneq ($(CONFIG_PACKAGE_linux-atm),)
   define Build/InstallDev
        mkdir -p $(1)/usr/include
-       $(CP)   $(PKG_INSTALL_DIR)/usr/include/atm{,d,sap}.h \
+       $(CP)   $(PKG_BUILD_DIR)/src/include/atm{,d,sap}.h \
                $(1)/usr/include/
        mkdir -p $(1)/usr/lib
-       $(CP)   $(PKG_INSTALL_DIR)/usr/lib/libatm.{a,so*} \
+       $(CP)   $(PKG_BUILD_DIR)/src/lib/.libs/libatm.{a,so*} \
                $(1)/usr/lib/
   endef
 endif
 
 define Package/linux-atm/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libatm.so.* $(1)/usr/lib/
+       $(CP) $(PKG_BUILD_DIR)/src/lib/.libs/libatm.so.* $(1)/usr/lib/
 endef
 
 define Package/atm-tools/install
        $(INSTALL_DIR) $(1)/usr/sbin/
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/atmarp{,d} $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/arpd/atmarp{,d} $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/lib/network
        $(INSTALL_BIN) ./files/ipoa.sh $(1)/lib/network/
        $(INSTALL_DIR) $(1)/usr/bin/
diff --git a/package/linux-atm/patches/200-no_libfl.patch b/package/linux-atm/patches/200-no_libfl.patch
deleted file mode 100644 (file)
index ea6bb05..0000000
+++ /dev/null
@@ -1,218 +0,0 @@
-Index: linux-atm-2.5.1/src/qgen/Makefile.am
-===================================================================
---- linux-atm-2.5.1.orig/src/qgen/Makefile.am  2010-02-27 01:36:10.156687492 +0100
-+++ linux-atm-2.5.1/src/qgen/Makefile.am       2010-02-27 01:36:23.388686762 +0100
-@@ -2,7 +2,7 @@
- qgen_SOURCES = common.c common.h file.c file.h first.c ql_y.y ql_l.l qgen.c \
-               qgen.h second.c third.c
--qgen_LDADD = -lfl
-+qgen_LDADD = 
- CC = @CC_FOR_BUILD@
- CFLAGS = @CFLAGS_FOR_BUILD@
-Index: linux-atm-2.5.1/src/qgen/Makefile.in
-===================================================================
---- linux-atm-2.5.1.orig/src/qgen/Makefile.in  2010-02-27 01:36:10.156687492 +0100
-+++ linux-atm-2.5.1/src/qgen/Makefile.in       2010-02-27 02:06:38.992684137 +0100
-@@ -58,7 +58,7 @@
- am__depfiles_maybe = depfiles
- am__mv = mv -f
- COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
--      $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
-+      $(AM_CFLAGS) $(CFLAGS)
- LTCOMPILE = $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) \
-       --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \
-       $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
-@@ -208,7 +208,7 @@
- qgen_SOURCES = common.c common.h file.c file.h first.c ql_y.y ql_l.l qgen.c \
-               qgen.h second.c third.c
--qgen_LDADD = -lfl
-+qgen_LDADD = 
- #TESTS = $(check_PROGRAMS)
- EXTRA_DIST = ql_y.h ql_y.c ql_l.c
-Index: linux-atm-2.5.1/src/qgen/ql_l.c
-===================================================================
---- linux-atm-2.5.1.orig/src/qgen/ql_l.c       2010-02-27 01:36:22.669685751 +0100
-+++ linux-atm-2.5.1/src/qgen/ql_l.c    2010-02-27 01:36:23.392683892 +0100
-@@ -514,6 +514,11 @@
- #include "qgen.h"
- #include "ql_y.h"
-+int yywrap(void)
-+{
-+        return 1;
-+}
-+
- typedef struct _tree {
-     struct _tree *left,*right;
-Index: linux-atm-2.5.1/src/sigd/cfg_l.c
-===================================================================
---- linux-atm-2.5.1.orig/src/sigd/cfg_l.c      2010-02-27 01:36:22.673681076 +0100
-+++ linux-atm-2.5.1/src/sigd/cfg_l.c   2010-02-27 01:36:23.392683892 +0100
-@@ -617,6 +617,10 @@
- #include "cfg_y.h"
-+int yywrap(void)
-+{
-+        return 1;
-+}
- static int lineno = 1;
- static int token; /* f@#%ing flex doesn't grok return after BEGIN */
-Index: linux-atm-2.5.1/src/sigd/Makefile.am
-===================================================================
---- linux-atm-2.5.1.orig/src/sigd/Makefile.am  2010-02-27 01:36:10.160686786 +0100
-+++ linux-atm-2.5.1/src/sigd/Makefile.am       2010-02-27 01:36:23.392683892 +0100
-@@ -8,7 +8,7 @@
-                       $(top_builddir)/src/q2931/qd.dump.o \
-                       $(top_builddir)/src/lib/libatm.la \
-                       $(top_builddir)/src/saal/libsaal.a
--atmsigd_LDADD = $(atmsigd_XTRAS) -lfl
-+atmsigd_LDADD = $(atmsigd_XTRAS) 
- atmsigd_DEPENDENCIES = mess.c $(atmsigd_XTRAS)
- CLEANFILES = mess.c
-Index: linux-atm-2.5.1/src/sigd/Makefile.in
-===================================================================
---- linux-atm-2.5.1.orig/src/sigd/Makefile.in  2010-02-27 01:36:10.160686786 +0100
-+++ linux-atm-2.5.1/src/sigd/Makefile.in       2010-02-27 01:36:23.396685195 +0100
-@@ -244,7 +244,7 @@
-                       $(top_builddir)/src/lib/libatm.la \
-                       $(top_builddir)/src/saal/libsaal.a
--atmsigd_LDADD = $(atmsigd_XTRAS) -lfl
-+atmsigd_LDADD = $(atmsigd_XTRAS) 
- atmsigd_DEPENDENCIES = mess.c $(atmsigd_XTRAS)
- CLEANFILES = mess.c
- sysconf_DATA = atmsigd.conf
-Index: linux-atm-2.5.1/src/switch/debug/debug.c
-===================================================================
---- linux-atm-2.5.1.orig/src/switch/debug/debug.c      2010-02-27 01:36:10.160686786 +0100
-+++ linux-atm-2.5.1/src/switch/debug/debug.c   2010-02-27 01:36:23.396685195 +0100
-@@ -20,6 +20,11 @@
- #define PRV(call) ((FAB *) (call)->fab)
-+int yywrap(void)
-+{
-+        return 1;
-+}
-+
- typedef struct _fab {
-     CALL *next; /* relay.c may not keep track of calls, but WE are */
-Index: linux-atm-2.5.1/src/switch/debug/Makefile.am
-===================================================================
---- linux-atm-2.5.1.orig/src/switch/debug/Makefile.am  2010-02-27 01:36:10.164686879 +0100
-+++ linux-atm-2.5.1/src/switch/debug/Makefile.am       2010-02-27 01:36:23.396685195 +0100
-@@ -5,7 +5,7 @@
- sw_debug_SOURCES = debug.c
- sw_debug_XTRAS = $(top_builddir)/src/switch/libsw.a \
-                       $(top_builddir)/src/lib/libatm.la
--sw_debug_LDADD = $(sw_debug_XTRAS) -lfl
-+sw_debug_LDADD = $(sw_debug_XTRAS) 
-                       
- sw_debug_DEPENDENCIES = $(sw_debug_XTRAS)
-Index: linux-atm-2.5.1/src/switch/debug/Makefile.in
-===================================================================
---- linux-atm-2.5.1.orig/src/switch/debug/Makefile.in  2010-02-27 01:36:10.164686879 +0100
-+++ linux-atm-2.5.1/src/switch/debug/Makefile.in       2010-02-27 01:36:23.396685195 +0100
-@@ -199,7 +199,8 @@
- sw_debug_XTRAS = $(top_builddir)/src/switch/libsw.a \
-                       $(top_builddir)/src/lib/libatm.la
--sw_debug_LDADD = $(sw_debug_XTRAS) -lfl
-+sw_debug_LDADD = $(sw_debug_XTRAS)
-+
- sw_debug_DEPENDENCIES = $(sw_debug_XTRAS)
- EXTRA_DIST = demo README
- all: all-am
-Index: linux-atm-2.5.1/src/switch/tcp/Makefile.am
-===================================================================
---- linux-atm-2.5.1.orig/src/switch/tcp/Makefile.am    2010-02-27 01:36:10.201682113 +0100
-+++ linux-atm-2.5.1/src/switch/tcp/Makefile.am 2010-02-27 01:36:23.412882977 +0100
-@@ -5,7 +5,7 @@
- sw_tcp_SOURCES = tcpsw.c
- sw_tcp_XTRAS = $(top_builddir)/src/switch/libsw.a \
-               $(top_builddir)/src/lib/libatm.la
--sw_tcp_LDADD = $(sw_tcp_XTRAS) -lfl
-+sw_tcp_LDADD = $(sw_tcp_XTRAS) 
- sw_tcp_DEPENDENCIES = $(sw_tcp_XTRAS)
- EXTRA_DIST = mkfiles README
-Index: linux-atm-2.5.1/src/switch/tcp/Makefile.in
-===================================================================
---- linux-atm-2.5.1.orig/src/switch/tcp/Makefile.in    2010-02-27 01:36:10.209681349 +0100
-+++ linux-atm-2.5.1/src/switch/tcp/Makefile.in 2010-02-27 01:36:23.417680887 +0100
-@@ -199,7 +199,7 @@
- sw_tcp_XTRAS = $(top_builddir)/src/switch/libsw.a \
-               $(top_builddir)/src/lib/libatm.la
--sw_tcp_LDADD = $(sw_tcp_XTRAS) -lfl
-+sw_tcp_LDADD = $(sw_tcp_XTRAS) 
- sw_tcp_DEPENDENCIES = $(sw_tcp_XTRAS)
- EXTRA_DIST = mkfiles README
- all: all-am
-Index: linux-atm-2.5.1/src/switch/tcp/tcpsw.c
-===================================================================
---- linux-atm-2.5.1.orig/src/switch/tcp/tcpsw.c        2010-02-27 01:36:10.221684444 +0100
-+++ linux-atm-2.5.1/src/switch/tcp/tcpsw.c     2010-02-27 01:36:23.428680415 +0100
-@@ -35,6 +35,10 @@
- #define MAX_PACKET (ATM_MAX_AAL5_PDU+sizeof(struct atmtcp_hdr))
- #define BUFFER_SIZE (MAX_PACKET*2)
-+int yywrap(void)
-+{
-+        return 1;
-+}
- typedef struct _table {
-     struct _link *out;        /* output port */
-Index: linux-atm-2.5.1/src/test/ispl_l.c
-===================================================================
---- linux-atm-2.5.1.orig/src/test/ispl_l.c     2010-02-27 01:36:22.677681892 +0100
-+++ linux-atm-2.5.1/src/test/ispl_l.c  2010-02-27 01:36:23.428680415 +0100
-@@ -629,6 +629,11 @@
- #include "isp.h"
- #include "ispl_y.h"
-+int yywrap(void)
-+{
-+      return 1;
-+}
-+
- static int lineno = 1;
-Index: linux-atm-2.5.1/src/test/Makefile.am
-===================================================================
---- linux-atm-2.5.1.orig/src/test/Makefile.am  2010-02-27 01:36:10.221684444 +0100
-+++ linux-atm-2.5.1/src/test/Makefile.am       2010-02-27 01:36:23.428680415 +0100
-@@ -20,7 +20,7 @@
- bw_SOURCES = bw.c
- isp_SOURCES = isp.c isp.h ispl_y.y ispl_l.l
- isp_XTRAS = $(LDADD)
--isp_LDADD = $(isp_XTRAS) -lfl
-+isp_LDADD = $(isp_XTRAS)
- isp_DEPENDENCIES = $(isp_XTRAS)
- window_SOURCES = window.c
-Index: linux-atm-2.5.1/src/test/Makefile.in
-===================================================================
---- linux-atm-2.5.1.orig/src/test/Makefile.in  2010-02-27 01:36:10.225688778 +0100
-+++ linux-atm-2.5.1/src/test/Makefile.in       2010-02-27 01:36:23.432685583 +0100
-@@ -282,7 +282,7 @@
- bw_SOURCES = bw.c
- isp_SOURCES = isp.c isp.h ispl_y.y ispl_l.l
- isp_XTRAS = $(LDADD)
--isp_LDADD = $(isp_XTRAS) -lfl
-+isp_LDADD = $(isp_XTRAS)
- isp_DEPENDENCIES = $(isp_XTRAS)
- window_SOURCES = window.c
- CLEANFILES = errnos.inc