optimize binaries for the rm5200 cpu present on cobalt, do not use the mips32 isa
authorFlorian Fainelli <florian@openwrt.org>
Wed, 7 Oct 2009 13:05:14 +0000 (13:05 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 7 Oct 2009 13:05:14 +0000 (13:05 +0000)
SVN-Revision: 17980

target/linux/cobalt/Makefile
toolchain/uClibc/config-0.9.30.1/mipsel.cobalt [new file with mode: 0644]

index 0ab1942c5148aa1633435dcca30c8f848df2a58b..10dcf45794180bd0fab9c3e4fd463c870936a39e 100644 (file)
@@ -10,6 +10,7 @@ ARCH:=mipsel
 BOARD:=cobalt
 BOARDNAME:=Cobalt Microservers
 FEATURES:=tgz pci ext2
+CFLAGS:=-O2 -pipe -mtune=r5000 -funit-at-a-time
 
 LINUX_VERSION:=2.6.30.8
 
diff --git a/toolchain/uClibc/config-0.9.30.1/mipsel.cobalt b/toolchain/uClibc/config-0.9.30.1/mipsel.cobalt
new file mode 100644 (file)
index 0000000..323b0aa
--- /dev/null
@@ -0,0 +1,17 @@
+ARCH_ANY_ENDIAN=y
+ARCH_CFLAGS="-mno-split-addresses"
+ARCH_LITTLE_ENDIAN=y
+ARCH_WANTS_LITTLE_ENDIAN=y
+# CONFIG_MIPS_ISA_1 is not set
+# CONFIG_MIPS_ISA_2 is not set
+CONFIG_MIPS_ISA_3=y
+# CONFIG_MIPS_ISA_4 is not set
+# CONFIG_MIPS_ISA_MIPS32 is not set
+# CONFIG_MIPS_ISA_MIPS32R2 is not set
+# CONFIG_MIPS_ISA_MIPS64 is not set
+# CONFIG_MIPS_N32_ABI is not set
+# CONFIG_MIPS_N64_ABI is not set
+CONFIG_MIPS_O32_ABI=y
+TARGET_ARCH="mips"
+TARGET_mips=y
+UCLIBC_HAS_FPU=y