padjffs2: link statically
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 10 Aug 2012 19:26:43 +0000 (19:26 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 10 Aug 2012 19:26:43 +0000 (19:26 +0000)
SVN-Revision: 33100

tools/padjffs2/Makefile
tools/padjffs2/src/Makefile

index a949ac062822aa959d87552f60171acf73ccb99f..3f033c0c2b8c488455c70a996d55235da8f6ba1a 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2011 OpenWrt.org
+# Copyright (C) 2011-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -18,6 +18,10 @@ define Host/Prepare
        find $(HOST_BUILD_DIR) -name .svn | $(XARGS) rm -rf
 endef
 
        find $(HOST_BUILD_DIR) -name .svn | $(XARGS) rm -rf
 endef
 
+define Host/Compile
+       $(MAKE) -C $(HOST_BUILD_DIR) LDFLAGS="-static"
+endef
+
 define Host/Configure
 endef
 
 define Host/Configure
 endef
 
index fe1a7aa628ddd0f82dfaeadc57beea6818465f74..45da8e5dbc37d4294e335644665589c3f041918e 100644 (file)
@@ -9,7 +9,7 @@ all: padjffs2
        $(CC) $(CFLAGS) $(WFLAGS) -c -o $@ $<
 
 padjffs2: $(padjffs2-objs)
        $(CC) $(CFLAGS) $(WFLAGS) -c -o $@ $<
 
 padjffs2: $(padjffs2-objs)
-       $(CC) -o $@ $(padjffs2-objs)
+       $(CC) $(LDFLAGS) -o $@ $(padjffs2-objs)
 
 clean:
        rm -f padjffs2 *.o
 
 clean:
        rm -f padjffs2 *.o