The Geos target (and probably others, like net5501) need to grab the new cs5535 gpio...
authorTravis Kemen <thepeople@openwrt.org>
Mon, 28 Mar 2011 01:18:58 +0000 (01:18 +0000)
committerTravis Kemen <thepeople@openwrt.org>
Mon, 28 Mar 2011 01:18:58 +0000 (01:18 +0000)
Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
SVN-Revision: 26330

target/linux/x86/geos/target.mk

index cfeffd742715045c5bdcb74f456ffd0da78ffc9f..faf616690b3b2d33f231935c4c343e1a5c407699 100644 (file)
@@ -1,8 +1,13 @@
 BOARDNAME:=Traverse Geos
 FEATURES:=squashfs jffs2 ext4 pci usb gpio
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.38)),1)
+  GEOS_GPIO:=gpio-cs5535-new
+else
+  GEOS_GPIO:=gpio-cs5535
+endif
 DEFAULT_PACKAGES += kmod-ata-via-sata \
             kmod-crypto-hw-geode kmod-crypto-ocf \
-            kmod-gpio-cs5535 kmod-gpio-nsc \
+            kmod-$(GEOS_GPIO) kmod-gpio-nsc \
             kmod-wdt-geode kmod-hwmon-core kmod-hwmon-lm90 \
             kmod-8139cp kmod-solos-pci \
             kmod-i2c-core kmod-i2c-gpio \
@@ -23,6 +28,6 @@ define Target/Description
     Build firmware images for Traverse Geos board
 endef
 
-define KernelPackage/gpio-cs5535/install
-     sed -i -r -e 's/$$$$$$$$/ mask=$(CS5535_MASK)/' $(1)/etc/modules.d/??-gpio-cs5535
+define KernelPackage/$(GEOS_GPIO)/install
+     sed -i -r -e 's/$$$$$$$$/ mask=$(CS5535_MASK)/' $(1)/etc/modules.d/??-$(GEOS_GPIO)
 endef