ar71xx: add profile and build image for the TP-Link TL-WR842N/ND v1 boards
authorGabor Juhos <juhosg@openwrt.org>
Mon, 13 Feb 2012 17:11:58 +0000 (17:11 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Mon, 13 Feb 2012 17:11:58 +0000 (17:11 +0000)
SVN-Revision: 30508

target/linux/ar71xx/generic/profiles/tp-link.mk
target/linux/ar71xx/image/Makefile

index e2b97212bc688dc5871f7a2e2ba814891c3d033b..96ff12ae74cd432c42c39376009580b4c36a2cd5 100644 (file)
@@ -127,6 +127,17 @@ endef
 $(eval $(call Profile,TLWR841))
 
 
+define Profile/TLWR842
+       NAME:=TP-LINK TL-WR842N/ND
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/TLWR842/Description
+       Package set optimized for the TP-LINK TL-WR842N/ND.
+endef
+$(eval $(call Profile,TLWR842))
+
+
 define Profile/TLWR941
        NAME:=TP-LINK TL-WR941N/ND
        PACKAGES:=
index f923efc37085a36c41fe0c6438e47ff6b2c20547..86e279f0a7de1c2c95b09987ce898347d6cbfbd5 100644 (file)
@@ -892,6 +892,11 @@ define Image/Build/Profile/TLWR841
        $(call Image/Build/Template/$(fs_64kraw)/$(1),TPLINK,tl-wr841nd-v7,$(tlwr841v7_cmdline),0x08410007,1,4M)
 endef
 
+tlwr842_cmdline=board=TL-MR3420 console=ttyS0,115200
+define Image/Build/Profile/TLWR842
+       $(call Image/Build/Template/$(fs_64kraw)/$(1),TPLINK,tl-wr842n-v1,$(tlwr842_cmdline),0x08420001,1,8M)
+endef
+
 tlwr941v2_cmdline=board=TL-WR941ND console=ttyS0,115200
 tlwr941v4_cmdline=board=TL-WR741ND console=ttyS0,115200
 define Image/Build/Profile/TLWR941
@@ -1034,6 +1039,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/TLWR741,$(1))
        $(call Image/Build/Profile/TLWR743,$(1))
        $(call Image/Build/Profile/TLWR841,$(1))
+       $(call Image/Build/Profile/TLWR842,$(1))
        $(call Image/Build/Profile/TLWR941,$(1))
        $(call Image/Build/Profile/TLWR1043,$(1))
        $(call Image/Build/Profile/TLWR2543,$(1))